Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Kismet does not see my wireless card...

  1. #1
    Junior Member thedp's Avatar
    Join Date
    Feb 2010
    Posts
    35

    Default Kismet does not see my wireless card...

    Hello again,

    I'm trying to run kismet from BT3 but I get the following error:
    Code:
    bt ~ # start-kismet-ng
    wlan0           Unknown         Unknown (MONITOR MODE NOT SUPPORTED)
    
    Sorry i could not identify any wlan interfaced
    i will exit now
    My card is recognized (wlan0) and even connected to a wireless network. Is that bug in BT3, or is it another Intel 3945 card issue.


    Thank you.


    P.S: Why can't I post anywhere else on the forums?

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  3. #3
    Junior Member thedp's Avatar
    Join Date
    Feb 2010
    Posts
    35

    Default

    I will try do this, but this might not be the best solution, since I'm using a liveCD, and I would to keep using a liveCD.


    Thank you.

  4. #4
    Junior Member thedp's Avatar
    Join Date
    Feb 2010
    Posts
    35

    Default

    Well that didn't work, I get too many errors. It asked me to install ieee80211, so I tried and got more errors. Are those kind of installations are supported using a liveCD?

  5. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by thedp View Post
    I'm trying to run kismet from BT3 but I get the following error:
    Code:
    bt ~ # start-kismet-ng
    wlan0 Unknown Unknown (MONITOR MODE NOT SUPPORTED)

    Sorry i could not identify any wlan interfaced
    i will exit now
    My card is recognized (wlan0) and even connected to a wireless network. Is that bug in BT3, or is it another Intel 3945 card issue.


    Thank you.


    P.S: Why can't I post anywhere else on the forums?
    It's telling you that that driver that's using wlan0 does not support "Monitor Mode"

    You have to load the ipwraw driver to change to monitor mode.

    After loading the ipwraw drivers run the command iwconfig to see if it uses wifi# or eth#, then configure the sources in the kismet.conf file accordingly.

    P.S. You have to wait three days before getting full member status... then you'll be able to post elsewhere on the forum
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  6. #6
    Junior Member thedp's Avatar
    Join Date
    Feb 2010
    Posts
    35

    Question

    Ok, I've tried to load the IP Raw driver, provided in the menu... But it's incorrect.
    So after a short lookup I've found this fix in backtrack wiki:
    Incorrect menu items

    Backtrack>Radio Network Analysis>80211>Misc

    Fix:

    * Load IPW 3945/4965

    Command: modprobe ipwraw && rmmod ipwraw & load && cd /root;sudo -s
    Workpath: /usr/src/drivers/iwlwifi-1.0.0/

    * Load IPWRAW

    Command: unload && modprobe ipwraw && cd /root;sudo -s
    Workpath: /usr/src/drivers/iwlwifi-1.0.0/


    -pureh@te confirmed -PrairieFire
    I executed the fix.

    Then I execute iwconfig, but this time my wlan0 interface was gone, and all was left is wifi0, so I set the source parameter in /usr/local/etc/kismet.conf to wifi0. But when I run kismet, it only gives me the following message:
    Code:
    bt ~ # start-kismet-ng
    
    Sorry i could not identify any wlan interfaced
    i will exit now
    Notice that now it no longer indicates any interface (wlan0).


    What should I do now?

  7. #7
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    7

    Unhappy same here

    I've got the same issue when trying to start Kismet with start-kismet-ng.

    I've even manually changed the /usr/local/etc/kismet.conf, made sure the card is in monitor mode (with airmon-ng) but then I get another error when starting with ./kismet:

    FATAL: Specifying a uid-0 user for the priv drop is pointless.

  8. #8
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by Calix View Post
    I've got the same issue when trying to start Kismet with start-kismet-ng.

    I've even manually changed the /usr/local/etc/kismet.conf, made sure the card is in monitor mode (with airmon-ng) but then I get another error when starting with ./kismet:
    Code:
    FATAL: Specifying a uid-0 user for the priv drop is pointless.
    This error has absolutely nothing to do with your card, and everything to do with suid privilege dropping in your kismet.conf file.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  9. #9
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by thedp View Post
    Code:
    bt ~ # start-kismet-ng
    
    Sorry i could not identify any wlan interfaced
    i will exit now
    Notice that now it no longer indicates any interface (wlan0).

    What should I do now?
    After loading IPWRAW

    Try:

    airmon-ng start wifi0
    then

    kismet
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  10. #10
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    7

    Default

    What you suggest .Lonewolf is what I've tried. first loading ipwraw, then using airmon-ng to put into monitor mode and start-kismet-ng. The result was the cannot find wireless interface error.

    Next added manually a SOURCE in the /usr/local/etc/kimset.conf.

    then again but started kismet by using "kismet" instead of start-kimset-ng: then the suid error appears...

    any ideas?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •