I was going to post this in the BT4 R1 post but its closed. But I have this wireless nic:

Adapter Vendor: Broadcom Corp
Adapter Name: BCM4309 802.11a/b/g

It works with Ubuntu and Xubuntu, both 9.10 and 10.04. The latest Linux Kernel I have used is 2.6.33 but BT4 has never worked with it. Maybe I'm doing something wrong when I try to activate it. I don't know. I really haven't used the KDE UI much. Anyways, since I see a lot of posts stating many Broadcom devices don't run on BT4 I decided to post this here so maybe it can be looked into for R1.