Results 1 to 8 of 8

Thread: Keeps booting my internal HD! Got BT on external HD

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default Keeps booting my internal HD! Got BT on external HD

    I've got BT3 installed on my external hard disk and Ubuntu on my internal HD! The problem i'm having is that when i'm booting backtrack as soon as it gets to mount part it keeps mount ubuntu and not BT3, i've disabled my harddrive in my bios BUT STILL it keeps on booting ubuntu!

    Here's my config from my external HD

    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/sdb
    #message = /boot/boot_message.txt
    prompt
    timeout = 1200
    append = "rootdelay=10 acpi=off"
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    image = /boot/vmlinuz
    root = /dev/sdb1
    label = Linu
    read-only
    # Linux bootable partition config ends

    It boots my ubuntu which is mounted on my sda1 partition on my internal HD.

  2. #2
    Member
    Join Date
    Sep 2008
    Posts
    306

    Default

    hi phil128,
    i've disabled my harddrive in my bios BUT STILL it keeps on booting ubuntu!
    Curious
    Are u sure you made lilo -v with right permissions?

    If so i've no clue whats going on.
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default

    Yeah it is! all i've done is followed the tutorial for installing BT on a External HD! The only changes i've made is to the timing for when it detects my HD (Otherwise i get an kernel panic). I don't know what the hell is wrong! I'll like to get it sorted tho, for me and other people who might of has problems! ****ED up tho cause even if i disable the HD from loading from the BIOS it still happens! SOOOO Stupid

    BTW thanks for the reply

  4. #4
    Member
    Join Date
    Apr 2007
    Posts
    155

    Default

    Well first off you don't need to disable your internal drive to boot to it. I'm assuming you have the external drive connected through USB, in which case can you boot to USB from the Boot Menu (the BIOS one)?!

    If not I would try adding the boot option for BackTrack to your GRUB bootloader.
    This is a hackers forum :P
    root ~# aircrack-ng pwnd-01.cap
    Lenovo Thinkpad R500, OS: Ubuntu 8.10, BackTrack3, Windows XP (VirtualBox), Windows Vista, Windows 7 beta

  5. #5
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default

    Thts what i do! I set my external one to boot first and it does! Its only when backtrack mounts the drives before the OS loads, thts where i'm having the problem!

    ----Boots BT3 off external > loads HD's > mounts Ubuntu----

    Thats basically whats happening!

    Weird as hell

  6. #6
    Member
    Join Date
    Sep 2008
    Posts
    306

    Default

    Quote Originally Posted by phil128 View Post
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/sdb
    #message = /boot/boot_message.txt
    prompt
    timeout = 1200
    append = "rootdelay=10 acpi=off"
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    image = /boot/vmlinuz
    root = /dev/sdb1
    label = Linu
    read-only
    # Linux bootable partition config ends

    It boots my ubuntu which is mounted on my sda1 partition on my internal HD.
    Hey, plz give this a try and report the results:
    Its only for an idea thats buzzing my brain

    Change "boot = /dev/sdb" to "boot = /dev/sda"
    Change "root = /dev/sdb1" to "root = /dev/sda1"
    Be sensitive in choosing where you ask your question. You are likely to be ignored, or written off as a loser, if you:

    * post your question to a forum where it's off topic
    * post a very elementary question to a forum where advanced technical questions are expected, or vice-versa
    * cross-post to too many different newsgroups
    * post a personal e-mail to somebody who is neither an acquaintance of yours nor personally responsible for solving your problem

  7. #7
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    You cant have 2 boot loaders. You have to add a entry to the grub menu for ubuntu and point it at the external drive.

  8. #8
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default

    LADS! This one is really weird! i've added extra 5 seconds to the "root mount" in lilo and it works!!! Weird tho cause i gave lilo 10 seconds before and even then it detected my "root mount" Very weird tho! an extra 5 seconds and BANG it works! So weird people!

    Thanks people for your help i hope this helps other people too!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •