Results 1 to 9 of 9

Thread: Alfa AWUS036H + wpa_supp. question

  1. #1
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    3

    Default Alfa AWUS036H + wpa_supp. question

    (I hope I post in the correct section etc. now...)

    Hello!

    Very nice distribution and a very nice forum. I've searched and got alot of answers for things I wondered about. TONS of information and nice guides!

    One thing that I didn't really find any answer to though was if anyone has problem connecting to WPA wlans with their ALfa AWUS036H?

    I have Backtrack installed to the harddrive.

    I assume not since I find no other complaint, but perhaps you see something I do not see in this picture. (When I attempt to connect . . .)
    I can successfully connect using the internal card on my laptop with wpa_supplicant, but not with the Alfa. I can connect to WEP with it though... so I know that its not broken or so.

    The messages I get, take a look please (cant post link):
    ladda-upp.com/bilder-a/wpa_cry-357.jpg

    I know very little about Linux (obviously).

    Thanks for any tip and help!

  2. #2
    Junior Member duwey96's Avatar
    Join Date
    Nov 2007
    Posts
    41

    Default

    try using a different driver with the -D command. You were trying wext, but your card may need to use a different one. Also try just not specifying a driver to use (leave out the -D option all together)

    I am just guessing here, you'll have to try it.

  3. #3
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Obviously ohmycow has posted a post,...yet his post count is 0
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  4. #4
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    Quote Originally Posted by ohmycow View Post
    (I hope I post in the correct section etc. now...)

    Hello!

    Very nice distribution and a very nice forum. I've searched and got alot of answers for things I wondered about. TONS of information and nice guides!

    One thing that I didn't really find any answer to though was if anyone has problem connecting to WPA wlans with their ALfa AWUS036H?

    I have Backtrack installed to the harddrive.

    I assume not since I find no other complaint, but perhaps you see something I do not see in this picture. (When I attempt to connect . . .)
    I can successfully connect using the internal card on my laptop with wpa_supplicant, but not with the Alfa. I can connect to WEP with it though... so I know that its not broken or so.

    The messages I get, take a look please (cant post link):
    ladda-upp.com/bilder-a/wpa_cry-357.jpg

    I know very little about Linux (obviously).

    Thanks for any tip and help!
    PasteBin output from this:
    Code:
    wpa_supplicant -Dwext -iwlan0 -dd -c/wpa.conf
    Post the contents of wpa.conf
    Μολὼν λαβέ - Great spirits encounter heavy opposition from mediocre minds.

  5. #5
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    3

    Default Thanks for the answers, here is my data

    Here's my wpa.conf file:
    The real password is not "hidden" ofcourse. It's a wpa_passkey phrase which works as seen below.

    Code:
    bt / # cat wpa.conf
    #wpa god damnit
    
    ctrl_interface=/var/run/wpa_supplicant
    
    network={
    	ssid="Kaptenen"
    	key_mgmt=WPA-PSK
    	proto=WPA
    	pairwise=TKIP
    	group=TKIP
    	psk=hidden
    }
    Here is a successfull connection with my internal eth0 wlan card (just to show that wpa_supplicant works in general):
    Code:
    bt / # wpa_supplicant -Dwext -ieth0 -c/wpa.conf
    Trying to associate with 00:13:46:cd:ab:b6 (SSID='Kaptenen' freq=2417 MHz)
    Associated with 00:13:46:cd:ab:b6
    WPA: Key negotiation completed with 00:13:46:cd:ab:b6 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:13:46:cd:ab:b6 completed (auth) [id=0 id_str=]
    CTRL-EVENT-TERMINATING - signal 2 received
    bt / #

    This is when I tried with ndiswrapper as -D driver:
    Trying without any -D at all put out the same message as with -Dwext, so it puts it automatically with -Dwext.
    Code:
    bt Desktop #wpa_supplicant -Dndiswrapper -iwlan0 -c/wpa.conf
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    CTRL-EVENT-TERMINATING - signal 2 received

  6. #6
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    3

    Post My data #2

    This is with "-dd" as PrairieFire mentioned:
    It's long.

    I've covered some MAC's from the AP's near my house and my own wlan card.. Im sure you understand. But not my own router which is "Kaptenen".

    Some bolds and lines so you easily can see when it repeats the AP scan:

    Code:
    bt Desktop # wpa_supplicant -Dwext -iwlan0 -dd -c/wpa.conf
    
    Initializing interface 'wlan0' conf '/wpa.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
    Configuration file '/wpa.conf' -> '/wpa.conf'
    Reading configuration file '/wpa.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    Line: 5 - start of a new network block
    ssid - hexdump_ascii(len=8):
         4b 61 70 74 65 6e 65 6e                           Kaptenen
    key_mgmt: 0x2
    proto: 0x1
    pairwise: 0x8
    group: 0x8
    PSK - hexdump(len=32): [REMOVED]
    Priority group 0
       id=0 ssid='Kaptenen'
    Initializing interface (2) 'wlan0'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    SIOCGIWRANGE: WE(compiled)=22 WE(source)=16 enc_capa=0x0
      capabilities: key_mgmt 0x0 enc 0x3
    WEXT: Operstate: linkmode=1, operstate=5
    Own MAC address: 00:**:**:**:**:**
    wpa_driver_wext_set_wpa
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x1 - Driver does not support WPA.
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    Driver did not support SIOCSIWENCODEEXT, trying SIOCSIWENCODE
    wpa_driver_wext_set_countermeasures
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - wpa_driver_wext_set_drop_unencrypted
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x1 - Setting scan request: 0 sec 100000 usec
    Added interface wlan0
    RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b2a len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b2a len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b2a len=8
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    Wireless event: cmd=0x8b2a len=8
    State: DISCONNECTED -> SCANNING
    Starting AP scan (broadcast SSID) ------------------ 
    Trying to get current scan results first without requesting a new scan to speed up initial association
    Received 190 bytes of scan results (1 BSSes)
    Scan results: 1
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 0 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 191 bytes of scan results (1 BSSes)
    Scan results: 1
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 1533 bytes of scan results (8 BSSes)
    Scan results: 8
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    1: 00:15:e9:**:**:** ssid='Default' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    2: 00:11:e2:**:**:** ssid='WLAN' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    3: 00:19:cb:**:**:** ssid='ZyXEL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    4: 1a:c7:ae:**:**:** ssid='WASC-PHILIPS' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
       skip - no WPA/RSN IE
    5: 00:0d:88:**:**:** ssid='Radio16' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    6: 00:18:39:**:**:** ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    7: 00:1a:2a:**:**:** ssid='Fluns' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 1538 bytes of scan results (8 BSSes)
    Scan results: 8
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    1: 00:15:e9:**:**:** ssid='Default' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    2: 00:11:e2:**:**:** ssid='WLAN' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    3: 00:19:cb:**:**:** ssid='ZyXEL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    4: 1a:c7:ae:**:**:** ssid='WASC-PHILIPS' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
       skip - no WPA/RSN IE
    5: 00:0d:88:**:**:** ssid='Radio16' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    6: 00:18:39:**:**:** ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    7: 00:1a:2a:**:**:** ssid='Fluns' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 397 bytes of scan results (2 BSSes)
    Scan results: 2
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    1: 1a:c7:ae:**:**:** ssid='WASC-PHILIPS' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 1532 bytes of scan results (8 BSSes)
    Scan results: 8
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    1: 00:15:e9:**:**:** ssid='Default' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    2: 00:11:e2:**:**:** ssid='WLAN' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    3: 00:19:cb:**:**:** ssid='ZyXEL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    4: 1a:c7:ae:**:**:** ssid='WASC-PHILIPS' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
       skip - no WPA/RSN IE
    5: 00:0d:88:**:**:** ssid='Radio16' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    6: 00:18:39:**:**:** ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    7: 00:1a:2a:**:**:** ssid='Fluns_s' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    Starting AP scan (broadcast SSID) ------------------ 
    Scan timeout - try to get results
    Received 1540 bytes of scan results (8 BSSes)
    Scan results: 8
    Selecting BSS from priority group 0
    0: 00:13:46:cd:ab:b6 ssid='Kaptenen' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    1: 00:15:e9:**:**:**ssid='Default' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    2: 00:11:e2:**:**:** ssid='WLAN' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    3: 00:19:cb:**:**:** ssid='ZyXEL' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
       skip - no WPA/RSN IE
    4: 1a:c7:ae:**:**:** ssid='WASC-PHILIPS' wpa_ie_len=0 rsn_ie_len=0 caps=0x12
       skip - no WPA/RSN IE
    5: 00:0d:88:**:**:** ssid='Radio16' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    6: 00:18:39:**:**:** ssid='linksys' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    7: 00:1a:2a:**:**:**ssid='Fluns_s' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
       skip - no WPA/RSN IE
    No suitable AP found.
    Setting scan request: 5 sec 0 usec
    CTRL-EVENT-TERMINATING - signal 2 received
    Removing interface wlan0
    State: SCANNING -> DISCONNECTED
    wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
    WEXT: Operstate: linkmode=-1, operstate=5
    No keys have been configured - skip key clearing
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    wpa_driver_wext_set_wpa
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
    wpa_driver_wext_set_drop_unencrypted
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x0 - wpa_driver_wext_set_countermeasures
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - No keys have been configured - skip key clearing
    Cancelling scan request
    Cancelling authentication timeout
    WEXT: Operstate: linkmode=0, operstate=6
    
    //CTRL+C after i has looped x times with the search of AP...
    
    bt Desktop #

  7. #7
    thundervirus
    Guest

    Default

    I have got exactly the same problem - anyone got already an answer to this?

  8. #8
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by thundervirus View Post
    I have got exactly the same problem - anyone got already an answer to this?
    You will need to use the NDISwrapper instead of the default driver to be able to connect to WPA/WPA2 encrypted APs. If you are having problems with the installation process you might want to take a look at the following thread.
    -Monkeys are like nature's humans.

  9. #9
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    13

    Default

    i have same problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •