Results 1 to 8 of 8

Thread: apt-get upgrade problems

  1. #1
    Junior Member
    Join Date
    Feb 2010
    Posts
    26

    Default apt-get upgrade problems

    Doesn't really go as a bug-per-say, but I didn't know where else to post this...

    Follwing implementation of lukscrypt to my usb with bt4 I've been unable to upgrade bt4 (I don't know why because "i r teh n00b", but I was able to recreate the problem only when installing lukscrypt)

    Code:
    root@bt:~# apt-get upgrade -V
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages have been kept back:
       nmap (5.0.0-bt0 => 5.20-bt0)
    The following packages will be upgraded:
       airoscript (2.1-bt3 => 2.1-bt5)
       autoscan (1.42-bt1 => 1.50-bt0)
       exploitdb (1.0-bt0 => 1.0-bt1)
       gerix-wifi-cracker-ng (2.0-bt5 => 2.0-bt7)
       hydra (5.40-bt4 => 5.40-bt5)
       libapache2-mod-php5 (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       libssl-dev (0.9.8g-10.1ubuntu2.5 => 0.9.8g-10.1ubuntu2.6)
       libssl0.9.8 (0.9.8g-10.1ubuntu2.5 => 0.9.8g-10.1ubuntu2.6)
       mdk3 (1.0-bt1 => 6.0-bt0)
       openssl (0.9.8g-10.1ubuntu2.5 => 0.9.8g-10.1ubuntu2.6)
       php-pear (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5 (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5-cli (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5-common (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5-mysql (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5-pgsql (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       php5-sqlite (5.2.6-2ubuntu4.5 => 5.2.6-4-bt0)
       set (1.0-bt2 => 1.4-bt0)
       sslstrip (0.2-bt0 => 0.7-bt0)
    19 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    E: The package index files are corrupted. No Filename: field for package airoscr                                                                                                                                                            ipt.
    E: Unable to parse package file /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages (2)
    E: Unable to parse package file /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386_Packages (2)
    I moved the binary incase I might need it later but you can remove it

    Code:
    mv /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386 /var/lib/apt/lists/archive.offensive-security.com_dists_pwnsauce_microverse_binary-i386XXX
    I then tried upgrading and met a problem with dpkg
    Code:
    ...
    Do you want to continue [Y/n]? y
    Preconfiguring packages ...
    dpkg: parse error, in file `/var/lib/dpkg/available' near line 27273 package `in
    fo':
     field name `´575/█ŃcVÝ' must be followed by colon
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    This is fixed by clearing dbpk and then updating

    Code:
    dpkg --clear-avail 
    sudo apt-get update
    After this upgrading worked for me.

    Code:
    apt-get upgrade

  2. #2
    Just burned his ISO
    Join Date
    Apr 2010
    Posts
    9

    Default AW: apt-get upgrade problems

    i'm having the same problem - apt-get won't download anything - but my network is under a domain which this machine is not connected to, but I can download if I would manage to get a connection through the proxy, like I did with Firefox and Konqueror.. I just don't know how to configure that on the console
    Can someone help me please?

    edit: solved
    Last edited by XtremuZ; 04-09-2010 at 08:47 AM.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    2

    Default Re: apt-get upgrade problems

    swicky@wicky-desktop:~$ sudo apt-get update
    Hit Index of / hardy Release.gpg
    Ign Index of / hardy/main Translation-en_US
    Ign Index of / hardy/restricted Translation-en_US
    Ign Index of / hardy/universe Translation-en_US
    Ign Index of / hardy/multiverse Translation-en_US
    Hit Index of / hardy-updates Release.gpg
    Ign Index of / hardy-updates/main Translation-en_US
    Ign Index of / hardy-updates/restricted Translation-en_US
    Ign Index of / hardy-updates/universe Translation-en_US
    Ign Index of / hardy-updates/multiverse Translation-en_US
    Hit Index of / hardy-security Release.gpg
    Ign Index of / hardy-security/main Translation-en_US
    Ign Index of / hardy-security/restricted Translation-en_US
    Ign Index of / hardy-security/universe Translation-en_US
    Ign Index of / hardy-security/multiverse Translation-en_US
    Hit Index of / hardy Release
    Hit Index of / hardy-updates Release
    Hit Index of / hardy-security Release
    Hit Index of / hardy/main Packages
    Hit Index of / hardy/restricted Packages
    Hit Index of / hardy/main Sources
    Hit Index of / hardy/restricted Sources
    Hit Index of / hardy/universe Packages
    Hit Index of / hardy/universe Sources
    Hit Index of / hardy/multiverse Packages
    Hit Index of / hardy/multiverse Sources
    Hit Index of / hardy-updates/main Packages
    Hit Index of / hardy-updates/restricted Packages
    Hit Index of / hardy-updates/main Sources
    Hit Index of / hardy-updates/restricted Sources
    Hit Index of / hardy-updates/universe Packages
    Hit Index of / hardy-updates/universe Sources
    Hit Index of / hardy-updates/multiverse Packages
    Hit Index of / hardy-updates/multiverse Sources
    Hit Index of / hardy-security/main Packages
    Hit Index of / hardy-security/restricted Packages
    Hit Index of / hardy-security/main Sources
    Hit Index of / hardy-security/restricted Sources
    Hit Index of / hardy-security/universe Packages
    Hit Index of / hardy-security/universe Sources
    Hit Index of / hardy-security/multiverse Packages
    Hit Index of / hardy-security/multiverse Sources
    Err http://repo.offensive-security.com binary/ Release.gpg
    Could not connect to repo.offensive-security.com:80 (208.68.239.28), connection timed out
    Err http://repo.offensive-security.com binary/ Translation-en_US
    Unable to connect to repo.offensive-security.com http:
    Reading package lists... Done
    W: Failed to fetch http://repo.offensive-security.com/d...ry/Release.gpg Could not connect to repo.offensive-security.com:80 (208.68.239.28), connection timed out

    W: Failed to fetch http://repo.offensive-security.com/d...nary/en_US.bz2 Unable to connect to repo.offensive-security.com http:

    W: Some index files failed to download, they have been ignored, or old ones used instead.
    W: You may want to run apt-get update to correct these problems

  4. #4
    Just burned his ISO
    Join Date
    Dec 2009
    Posts
    4

    Default Re: apt-get upgrade problems

    Hi,
    I recently tried to install update and had a error. It asked to use the following command.
    apt-get -f install

    However I am having some problem ans at the end it says "dpkg error code 100" Could you please help me out regarding this problem. Thank you in advance for looking at my post.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2010
    Location
    That would be telling !
    Posts
    12

    Default bt in vmware is using too much space :(

    I have a little question for anyone who can help ?

    i have installed bt4 in vm ware and the size of the vmware install folder has gone from 9 or so gb to now 30gb....? what has collected in bt4 that needs to be cleaned...? ive only got in there 1.6 gb of word lists....please help any one

  6. #6
    Just burned his ISO Mafaioz's Avatar
    Join Date
    Nov 2010
    Location
    Behind you...sniffing ur wifi
    Posts
    7

    Exclamation Re: apt-get upgrade problems

    Quote Originally Posted by subhasis_s6o View Post
    Hi,
    I recently tried to install update and had a error. It asked to use the following command.
    apt-get -f install

    However I am having some problem ans at the end it says "dpkg error code 100" Could you please help me out regarding this problem. Thank you in advance for looking at my post.
    I also got that after i apt-get install kde <- as the "how to fix gui login" fix. i had to completely reinstall everything. mighta been that

  7. #7
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    2

    Angry Re: apt-get upgrade problems

    Problem... urg

    sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    openvas-scanner
    The following NEW packages will be installed:
    openvas-scanner
    0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
    1 not fully installed or removed.
    Need to get 0B/212kB of archives.
    After this operation, 926kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 234276 files and directories currently installed.)
    Unpacking openvas-scanner (from .../openvas-scanner_3.1.1-bt0_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb (--unpack):
    trying to overwrite `/usr/local/lib/openvas/plugins/synscan.nes', which is also in package openvas-plugins
    Errors were encountered while processing:
    /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    help pls

  8. #8
    r083rt
    Guest

    Default Re: apt-get upgrade problems

    Quote Originally Posted by sdsl366 View Post
    swicky@wicky-desktop:~$ sudo apt-get update
    Hit Index of / hardy Release.gpg
    Ign Index of / hardy/main Translation-en_US
    Ign Index of / hardy/restricted Translation-en_US
    Ign Index of / hardy/universe Translation-en_US
    Ign Index of / hardy/multiverse Translation-en_US
    Hit Index of / hardy-updates Release.gpg
    Ign Index of / hardy-updates/main Translation-en_US
    Ign Index of / hardy-updates/restricted Translation-en_US
    Ign Index of / hardy-updates/universe Translation-en_US
    Ign Index of / hardy-updates/multiverse Translation-en_US
    Hit Index of / hardy-security Release.gpg
    Ign Index of / hardy-security/main Translation-en_US
    Ign Index of / hardy-security/restricted Translation-en_US
    Ign Index of / hardy-security/universe Translation-en_US
    Ign Index of / hardy-security/multiverse Translation-en_US
    Hit Index of / hardy Release
    Hit Index of / hardy-updates Release
    Hit Index of / hardy-security Release
    Hit Index of / hardy/main Packages
    Hit Index of / hardy/restricted Packages
    Hit Index of / hardy/main Sources
    Hit Index of / hardy/restricted Sources
    Hit Index of / hardy/universe Packages
    Hit Index of / hardy/universe Sources
    Hit Index of / hardy/multiverse Packages
    Hit Index of / hardy/multiverse Sources
    Hit Index of / hardy-updates/main Packages
    Hit Index of / hardy-updates/restricted Packages
    Hit Index of / hardy-updates/main Sources
    Hit Index of / hardy-updates/restricted Sources
    Hit Index of / hardy-updates/universe Packages
    Hit Index of / hardy-updates/universe Sources
    Hit Index of / hardy-updates/multiverse Packages
    Hit Index of / hardy-updates/multiverse Sources
    Hit Index of / hardy-security/main Packages
    Hit Index of / hardy-security/restricted Packages
    Hit Index of / hardy-security/main Sources
    Hit Index of / hardy-security/restricted Sources
    Hit Index of / hardy-security/universe Packages
    Hit Index of / hardy-security/universe Sources
    Hit Index of / hardy-security/multiverse Packages
    Hit Index of / hardy-security/multiverse Sources
    Err http://repo.offensive-security.com binary/ Release.gpg
    Could not connect to repo.offensive-security.com:80 (208.68.239.28), connection timed out
    Err http://repo.offensive-security.com binary/ Translation-en_US
    Unable to connect to repo.offensive-security.com http:
    Reading package lists... Done
    W: Failed to fetch http://repo.offensive-security.com/d...ry/Release.gpg Could not connect to repo.offensive-security.com:80 (208.68.239.28), connection timed out

    W: Failed to fetch http://repo.offensive-security.com/d...nary/en_US.bz2 Unable to connect to repo.offensive-security.com http:

    W: Some index files failed to download, they have been ignored, or old ones used instead.
    W: You may want to run apt-get update to correct these problems
    sorry we dont support ubuntu here there are guides online how to install the tools
    on ubuntu or go to ubuntu forums

Similar Threads

  1. distribution upgrade??
    By idrez in forum Beginners Forum
    Replies: 3
    Last Post: 02-19-2010, 05:24 AM
  2. Upgrade from prefinal to final Backtrack 4
    By Herztier in forum Beginners Forum
    Replies: 3
    Last Post: 01-18-2010, 02:44 PM
  3. Preferred upgrade path from BT4 pre-final to BT4 final?
    By v3rsificator in forum Beginners Forum
    Replies: 13
    Last Post: 01-15-2010, 03:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •