Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Can't mount external usb harddrive

  1. #1
    Member
    Join Date
    Feb 2008
    Posts
    74

    Default Can't mount external usb harddrive

    Hi,

    I am using a eeepc running backtrack3 final. I am been trying to mount my external ntfs usb harddrive. However, it doesn't seem to find it. I don't know which dev name to use. The command I am using is:

    mount /dev/sdxx /mnt however I don't know what sdxx to used.

    I tried doing a fdisk -l to see if the system saw it but it doesn't show my external harddrive which by the way is a western digital passport 160gb, it only sees my harddrive(4g) and a sd card (16gb). Is there something I am missing or another way how to troubleshoot this?.

  2. #2
    Member
    Join Date
    Mar 2008
    Posts
    111

    Default

    type just "mount" to find out sdxx

  3. #3
    Jenkem Addict imported_wyze's Avatar
    Join Date
    Jul 2007
    Posts
    1,543

    Default

    Quote Originally Posted by calypso View Post
    type just "mount" to find out sdxx
    Even better, plug it in and unplg it a couple of times and look at the dmesg output.
    dd if=/dev/swc666 of=/dev/wyze

  4. #4
    Member
    Join Date
    Feb 2008
    Posts
    74

    Default

    ok, I tried both suggestion, however, I don't see anything that I can used.
    >mount
    aufs on /type aufs(rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    tmpfs on /tmp type tmpfs (rw, noatime, mode=0777)
    tmpfs on /var/tmp type tmpfs (rw, noatime, mode=0777)
    tmpfs on /var/log type tmpfs (rw, noatime, mode=0777)

    now after pluging and unpluging the usb deviced
    >dmesg |grep usb
    #1 chosen from 1 choice
    usb 1-3: usb disconnect, address (1-106)
    usb 1-3: new high speed usb device using ehci_hcd and address (1-106)
    usb 1-3: configuration #1 chosen from 1 choice
    usb 1-3: usb disconnect, address (1-106)

    **the 1-106 means that these lines are repeating, starting with number 1 up to number 106.

    I don't know if these means that the machine is aware that a usb deviced has been connected and it doesn't know what to do??? Let me know if I miss a big clue or what else I can do.

  5. #5
    Member
    Join Date
    Mar 2008
    Posts
    111

    Default

    im afraid im no expert but your output from mount looks really wierd, it doesnt seem to show any hard drives at all!
    Did you type this command in straight after you booted?

  6. #6
    Member
    Join Date
    Feb 2008
    Posts
    74

    Default

    Quote Originally Posted by calypso View Post
    im afraid im no expert but your output from mount looks really wierd, it doesnt seem to show any hard drives at all!
    Did you type this command in straight after you booted?

    I don't recall, however if I do a fdisk -l it does show all my current drives that are connected with the exception of the external usb harddrive.

    I was googling the problem and in a unbuntun forum, someone with a similar output to my dmesg (see previous posting) was recomended to disable the ehci_hcd. Once he did it it work for him.

    I am not a linux expert but what could be the worst thing that can happened if I were to do that? Also how do you disable it? I tried what the posting was recomending on how to disable it but it didn't work for me.

    On the posting, the person was recomending to type the following commands to disable the ehci_hcd:
    >echo blacklist ehci_hcd > /etc/modprobe.d/blacklist.ehci
    >update-initramfs -u
    then reboot.

    However, when I tried the second line (update-initramfs -u), I get an error saying command not found. Do I have to be in a specific path/directory to do that? I also tried doing a "echo blacklist" to see what gets display and it echo's the word blacklist of course. It is that right?.


    Another article that I found promising was about USB drives in slackware12.0 http://www.mutaku.com/geeklog/articl...71218003749377 I haven't tried that either, at least not yet. I'll give it a tried when I get home, if it doesn't work, I'll tried the disabling ehci_hcd.

  7. #7
    Member
    Join Date
    Feb 2008
    Posts
    74

    Default

    Got it working. I feel like such a fool that it didn't occur to me to try this earlier. When troubleshooting the problem with a friend, he plug in his western digital usb harddrive and it worked fine. So he plug mine to his xp desktop machine which didn't recognized mine. Thus, it occurs to us that his harddrive was using a shorter usb cable in comparison with mine harddrive which had the long usb cable. Once we replace the long cable with a short one, it worked!

    Don't know why the lenght of the USB cable made any difference but it works now and that is all what matters.

  8. #8
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by algemy View Post
    Got it working. I feel like such a fool that it didn't occur to me to try this earlier. When troubleshooting the problem with a friend, he plug in his western digital usb harddrive and it worked fine. So he plug mine to his xp desktop machine which didn't recognized mine. Thus, it occurs to us that his harddrive was using a shorter usb cable in comparison with mine harddrive which had the long usb cable. Once we replace the long cable with a short one, it worked!

    Don't know why the lenght of the USB cable made any difference but it works now and that is all what matters.
    Could be a bad cable.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  9. #9
    Junior Member
    Join Date
    Jun 2008
    Posts
    25

    Default no usb mem card or hdd working :S

    i have bt3 i have usb memory card and it sais a security policy is stoping this device or access to this device eoor any help i need to edit a file dno were the file is or wot its called and can sum1 help plz soz 4 shorthand :P thanks 4 any respons ps luv u all lol xx xx xx rawr help me !!!

  10. #10
    Junior Member
    Join Date
    Jun 2008
    Posts
    25

    Default

    how do i browse cds / dvd on bt3 aswell wot i type in konsol?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •