Results 1 to 8 of 8

Thread: macchanger causing problems (i think)

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    31

    Default macchanger causing problems (i think)

    For a while now I've been trying to connect to my AP with a spoofed mac via macchanger. This is what I do;

    Code:
    bt ~# ifconfig wlan0 down
    bt ~# macchanger -A wlan0
    
    Then I get assigned a random MAC
    
    bt ~# ifconfig wlan0 up
    bt ~# iwconfig wlan0 mode managed key [WEP KEY]
    bt ~# iwconfig wlan0 essid [ESSID]
    bt ~# dhclient wlan0
    
     This is where it goes wrong...
    I can't get assigned an IP via the AP
    
    Internet Systems Consortium DHCP Client v3.0.6
    All rights reserved
    For info, please visit blah blah blah
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/[My spoofed MAC]
    Sending on LPF/wlan0/[My spoofed MAC]
    Sending on Socket/fallback
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPNAK from 192.168.1.1
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    receive _packet failed on wlan0: Network is down
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    No DHCPOFFERS received.
    No working leases in persistant database - sleeping
    bt ~#
    However if I go through the procedure again minus the macchanger command I can connect fine.

    I use the iwl3945 drivers with the Intel Pro chipset. I've tried loading the ipwraw drivers but it doesn't like that too.

    Am I doing something wrong or is my card an issue?

    Thanks.

  2. #2
    Senior Member ShadowKill's Avatar
    Join Date
    Dec 2007
    Posts
    908

    Default

    Quote Originally Posted by SlipDigby View Post
    For a while now I've been trying to connect to my AP with a spoofed mac via macchanger. This is what I do;

    Code:
    bt ~# ifconfig wlan0 down
    bt ~# macchanger -A wlan0
     
    Then I get assigned a random MAC
     
    bt ~# ifconfig wlan0 up
    bt ~# iwconfig wlan0 mode managed key [WEP KEY]
    bt ~# iwconfig wlan0 essid [ESSID]
    bt ~# dhclient wlan0
     
    This is where it goes wrong...
    I can't get assigned an IP via the AP
     
    Internet Systems Consortium DHCP Client v3.0.6
    All rights reserved
    For info, please visit blah blah blah
     
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/[My spoofed MAC]
    Sending on LPF/wlan0/[My spoofed MAC]
    Sending on Socket/fallback
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPNAK from 192.168.1.1
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    receive _packet failed on wlan0: Network is down
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    No DHCPOFFERS received.
    No working leases in persistant database - sleeping
    bt ~#
    However if I go through the procedure again minus the macchanger command I can connect fine.

    I use the iwl3945 drivers with the Intel Pro chipset. I've tried loading the ipwraw drivers but it doesn't like that too.

    Am I doing something wrong or is my card an issue?

    Thanks.
    Try issuing a fake MAC of the same type as the AP



    "The goal of every man should be to continue living even after he can no longer draw breath."

    ~ShadowKill

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Posts
    31

    Default

    Still no joy...

    Some more output for you...

    Code:
    This is what I get by default from a fresh startup of BT
    bt ~ # iwconfig
    lo        no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:""  Nickname:""
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
              Tx-Power=27 dBm
              Retry min limit:7   RTS thr:off   Fragment thr=2346 B
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    bt ~ # ifconfig -a
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    wlan0     Link encap:Ethernet  HWaddr 00:1F:3C:[MY MAC]
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    wmaster0  Link encap:UNSPEC  HWaddr [MY MAC]
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    I then perform the following...

    Code:
    bt ~ # ifconfig wlan0 down
    bt ~ # macchanger --endding wlan0
    Current MAC: 00:1f:3c:[MYMAC] (unknown)
    Faked MAC:   00:1f:3c:[MYMAC-ENDING CHANGED] (unknown)
    bt ~ # ifconfig wlan0 up
    bt ~ # iwconfig wlan0 mode managed key [WEP KEY]
    bt ~ # iwconfig wlan0 essid '[ESSID]'
    bt ~ # dhclient wlan0
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:1f:3c:[MYMAC]
    Sending on   LPF/wlan0/00:1f:3c:[MYMAC]
    Sending on   Socket/fallback
    DHCPREQUEST on wlan0 to 255.255.255.255 port 67
    DHCPNAK from 192.168.1.1
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
    receive_packet failed on wlan0: Network is down
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 21
    
    and it fails as usual
    Just trying to pluck some ideas out of my head...should I use the iwpwraw drivers instead?

  4. #4
    heather
    Guest

    Default

    im pretty sure, that you said that you had mac filtering on your ap in the previos thread

    ie you will not be able to connect to your ap if you change you mac addy

  5. #5
    Junior Member
    Join Date
    Aug 2008
    Posts
    31

    Default

    Quote Originally Posted by heather View Post
    im pretty sure, that you said that you had mac filtering on your ap in the previos thread

    ie you will not be able to connect to your ap if you change you mac addy
    Just checked my testing AP and MAC Filtering is not enabled....

  6. #6
    Junior Member
    Join Date
    Aug 2008
    Posts
    31

    Default

    BUMP

    [sorry if bumping is not allowed - just eager for an idea to sort this issue out]

  7. #7
    Junior Member
    Join Date
    Aug 2008
    Posts
    31

    Default

    Never mind all. I've discovered a workaround - although a bit buggy...

    If I keep the settings as they are at startup and use macchanger (--endding) then connect to an AP using Wireless Assistant 0.5.7 I get the message disconnected message and it asks me if I want to reconnect - I just ignore this as I am connected anyway - don't know why it says I'm disconnected when I am not(?)

    I've got a new internal wifi card coming tomorrow with the Atheros 5007 chipset so this should solve most of my problems - I currently use Intep Pro ABG.

  8. #8
    Just burned his ISO kraven666's Avatar
    Join Date
    Sep 2008
    Posts
    19

    Default

    I also use the Intel Pro chipset, this is what I do:

    Code:
    >modprobe -r iwl3945
    >modprobe ipwraw
    >iwconfig
    >airmon-ng stop wifi0
    >ifconfig wifi0 down
    >macchanger -m 00:11:22:33:44:55
    That works perfect for me.

    Kraven666

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •