Results 1 to 9 of 9

Thread: Kismet needs to be configured...

  1. #1
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default Kismet needs to be configured...

    Hi, I have just started using Backtrack. I am having some trouble with kismet though. Yesterday, I would open the terminal, type "kismet", and it would work properly. My wireless network would show up and everything. Today though, it comes up with this:
    Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line.
    Then stops.
    I haven't changed anything since yesterday so I don't know why this is showing up. I also don't know where the .conf file is located as I am booting Backtrack from a USB stick. Does anyone know how to fix this? I have searched Google and the forums and read through the readme but I still haven't been able to find anything. Thanks to anyone who can help.

  2. #2
    Member imported_pynstrom's Avatar
    Join Date
    May 2008
    Posts
    143

    Default

    If your posting this question you didn't search enough as this is probably the most asked and answered question on this forum.
    This was found by searching "kismet.conf": http://forums.remote-exploit.org/sho...ht=kismet.conf and should get you started.
    When hungry, eat your rice; when tired, close your eyes. Fools may laugh at me, but wise men will know what I mean. -- Lin-Chi
    - - - - - - - -
    I slept once, it was a Tuesday.

  3. #3
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default

    Yeah but the thing is there is no kismet.conf file for me to edit. That's what I was saying. I found that thread you linked to when I tried searching the forums.

    Quote Originally Posted by pynstrom View Post
    If your posting this question you didn't search enough as this is probably the most asked and answered question on this forum.
    This was found by searching "kismet.conf": <URL> and should get you started.
    Yeah but there isn't any kismet.conf file that I can find. I am booting from a USB so the directory that they say in that thread doesn't exist.

    edit - Sorry about the double post, I thought that the last post hadn't been posted before. I forgot that each post has to be reviewed by a moderator before it can be posted during the first 3 days. Just need a bit more help here, my wifi card is Intel(R) PRO/Wireless 2200BG. Does anyone know what I should put in the "source=" line? When I looked at iwconfig in the terminal, the only thing that had stuff next to it was "eth1". Thanks for your help, and sorry about the double post.

  4. #4
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default

    Quote Originally Posted by st_nick5 View Post
    Yeah but the thing is there is no kismet.conf file for me to edit. That's what I was saying. I found that thread you linked to when I tried searching the forums.



    Yeah but there isn't any kismet.conf file that I can find. I am booting from a USB so the directory that they say in that thread doesn't exist.
    edit -
    /me kicks myself
    I found the directory and the config file I'm just finding out what I have to put in place of that line I have to change. Thanks for your help.

    edit - How do I delete this post? -_-

  5. #5
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default

    Hello again. Well I sorted out the kismet problem, I know what to configure now to get it working after booting it up. I'm having another slight problem though. I managed to get it all the way to downloading IV packets, but it was downloading them very slowly. This is what I did:
    I first ran kismet to put my card into monitor mode, then I ran
    aireplay-ng -b xx:xx:xx:xx:xx:xx -3 eth1 where xx:xx etc is my router MAC address. I had to use -3 because my card doesn't seem to support injection, unless I haven't got something else configured. My card is a Centrino b/g with an ipw2200 driver.
    It then started downloading IVs very slowly, and I ran
    airmon-ng -w wepcrack --channel 1 --ivs
    After that it downloaded 864 IVs, read 37000+ packets, and sent 4200000+ packets in the space of about 2 and a half hours. The router I am using is a BTHomeHub. Does anyone know if my card just won't work for wep cracking? Or is there a workaround? I'm doing a lot of searching on the internet now but I'm just posting this in case someone knows the answer and can enlighten me. Thanks for your help

    edit - if this post sounds like absolute garbage, then it's because it probably is. I don't know all the terminology very well yet ^^

  6. #6
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by st_nick5 View Post
    aireplay-ng -b xx:xx:xx:xx:xx:xx -3 eth1 where xx:xx etc is my router MAC address. I had to use -3 because my card doesn't seem to support injection, unless I haven't got something else configured. My card is a Centrino b/g with an ipw2200 driver.
    All attacks using aireplay-ng are based on the assumption that injection works with your wireless card. The option -3 is also called ARP-replay attack, and will intercept any broadcasted ARP request and replay/inject this over and over again to generate IVs. As your card does support injection I would recommend that you do some research on the forum both on the correct process for cracking WEP and how to inject using your card.
    -Monkeys are like nature's humans.

  7. #7
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default

    Quote Originally Posted by =Tron= View Post
    All attacks using aireplay-ng are based on the assumption that injection works with your wireless card. The option -3 is also called ARP-replay attack, and will intercept any broadcasted ARP request and replay/inject this over and over again to generate IVs. As your card does support injection I would recommend that you do some research on the forum both on the correct process for cracking WEP and how to inject using your card.
    Ah wicked. So it must be something I'm doing wrong then. Thanks for that.

  8. #8
    heather
    Guest

    Default

    your not really doing anything wrong, you can still crack wep, without using aireplay-ng it will just be a much slower process.

    I would recommend, finding the thread on this forum which lists all wireless cards that support packet injection, buying one of those and start again

  9. #9
    Just burned his ISO
    Join Date
    Sep 2008
    Posts
    12

    Default

    Quote Originally Posted by heather View Post
    your not really doing anything wrong, you can still crack wep, without using aireplay-ng it will just be a much slower process.

    I would recommend, finding the thread on this forum which lists all wireless cards that support packet injection, buying one of those and start again
    I read somewhere that the card is fine (I was able to start capturing IVs, very slowly though), it is just the ipw2200 driver which is the problem. Should I just find a different driver that is compatible? Or is it more difficult than just buying a new card?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •