Results 1 to 4 of 4

Thread: Interesting error

  1. #1
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default Interesting error

    Hey guys,
    I noticed following a tutorial the other day on WEP cracking that when I run:

    Code:
    airmon-ng stop wlan0
    everything is fine, but when I start it back up with:
    Code:
    airmon-ng start wlan0
    I get this:

    ERROR: Neither the sysfs interface links nor the iw command is available.

    And I can't seem to get cracking. But if I use Ezpwn, WEP cracks fine, and quite quickly in most cases. Any insight to what is going on here?

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Try this command instead to put your card into monitor mode:
    Code:
    iwconfig wlan0 mode monitor
    -Monkeys are like nature's humans.

  3. #3
    Senior Member ShadowKill's Avatar
    Join Date
    Dec 2007
    Posts
    908

    Default

    Or just bring wlan0 down via
    Code:
    ifconfig wlan0 down
    and then run
    Code:
    airmon-ng start wlan0
    which should create a VAP (wlan1) in monitor mode that you can then use. When you are done, simply stop wlan1 and bring wlan0 back up. Fin!



    "The goal of every man should be to continue living even after he can no longer draw breath."

    ~ShadowKill

  4. #4
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default

    Tron, your option seems to work, I only tried quickly, but iwconfig shows it in monitored mode. I will try in depth when I get home.

    Shadowkill, your commands still return the sysfs error. I am going to research this a bit more.
    If I get a fix, I will post the resolve. Thanks guys!

    **Updated**
    Seems as though Tron's suggestion works fine. Not sure what is going on, but I will look into it further as this card (ipw3945) is supported.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •