Results 1 to 7 of 7

Thread: How to install BT3Final onto external USB HDD - Solve the Kernel Panic

  1. #1
    Junior Member
    Join Date
    Aug 2007
    Posts
    99

    Default How to install BT3Final onto external USB HDD - Solve the Kernel Panic

    Hallo,
    This is a Tutorial about installing BT3Final to an external USB HDD and solve the Kernel Panic while startup. The point is, that the root partition isn't yet mounted when BACKTRACK starts up. so we have to add the rootdelay-option to the lilo.conf file.

    This will be my first tut and I don’t really know if there is one about this topic.Nevertheless, after having several problems installing BT3 to my HDD, I decided to write this one.


    First of all I followed this excellent tutorial written by pureh@te:
    hxxp://forums.remote-exploit.org/showthread.php?t=14751&page=9&highlight=extern+bac ktrack3

    I also assume you already partitioned your drive. We are going to install Backtrack to our external USB HDD. So the 3 Partitions are: (maybe yours will be sdc etc.)
    Sdb1: Boot
    Sdb2: Swap
    Sdb3: root

    Boot your live cd and open a bash shell and begin.

    If your swap is not yet made then do this..(otherwise omit this step)
    Code:
    bt~#mkswap /dev/sdb2
    bt~#swapon /dev/sdb2
    
    bt~#mkdir /mnt/backtrack
    bt~#mount /dev/sdb3 /mnt/backtrack/
    bt~#mkdir /mnt/backtrack/boot/
    bt~#mount /dev/sdb1 /mnt/backtrack/boot/ (note: If you only have one partiton to install backtrack to simply omit this step)
    bt~#cp --preserve -R /{bin,dev,home,pentest,root,usr,etc,lib,opt,sbin,va r} /mnt/backtrack/ <<< note: there is no space in var. Seems to be a glitch in the matrix
    bt~#mkdir /mnt/backtrack/{mnt,proc,sys,tmp}
    bt~#mount --bind /dev/ /mnt/backtrack/dev/
    bt~#mount -t proc proc /mnt/backtrack/proc/
    bt~#cp /boot/vmlinuz /mnt/backtrack/boot/
    Now for lilo.
    Code:
    bt~#chroot /mnt/backtrack/ /bin/bash
    bt~#nano /etc/lilo.conf

    Now pointing out that the lilo.conf file will solve the kernel panic issue we have to config it the following way: (remember to set your own VGA accordingly )

    lba32
    boot /dev/sdb
    prompt
    timeout=60
    change-rules
    reset
    compact
    vga=791
    image = /boot/vmlinuz
    root = /dev/sdb3
    label = backtrack3_final
    append = ”rootdelay=10”

    Excellent. Save that and then execute lilo (I like to use the verbose flag)
    Code:
    bt~#lilo -v
    after that exit your chroot enviorment
    Code:
    bt/~exit
    and reboot and cross your fingers

    Code:
    bt~#reboot

  2. #2
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    1

    Default

    worked for me thanks goon123

  3. #3
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    20

    Default

    I've got this kernel panic problem on a quad-boot where, Vista, Fedora, BT3 and OpenSuSE are installed. Except for BT3, others boot fine. I'm using OpenSuSE's GRUB for booting. Should this method work? Could you please explain why it won't boot if we don't put that 'rootdelay'?
    I had rather be hated for what I am, than loved for what I'm not

  4. #4
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    11

    Default

    copy the init.g from the CD to your /boot and insert (a string look in the forum) that change in the grub menu.lst

  5. #5
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    10

    Default

    Goon, you sir, are a diamond. I got the HD install working fairly easily (thanks to Purehate's tutorial) with only 1 false start. When I tried installing it on USB from the fresh HD install, I ran into problems. So I tried it from the CD onto the USB - and hit this kernel panic error. I thought it was me doing something wrong, so tried it a few more times in various permutations, sometimes it wouldn't boot at all, sometimes it would panic. Then I found this thread

    Still, it's not a complete loss, as I now feel comfortable with fdisk, and can more or less install it with my eyes closed. But still...thanks for the pointer!

  6. #6
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    3

    Default

    Thanks! It works just fine for me. Only I have to figure out how to boot without compiz

  7. #7
    Just burned his ISO ogredeschnique's Avatar
    Join Date
    Sep 2008
    Posts
    13

    Default

    Quote Originally Posted by moonman View Post
    copy the init.g from the CD to your /boot and insert (a string look in the forum) that change in the grub menu.lst
    I thought of this. I copied the initrd.gz after the first few kernel panics.
    It worked for a while with weird results.
    Code:
    ht tp://forums .remote-exploit.o rg/showpost.php?p=113011&postcount=130
    Now, it fails at
    Code:
    linux live end, starting the Linux distribution
    BusyBox v1.5.1 (2007-08-28 16:05:28 GMT) multi-call binary
    
    No help available.
    
    /linuxrc: exec: line 252: .: Permission denied
    Quote Originally Posted by twinszg View Post
    Thanks! It works just fine for me. Only I have to figure out how to boot without compiz
    From the terminal run "pkgtool"
    and select "Choose Slackware installation scripts to run again"
    At the very botton of the next screen press the spacebar on xwmconfig and press enter.
    Select FluxBox. :-) (alright, that may just be my preference for the eee,)
    OR start pkgtool and select "Remove packages that are currently installed"
    This can also be useful for slimming down your distro.
    Code:
    ht tp:/www .linuxquestions.o rg/questions/slackware-14/small-slackware-even-smaller-697161/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •