Results 1 to 5 of 5

Thread: Nmap error

  1. #1
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default Nmap error

    Hey guys, first post, I have recently installed BT2 onmy laptop. I am not a new Linux user, however, im not the most experienced either.
    When trying to run Nmap from konsole, I get

    "Segmentation fault"

    So I ran it from Kmenu, when the shell opens I get:

    "/bin/sh: line 1: 7337 Segmentation fault nmap"

    I have searched around, but can't seem to find anything on the particular error.

    Any help would be greatly appreciated, let me know if you need more details.

    Thank you

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    try updating your nmap. Bt2's version is pretty old.

    Sorry meant Nmap

  3. #3
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Post

    Quote Originally Posted by pureh@te View Post
    try updating your aircrack. Bt2's version is pretty old.
    Pureh@te where he is asking about aircrack and how Nmap's error are related with aircrack-ng suite?
    for the OP.define an interface using -e switch if you have multiple interfaces.check interfaces using ifconfig -a.

  4. #4
    Good friend of the forums
    Join Date
    Feb 2010
    Posts
    328

    Default

    if all else fails compile from source .. if that fails then you borked yer kernel or something ..

  5. #5
    Member
    Join Date
    Feb 2010
    Location
    Root
    Posts
    121

    Default

    All help was appreciated on this matter. As I moved along, I used the same cd to install on an older machine I had, and noticed the same error on that one. Everything seemed to be in order. Except that I got the same fault with other programs I noticed. I have since downloaded and burned another ISO, installed on my laptop last night, and no problems at all. I haven't had a chance to put it on my other machine, but I am going to assume at this point, that it had something to do with that particular image. Nmap is running fine, along with other programs I was getting faults with.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •