I ran pkgtool and removed glib, pango, and the gtk+ packages. I downloaded the most recent versions of all of them. Heard the order of install was glib, pango, then gtk+. I tar-xvf glib, went into the extracted glib dir, then ran ./configure, then make && make install. Afterwards, I ran pkgtool to see the new package of glib, but it wasn't there. I rebooted and still it wasn't there.

What am I doing wrong? I did the same for pango. Then, when I was doing gtk+, the make && make install outputed that there was no target. I redid the ./configure and saw an error at the end that said the gtk+ install required a certain version of glib. Of course, that version that I thought I installed was good enough, but apparently it wasn't even installed according to the pkgtool utility.


What am I doing wrong?

Also, I installed the NVIDIA drivers from their website. The nvidia driver is now in my xorg.conf and it works like a charm. I installed BT3 from a cd which had the hd install version. I want to get compiz to run, do I need to get the usb bt3 version for compiz? Can I just download the nvidia.lzm from the bt3 wiki? Or am I good since I installed the nvidia drivers? If I need to extract the nvidia.lzm where do I extract them to? /usr/lib/ ?

Also, I'm running 1440x900 res, I wanna try and get 1152x864, do I just add it as a mode in the xorg.conf?

What I'm doing is downloading the .tar.gz files for those 3 programs into my root dir. I just tar them from there and ./configure, make && make install. Kernel should automatically place the programs files where they need to be right?

I just noticed that those three compressed files for those three programs ended in tar.gz

Please excuse me, I'm still learning linux but I was running

tar -xvf when I should've been running tar -xvvzf. So I installed all of them and still they don't show in the pkgtool utility.

Also noticed this when I ran ./configure for the gtk+

checking for GLIB - version >= 2.13.5...
*** 'pkg-config --modversion glib-2.0' returned 2.16.5, but GLIB (2.12.12)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.13.5 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/

It says that it found the 2.16.5 version of glib which is great because that is one of the three packages that I tried to install and I guess it really did install. However, right after that it says that 2.12.12 was returned. I had already removed 2.12.12 of glib with pkgtool. What else do I need to do to get 2.12.12 of glib removed?