Results 1 to 8 of 8

Thread: I'm having trouble installing glib, pango, and gtk+

  1. #1
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    I ran pkgtool and removed glib, pango, and the gtk+ packages. I downloaded the most recent versions of all of them. Heard the order of install was glib, pango, then gtk+. I tar-xvf glib, went into the extracted glib dir, then ran ./configure, then make && make install. Afterwards, I ran pkgtool to see the new package of glib, but it wasn't there. I rebooted and still it wasn't there.

    What am I doing wrong? I did the same for pango. Then, when I was doing gtk+, the make && make install outputed that there was no target. I redid the ./configure and saw an error at the end that said the gtk+ install required a certain version of glib. Of course, that version that I thought I installed was good enough, but apparently it wasn't even installed according to the pkgtool utility.


    What am I doing wrong?

    Also, I installed the NVIDIA drivers from their website. The nvidia driver is now in my xorg.conf and it works like a charm. I installed BT3 from a cd which had the hd install version. I want to get compiz to run, do I need to get the usb bt3 version for compiz? Can I just download the nvidia.lzm from the bt3 wiki? Or am I good since I installed the nvidia drivers? If I need to extract the nvidia.lzm where do I extract them to? /usr/lib/ ?

    Also, I'm running 1440x900 res, I wanna try and get 1152x864, do I just add it as a mode in the xorg.conf?

    What I'm doing is downloading the .tar.gz files for those 3 programs into my root dir. I just tar them from there and ./configure, make && make install. Kernel should automatically place the programs files where they need to be right?

    I just noticed that those three compressed files for those three programs ended in tar.gz

    Please excuse me, I'm still learning linux but I was running

    tar -xvf when I should've been running tar -xvvzf. So I installed all of them and still they don't show in the pkgtool utility.

    Also noticed this when I ran ./configure for the gtk+

    checking for GLIB - version >= 2.13.5...
    *** 'pkg-config --modversion glib-2.0' returned 2.16.5, but GLIB (2.12.12)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLIB 2.13.5 or better is required. The latest version of
    *** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/

    It says that it found the 2.16.5 version of glib which is great because that is one of the three packages that I tried to install and I guess it really did install. However, right after that it says that 2.12.12 was returned. I had already removed 2.12.12 of glib with pkgtool. What else do I need to do to get 2.12.12 of glib removed?

  2. #2
    Good friend of the forums
    Join Date
    Feb 2010
    Posts
    328

    Default

    use gslapt it will give you the option to reinstall

  3. #3
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    Where can I get gslapt? I tried slapt-get too. The command isn't found when I type in the command. I installed the hdd version of bt3.

    I tried installing those three packages again and ran ldconfig after each one and they still don't come up in the pkgtool utility.

  4. #4
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    I was able to install all, thanks.

  5. #5
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    Do I have to installpkg gslapt and slapt-get everytime I boot up?

    How do I set it up to where gslapt and slapt-get are here to stay? I'm running the hdd bt3 version.

    Not sure what happened that time, but gslapt is installed permamently now. That was weird.

  6. #6
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    Also, I've been using this guide

    http://forums.remote-exploit.org/showthread.php?t=15515

    and I'm currently trying to install compiz

    I need to use slapt-get to get the packages. I'm confused on how to use it.

    I've tried slapt-get PACKAGE, which is the TARGET, but that doesn't work it just gives me the help page instead. So I added those 3 repos in the preferences section of gslapt. The guide says to use slapt-get, but why can't I just use gslapt? Don't they both basically do the same thing? What do I do now?

    So I'm getting the packages in that order that the guide recommends. I've come to the sexy-python package and I get dependencies needed notice for glibc-solibs. Should I go ahead and install the sexy-python package anyways? I then search for glibc-solibs and that one is excluded as well. Why is that one excluded? What should I do?

  7. #7
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    anyone? why is glibc-solibs, a package I need inorder to install the sexy-python package, on excluded status? I could try installing it manually but that's what I've done at the very beginning with glib, pang, and gtk+ and that didn't seem to work for some reason.

  8. #8
    Member
    Join Date
    May 2008
    Posts
    190

    Default

    I was able to install the usb version and finally got compiz to work, *headbangs*

    However, I noticed that the borders are missing around my windows, so I can't move the windows around or resize them. How do I bring the borders back? Or is this a bug with compiz?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •