Results 1 to 9 of 9

Thread: error msg when trying to mount main partition under Konqueror

  1. #1
    Member MosGuy's Avatar
    Join Date
    Jan 2010
    Location
    Ontario, Canada
    Posts
    120

    Arrow error msg when trying to mount main partition under Konqueror

    Hey gang,

    I have noticed an error when I try to mount the main root partition under the "media" section of Konqueror. I get the following:

    a security policy in place prevents this sender from sending this message to this recipient. see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")

    Yet the partition clearly boots and runs fine. My output of the mount command is: /dev/hda2 on / type auto (rw) . Konqueror claims it is unmounted tho.

    I had the exact same error when I installed BT3 beta under VMware on my Mac system. I don't recall it happening with BT 2 though. The error message occurs from a fresh install with no security changes done. It's running under root. Currently I have BT3 install on the internal HD, it's the only OS on the drive. It would be handy to get the konqueror mount working.

    Any thoughts ?, I've never seen or had this happen under any other Linux distro I've run before.

  2. #2
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Thumbs up

    Quote Originally Posted by MosGuy View Post
    Hey gang,

    I have noticed an error when I try to mount the main root partition under the "media" section of Konqueror. I get the following:

    a security policy in place prevents this sender from sending this message to this recipient. see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")

    Yet the partition clearly boots and runs fine. My output of the mount command is: /dev/hda2 on / type auto (rw) . Konqueror claims it is unmounted tho.

    I had the exact same error when I installed BT3 beta under VMware on my Mac system. I don't recall it happening with BT 2 though. The error message occurs from a fresh install with no security changes done. It's running under root. Currently I have BT3 install on the internal HD, it's the only OS on the drive. It would be handy to get the konqueror mount working.

    Any thoughts ?, I've never seen or had this happen under any other Linux distro I've run before.
    This is caused by the hal daemon not allowing you to access the device because of a security policy. The hal daemons security policy resides in a file at “/etc/dbus-1/system.d/hal.conf”.

    your hal.conf should look like this
    <!DOCTYPE busconfig PUBLIC
    "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
    "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
    <busconfig>

    <!-- This configuration file specifies the required security policies
    for the HAL to work. -->

    <!-- Only root or user haldaemon can own the HAL service -->
    <policy user="haldaemon">
    <allow own="org.freedesktop.Hal"/>
    </policy>
    <policy user="root">
    <allow own="org.freedesktop.Hal"/>
    </policy>

    <!-- Allow anyone to invoke methods on the Manager and Device interfaces -->
    <policy context="default">
    <allow send_interface="org.freedesktop.Hal.Manager"/>
    <allow send_interface="org.freedesktop.Hal.Device"/>
    <allow receive_interface="org.freedesktop.Hal.Manager"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device"
    receive_sender="org.freedesktop.Hal"/>

    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Syst emPowerManagement"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Lapt opPanel"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Volu me"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Volu me.Crypto"
    receive_sender="org.freedesktop.Hal"/>
    </policy>

    <!-- Default policy for the exported interfaces -->
    <policy context="default">
    <deny send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <deny send_interface="org.freedesktop.Hal.Device.VideoAd apterPM"/>
    <deny send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <deny send_interface="org.freedesktop.Hal.Device.Volume"/>
    <deny send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    <!-- This will not work if pam_console support is not enabled -->
    <!-- This build (from SlackBuilds.org) does not include pam_console support -->
    <policy at_console="true">
    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    <!-- Allow members of 'power' group to shutdown/restart/suspend/hibernate -->
    <policy group="power">
    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    </policy>

    <!-- Allow members of 'video' group to manipulate video settings -->
    <policy group="video">
    <allow send_interface="org.freedesktop.Hal.Device.VideoAd apterPM"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    </policy>

    <!-- Allow members of the 'plugdev' group to mount volumes -->
    <policy group="plugdev">
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    </busconfig>


    restart using

    /etc/init.d/haldaemon restart

  3. #3
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by MosGuy View Post
    I have noticed an error when I try to mount the main root partition under the "media" section of Konqueror. I get the following:

    Yet the partition clearly boots and runs fine.
    You can of course always access the root partition through simply typing /root, or any other direct path for that matter, instead of accessing it through the media section. I have noticed this same "error" message, but never bothered to look into the hal security policy since you naturally can access all the files just fine anyway.
    -Monkeys are like nature's humans.

  4. #4
    Member MosGuy's Avatar
    Join Date
    Jan 2010
    Location
    Ontario, Canada
    Posts
    120

    Default

    Secure_it: Thanks for the info. I'll take a look at my config file the next time I fire up BT

    Tron: I agree, the error isn't all that critical since it doesn't affect OS use. I do have the occasional instance where it would just be handy to have it working under Konqueror.

  5. #5
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by MosGuy View Post
    Tron: I agree, the error isn't all that critical since it doesn't affect OS use. I do have the occasional instance where it would just be handy to have it working under Konqueror.
    Well my point is exactly that you still can access the root partition from within Konqueror, just don’t go through the media section.
    -Monkeys are like nature's humans.

  6. #6
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Lightbulb

    Quote Originally Posted by MosGuy View Post
    Secure_it: Thanks for the info. I'll take a look at my config file the next time I fire up BT

    Tron: I agree, the error isn't all that critical since it doesn't affect OS use. I do have the occasional instance where it would just be handy to have it working under Konqueror.
    Tron is indicating by going to /mnt directory instead of /media.you can browse the things.give it a try.

  7. #7
    Member MosGuy's Avatar
    Join Date
    Jan 2010
    Location
    Ontario, Canada
    Posts
    120

    Default

    Ah yes... I had misread what Tron meant initially. It had been a long day. I understand /mnt works. For my LAN I ended up switching paths to ones that work. The tech in me likes to tinker with things that are throwing up errors . I ended up tweaking the conf file & removing the deny references. Now getting a: can't obtain lock on /media/.hal-mtab . I'll continue to play around to see if I can get it working, just because

  8. #8
    Junior Member
    Join Date
    Jun 2008
    Posts
    25

    Default mine sais all that an dont work stil?

    Quote Originally Posted by secure_it View Post
    This is caused by the hal daemon not allowing you to access the device because of a security policy. The hal daemons security policy resides in a file at “/etc/dbus-1/system.d/hal.conf”.

    your hal.conf should look like this
    <!DOCTYPE busconfig PUBLIC
    "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
    "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
    <busconfig>

    <!-- This configuration file specifies the required security policies
    for the HAL to work. -->

    <!-- Only root or user haldaemon can own the HAL service -->
    <policy user="haldaemon">
    <allow own="org.freedesktop.Hal"/>
    </policy>
    <policy user="root">
    <allow own="org.freedesktop.Hal"/>
    </policy>

    <!-- Allow anyone to invoke methods on the Manager and Device interfaces -->
    <policy context="default">
    <allow send_interface="org.freedesktop.Hal.Manager"/>
    <allow send_interface="org.freedesktop.Hal.Device"/>
    <allow receive_interface="org.freedesktop.Hal.Manager"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device"
    receive_sender="org.freedesktop.Hal"/>

    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Syst emPowerManagement"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Lapt opPanel"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Volu me"
    receive_sender="org.freedesktop.Hal"/>
    <allow receive_interface="org.freedesktop.Hal.Device.Volu me.Crypto"
    receive_sender="org.freedesktop.Hal"/>
    </policy>

    <!-- Default policy for the exported interfaces -->
    <policy context="default">
    <deny send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <deny send_interface="org.freedesktop.Hal.Device.VideoAd apterPM"/>
    <deny send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <deny send_interface="org.freedesktop.Hal.Device.Volume"/>
    <deny send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    <!-- This will not work if pam_console support is not enabled -->
    <!-- This build (from SlackBuilds.org) does not include pam_console support -->
    <policy at_console="true">
    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    <!-- Allow members of 'power' group to shutdown/restart/suspend/hibernate -->
    <policy group="power">
    <allow send_interface="org.freedesktop.Hal.Device.SystemP owerManagement"/>
    </policy>

    <!-- Allow members of 'video' group to manipulate video settings -->
    <policy group="video">
    <allow send_interface="org.freedesktop.Hal.Device.VideoAd apterPM"/>
    <allow send_interface="org.freedesktop.Hal.Device.LaptopP anel"/>
    </policy>

    <!-- Allow members of the 'plugdev' group to mount volumes -->
    <policy group="plugdev">
    <allow send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_interface="org.freedesktop.Hal.Device.Volume. Crypto"/>
    </policy>

    </busconfig>


    restart using

    /etc/init.d/haldaemon restart
    (read all that and compared and is same and stil have unset mounting error as above

  9. #9
    Junior Member
    Join Date
    Jun 2008
    Posts
    25

    Default

    any1 know how 2 update all curent stuff in least amount of comands

    example
    wget updates

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •