Tested on hardware Linksys WUSB54GC rt73 chipset based.

there is new update for rt73 chipset based cards.first download the latest modules.

working with wpa_supplicant.
you need to patch wpa_supplicant
or
use the next generation rt2x00 driver which is compatible with wpa_supplicant
or
latest modules of rt73 have in-built private ioctls to support wpa_supplicant like config.

Ok we begin
http://homepages.tu-darmstadt.de/~p_larbig/wlan/rt73-k2wrlz-3.0.1.tar.bz2
extract archive

ifconfig rausb0 down
modprobe -r rt73
cd rt73-k2wrlz-3.0.1/module
make && make install

modprobe rt73 ifname=rausb0 or wlan0
(here you can choose the appropriate name according to your choice like wlan0 or rausb0 or eth1 whatever)

now use the iwpriv command to avaliable private ioctls
iwpriv wlan0

bt ~ # iwpriv wlan0
wlan0 Available private ioctls :
set (8BE2) : set 1024 char & get 0
txpower (8BF3) : set 1024 char & get 1024 char
adhocOfdm (8BE6) : set 1 int & get 0
stat (8BE9) : set 1024 char & get 1024 char
get_site_survey (8BEF) : set 1024 char & get 1024 char
get_RaAP_Cfg (8BF1) : set 1024 char & get 0
forceprism (8BF2) : set 1024 char & get 0
rfmontx (8BEC) : set 1024 char & get 0
get_rfmontx (8BED) : set 0 & get 1 int
auth (8BE7) : set 1 int & get 0
enc (8BE8) : set 1 int & get 0
wpapsk (8BEA) : set 64 char & get 0
psm (8BEB) : set 1 int & get 0

you are able to see that we got options like txpower and wpapsk,auth,enc etc to modify the settings.

if you want to set the txpower output.use
ifconfig wlan0 down
modprobe -r rt73
modprobe rt73 txPowerTuning=36 ifname=wlan0
Remember: This value will be ADDED to the default Power stored in the card's EEPROM!
Valid Values for Transmit Power: -6 to 36 (0xFA to 0x24).
WARNING: MAY DAMAGE YOUR HARDWARE! - USE AT OWN RISK!
I set it on my Linksys WUSB54GC as 36 without problem.
now you can use
iwconfig

it will show the USB NIC interface as newly created wlan0

use airodump-ng wlan0

you will get pwr much more then before.I got amazingly 90 to 110.

now you have options to use and work with WPA/WPA2 networks.
first option as already told use latest rt2x00 drivers from serialmonkey or configure the wlan0 USB NIC as following

b) WPA (802.11g)

wpa_passphrase <essid> <passphrase>
copy the psk hash(uncommented one)
iwconfig wlan0 mode managed
iwpriv wlan0 set AuthMode=WPAPSK
iwpriv wlan0 set WPAPSK=<key> #replace key with your psk-hash
iwpriv wlan0 set EncrypType=TKIP

c) WPA2 (802.11i)
wpa_passphrase <essid> <passphrase>
copy the psk hash(uncommented one)
iwpriv wlan0 set AuthMode=WPA2PSK
iwpriv wlan0 set WPAPSK=<KEY> #replace key with your psk-hash
iwpriv wlan0 set EncrypType=AES

Check that you're associated with an AP
iwconfig wlan0

or
if you want to patch wpa_supplicant for rt73 chipset you need to patch
the wpa_supplicant file to work with rt73 based chipset
download wpa_Supplicant & patch files here.

WPA_Supplicant-0.5.10.tar.gz
wpa_supplicant-ralink_rt73.patch
wpa_supplicant-ralink_rt73-fix.patch


tar xzf wpa_supplicant-0.5.7.tar.gz
cd wpa_supplicant-0.5.7
patch -p1 < wpa_supplicant-ralink_rt73.patch
patch -p1 < wpa_supplicant-ralink_rt73-fix.patch
make
# install as usual, e.g.
cp wpa_cli wpa_supplicant /usr/local/bin


configure using wpa_supplicant(other users who looking for wpa_supplicant config. can try this)

use these commands

wpa_passphrase <essid> <passphrase>
e.g.
bt ~ # wpa_passphrase thunderbolt backtrack3
network={
ssid="thunderbolt"
#psk="backtrack3"
psk=7b8e62496b86b7eba28199fd9af1f560a8503b7ede9149 bd2f42e42e631bedb0
}
copy the psk-hash


for configuring wpa_supplicant
nano /etc/wpa_supplicant.conf

edit it
# WPA protected network, supply your own ESSID and WPAPSK here:
network={
scan_ssid=0 #1 is ssid is hidden
ssid="thunderbolt" #change with your ssid/essid
proto=WPA
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
psk=7b8e62496b86b7eba28199fd9af1f560a8503b7ede9149 bd2f42e42e631bedb0
# change the psk hash with your psk hash you got from wpa_passphrase
}

now connect with WPA/WPA2 enable AP using

bt ~ # wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf - d rt73 -w (other user may change to ath0-madwifi-ng,wifi0)

Trying to associate with 00:21:29:68:16:c2 (SSID='thunderbolt' freq=2462 MHz)

Associated with 00:21:29:68:16:c2
WPA: Key negotiation completed with 00:21:29:68:16:c2 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to 00:21:29:68:16:c2 completed (auth) [id=0 id_str=]

Here you done configuring txpower for new rt73 module,configuring wpa/wpa2.hope you all liked this little hardware hacks and configs.