Results 1 to 6 of 6

Thread: Ettercap ssl doesnt work

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    15

    Default Ettercap ssl doesnt work

    So ive uncommented the redir_on/off iptables lines in the etter.conf, actually backtrack seems to have them uncommented by default. No matter tho it will not sniff ssl connections. Ive done plenty of googling and searching around here but according to most guides it should be working

    HELP!!

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by Abracadabra View Post
    So ive uncommented the redir_on/off iptables lines in the etter.conf, actually backtrack seems to have them uncommented by default. No matter tho it will not sniff ssl connections. Ive done plenty of googling and searching around here but according to most guides it should be working

    HELP!!
    Care to provide us with some additional information on the set-up and commands that you use?
    -Monkeys are like nature's humans.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    15

    Default

    I dont use any commands i use the GUI. I start up ettercap, sniff my own connection obviously and doin this i can sniff any http connection but cant sniff https, according to many guides i should be able to as long as that redir_on/off is uncommented in the etter.conf.

  4. #4
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by Abracadabra View Post
    I dont use any commands i use the GUI. I start up ettercap, sniff my own connection obviously and doin this i can sniff any http connection but cant sniff https, according to many guides i should be able to as long as that redir_on/off is uncommented in the etter.conf.
    Personally I find using ettercap through the GUI more confusing and slower compared to the command line, but it seems like you are not performing a MITM attack which is why you have no success with SSL. Try using this command to run ettercap as it is easier to explain than the comparable steps in the GUI:
    Code:
    ettercap -Tq -M ARP // // -i interface
    Simply replace interface with the correct one and if you still have no success using this try specifying the target IP between the first // brackets, for example /192.168.1.2/.
    -Monkeys are like nature's humans.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    15

    Default

    Ok thanks a bunch =Tron=, i think i see what im doin wrong i will experiment in a bit got the mrs bitching at me right now lol....maybe ill sniff her passwords hehe


    EDIT: Tried it but still ettercap will only sniff http and not https, wonder what the problem is....hmmm!!

    EDIT2: lol the problem is that old n00b bollox over here is tryin to spoof the same connection im running the attack from for anybody that may get the same problem

  6. #6
    Junior Member
    Join Date
    May 2008
    Posts
    56

    Default

    Are you using Backtrack in Vmware by any chance?
    A+
    Network +
    Security +
    Linux +

    Work in progress: Saving for OSCP

    Currently reading:Hacking-The Art Of Exploitation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •