GOD!!!!!!!!! I've got my new router and i'm trying to connect to it using wpa_supplicant and i keep getting errors. These are the problems i seem to be getting

GNU nano 2.0.6 File: /etc/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1

network={
ssid="MYSSID"
#psk="KEY"
psk=123456789012345678901234567890
}

script generated from // http://www.enterprisenetworkingplane...le.php/3594946

Now once i've done that i try to use the script with wpa_supplicant like this

wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf

Which is correct??

Then i get this error after that command a ran

ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - CTRL-EVENT-TERMINATING - signal 2 received
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported

The key on my access point is correct and my brother who's using windows connects to it fine with no problems :-(. The adapter i'm using is the excellent ALFA adapter!!!!!!

I really need to sort it out been trying now for hours!!!

Please help me really wanna get on the net using my laptop! brother moans when i use his for the net :-( ARGHHHHHHHHHh