Results 1 to 10 of 11

Thread: cannot connecting to WPA access point "ERROR"

Hybrid View

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default cannot connecting to WPA access point "ERROR"

    GOD!!!!!!!!! I've got my new router and i'm trying to connect to it using wpa_supplicant and i keep getting errors. These are the problems i seem to be getting

    GNU nano 2.0.6 File: /etc/wpa_supplicant.conf

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    ap_scan=1

    network={
    ssid="MYSSID"
    #psk="KEY"
    psk=123456789012345678901234567890
    }

    script generated from // http://www.enterprisenetworkingplane...le.php/3594946

    Now once i've done that i try to use the script with wpa_supplicant like this

    wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf

    Which is correct??

    Then i get this error after that command a ran

    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x1 - CTRL-EVENT-TERMINATING - signal 2 received
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
    ioctl[SIOCSIWAUTH]: Operation not supported
    WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported

    The key on my access point is correct and my brother who's using windows connects to it fine with no problems :-(. The adapter i'm using is the excellent ALFA adapter!!!!!!

    I really need to sort it out been trying now for hours!!!

    Please help me really wanna get on the net using my laptop! brother moans when i use his for the net :-( ARGHHHHHHHHHh

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    The adapter i'm using is the excellent ALFA adapter!!!!!!
    Just re-read your post and edited my post accordingly. Have you made sure that you use ndiswrapper with your Alfa card, as it as far as I know is not possible to connect to a WPA/WPA2 encrypted APs using the default rt8187 driver.
    -Monkeys are like nature's humans.

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default

    OOO so i need to use "ndiswrapper" for it to be fully supported? Would i have to use the .inf off the driver disc i got with my card with ndiswrapper? I've used it once i think but i dont know if you can use linux drivers with ndiswrapper with in-turn enables the driver to connect with WPA clients!

    TRON thanks for your help tho!!!! Gets really really annoying at times!!!!

  4. #4
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by phil128 View Post
    OOO so i need to use "ndiswrapper" for it to be fully supported?
    You will need ndiswrapper only to be able to connect to WPA/WPA2 ecrypted networks, to be able to inject and get the card into monitor mode you will still need the default rt8187 driver.
    Would i have to use the .inf off the driver disc i got with my card with ndiswrapper? I've used it once i think but i dont know if you can use linux drivers with ndiswrapper with in-turn enables the driver to connect with WPA clients!
    I believe that the files you need are included on the disc, however it is not the linux drivers you will want to use along with ndiswrapper but the windows version.
    -Monkeys are like nature's humans.

  5. #5
    Junior Member
    Join Date
    May 2007
    Posts
    82

    Default

    I've downloaded the drivers off the net but i ad some problems with ndiswrapper :-(. I'll try the drivers off the Disc when i get back from work then i'll let you know "tron". Thanks alot!!!!!!!!!!!!

  6. #6
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by phil128 View Post
    I've downloaded the drivers off the net but i ad some problems with ndiswrapper :-(. I'll try the drivers off the Disc when i get back from work then i'll let you know "tron". Thanks alot!!!!!!!!!!!!
    Since there have been quite a few questions on how to use ndiswrapper with the Alfa card I decided to do a little write-up. In case you have problems getting it to work you might want to check out the guide at:
    http://forum.remote-exploit.org/showthread.php?t=15497
    -Monkeys are like nature's humans.

  7. #7
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    11

    Default

    has anyone got an answer for this, i have the same error

  8. #8
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by the_fulton View Post
    has anyone got an answer for this, i have the same error
    All the questions asked and errors reported in this thread have already been addressed. In case you use the same card as the OP just read through the thread to find the answers and if you use a different card you will have to post this information in order for us to be able to help.
    -Monkeys are like nature's humans.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •