Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ophcrack 3.0 BT3.0

  1. #1
    Junior Member imported_spudgunman's Avatar
    Join Date
    Feb 2007
    Posts
    78

    Default ophcrack 3.0 BT3.0

    I got ophcrack3 working like this...

    download ophcrack and qt4.4.0 (newest)

    compile and build qt4.4.0

    copy qmake and qconfig from /usr/local/Trolltech/Qt-4.4.0/bin to /usr/bin
    link qmake-qt4 and qmake4 to /usr/bin/qmake

    i also linked /usr/local/Trolltech/Qt-4.4.0/bin to /usr/lib/qt and /usr/lib/qt-4.4.0

    on the ophcrack configure

    UPDATE 3.0.1 appears to have fixed this error

    line 5372 to look like this...
    Code:
          if ($qmake4 --version 2>&1 | $EGREP -q 'Qt.*[Vv]ersion 4.4.0'); then
    then ophcrack ./configure you should get no errors

    make

    make install

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Location
    Germany
    Posts
    6

    Default

    Hello spudgunman,

    i think you forgot one link, i have to do it:

    ln /usr/local/Trolltech/Qt-4.4.0/bin/moc /usr/bin/moc

    otherwise, it works with vmware on my notebook

    thank you!

    btw: the gmake of qt takes several hours on my notebook, i need an new one

  3. #3
    Junior Member imported_spudgunman's Avatar
    Join Date
    Feb 2007
    Posts
    78

    Default

    yes you do thanks, I wrote this after I did it so it was by memory thanks for the catch.

    yes on my d630 it was about 25 min build time, people thought I was working

  4. #4
    Just burned his ISO
    Join Date
    Jun 2006
    Posts
    23

    Default qt-x11 error, need help

    I down loaded qt-x11-opensource-src-4.4.0 and ran ./configure got the following errors:

    for /tmp/qt-x11-opensource-src-4.4.0/tools/qvfb/translations/translations.pro
    WARNING: Failure to find: ../skin.cpp
    WARNING: Failure to find: ../skin.h

    Pls help.

  5. #5
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by mobychien View Post
    I down loaded qt-x11-opensource-src-4.4.0 and ran ./configure got the following errors:

    for /tmp/qt-x11-opensource-src-4.4.0/tools/qvfb/translations/translations.pro
    WARNING: Failure to find: ../skin.cpp
    WARNING: Failure to find: ../skin.h

    Pls help.
    Make sure that you include all the steps mentioned and don't just jump straight to ./configure.
    -Monkeys are like nature's humans.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2006
    Posts
    23

    Default

    Do I just "compile and build qt4.4.0"?
    So I ran ./configure as the first step and got the erros.

    Pls let us know the steps to take to do an error free make and install. Thnks.

  7. #7
    Junior Member imported_spudgunman's Avatar
    Join Date
    Feb 2007
    Posts
    78

    Default

    i assume that your untar didnt work as you expected redownload the package should be 120mb+ you want the one from this page then use graphical archive handler if you get stuck. As there should be no issues with qt-tools and building it... other then disk space

    http://trolltech.com/developer/downloads/qt/x11

    you should be able to compile that with no issues on a HDD install of BT3, if you still have issues make sure that you have BT3 installed correctly, also try moving it from your tmp directory to your home directory in the case of root /root

  8. #8
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    3

    Default

    Can someone make a script for this? I have just started learning python and could make something maybe, but I am sure it could be done easier in BASH. I suppose I could at least give it a go.

  9. #9
    Junior Member
    Join Date
    Dec 2007
    Posts
    55

    Default

    '... other then disk space'

    Thanks for the tut spudgunman. I am running BT3 Final (live) on an EEE 701 running off a 16 gig sdhc with 2.5 gis dedicated to Boot and BT, 3 gigs for changes and 10gb for spare. Am I dreaming to think I can install ophcrack per your tut on this machine? I looked on the ophcrack website and there is a live cd (so I presume it should be small enough) but I don't want to hose my system. I would put the tables on a separate drive. Sorry for noob question. Cheers. B.

  10. #10
    Junior Member imported_spudgunman's Avatar
    Join Date
    Feb 2007
    Posts
    78

    Default

    @twocent$ i didnt look but it was in the 250mb range for the build of qt and the compiled copy was around 100mb so you need 300 mb for that.


    as for the tables, if you dont buy the full copy then you could download the smaller ones to a HDD, and yes you would need to have the 500 MB per table free

    so you want to download the .tar.gz file from ophtcrack site and if you are using the 400mb tables download them whereever you want, you can say "file.open table" from the application

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •