Results 1 to 3 of 3

Thread: No network at all, wired or wireless

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    21

    Unhappy No network at all, wired or wireless

    Well, first off I downloaded the bt3final_usb and burnt it to DVD.

    Booted up fine, even compiz works, but no network at all.

    I am familiar with ubuntu, I actually have a dual boot setup on my machine.
    In ubuntu I had to use ndiswrapper to get my wireless to work, but the wired worked without any issue. My computer is a HP m7463w with all the original hardware. Which doesn't make sense why BT3 doesn't work.


    Anyway,
    I ran lspci and it shows my adapters. I tried to save the output to hdd and a flash but it wouldn't do either. So I took a picture of my monitor and I can't make out the intel number.

    Ethernet Controller Intel Corporation 82816??? (ICH7 Family) LAN Controller (rev 01)

    Ethernet Controller Atheros Communications, Inc, AR5413 802.11abg NIC (rev 01)


    When I run iwconfig it says no wireless interfaces detected.

    When I run ifconfig it only shows lo


    Any suggestions? Thanks

  2. #2
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    21

    Default

    Ok, I got the wired ethernet working by using:

    modprobe e100

    Now I have internet, still no wireless, here is the output when I run lspci:

    bt ~ # lspci
    00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev
    81)

    00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev
    81)

    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
    Audio Controller (rev 01)

    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
    Controller #1 (rev 01)

    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
    Controller #2 (rev 01)

    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
    Controller #3 (rev 01)

    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
    Controller #4 (rev 01)

    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
    Controller (rev 01)

    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)

    00:1f.0 ISA bridge: Intel Corporation 82801GH (ICH7DH) LPC Interface Bridge (rev
    01)

    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
    (rev 01)

    00:1f.2 RAID bus controller: Intel Corporation 82801GR/GH (ICH7 Family) SATA
    RAID Controller (rev 01)

    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)

    01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 LE] (rev
    a1)

    02:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
    (rev 80)

    02:03.0 Ethernet controller: Atheros Communications, Inc. AR5413 802.11abg NIC
    (rev 01)

    02:04.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416)

    MPEG-2 Encoder (rev 01)

    02:05.0 Communication controller: Agere Systems Unknown device 0620

    02:08.0 Ethernet controller: Intel Corporation 82801G (ICH7 Family) LAN
    Controller (rev 01)

  3. #3
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Default

    try this
    modprobe -r ath_pci
    modprobe ath_pci
    (if it not works then try with)
    install latest drivers
    svn checkout http://svn.madwifi.org/madwifi/trunk
    cd trunk
    modprobe -r ath_pci
    make && make install
    modprobe ath_pci

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •