Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Inspiron 1501 w/ ATI boot problems

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    3

    Default Inspiron 1501 w/ ATI boot problems

    I have downloaded the USB version of the BT3 and loaded it on my previously BT3Beta Thumb Drive (an 8GB Kingston). Ran the batch file to make drive bootable again (may have been overkill). Any option other than safe mode brings me a black screen on booting off the thumb drive. Safe mode shows a bunch of memory allocation errors (on the same machine right now so i dont have the exact error). I modified the syslinux.cfg to remove the vga=317 option for framebuffering (had problems with ATI and framebuffer before). I get the same results. Has anybody else had this issue? Any suggestions for things to try?

    Beethovan

  2. #2
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default

    eh, i had BT3beta on my 2gb sandisk cruzer earlier today... with the final version, the bootloader says it cant find a kernel... oh well, i'll figure it out.
    *edit, though i'd try the usb installer from linux, so what better linux distro to use than BT? so i burned the usb iso file to a DVD using imgburn, and it ALSO wont boot, booting BT2/3b was always fine dont know what the problem is now... also checked the DVD against the iso file in imgburn... although booting from the CD gives me a different error at the bootloader.*

    -- double edit, looks like my file size is 726mb, and it lists like 780mb, and guess what my MD5sum aint the same, damn it, time to download again.--

  3. #3
    Just burned his ISO
    Join Date
    May 2007
    Posts
    14

    Default

    Yeah I am having the same problem on the CD Image :s
    It seems to get stuck on the following line when I try to run in Safe mode.
    "Time: acpi_pm clocksource has been installed."

    Ive just finished downloading the USB image and will see if I get the same problem with that

    [EDIT1]
    I just noticed that before I get to choose what mode it runs in I get a message "Unknown keyboard in config file" its up for a fraction of a second but I'm sure that's what it says. I don't know if that will be any help

    [EDIT2]
    The USB image gets stuck on the following line when I run in Safe mode.
    "NET: Registered protocol family 2"

  4. #4
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    1

    Default

    if you can add either acpi=off or noacpi to boot options it should solve the problem. I haven't tried the USB install yet so I'm not sure that that is as easy as I think it would be.

  5. #5
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    3

    Default acpi=off

    The acpi=off trick worked to get me to a command prompt. xconf generates the xorg.conf file, but then the startx just brings up a black screen (i cant break out of it due to my laptop keyboard). I originally disabled framebuffers at the beginning. i'll try enabling again.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    3

    Default

    OK, so acpi=off and disabling framebuffers (due to ati card) will get me to a command prompt, and i can successfully run xconf, but the startx goes black, and since it's a laptop with no real num + key, I cant break out of the screen. any ideas for that last stretch of problem?

  7. #7
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    22

    Default

    Quote Originally Posted by beethovan2001 View Post
    OK, so acpi=off and disabling framebuffers (due to ati card) will get me to a command prompt, and i can successfully run xconf, but the startx goes black, and since it's a laptop with no real num + key, I cant break out of the screen. any ideas for that last stretch of problem?
    Got the same thing on my 6400. I also see that ATI.lzm gives me a "Corrupted Download" message on boot. Anyone else get this?

  8. #8
    Junior Member
    Join Date
    Jun 2008
    Posts
    30

    Default

    Quote Originally Posted by beethovan2001 View Post
    OK, so acpi=off and disabling framebuffers (due to ati card) will get me to a command prompt, and i can successfully run xconf, but the startx goes black, and since it's a laptop with no real num + key, I cant break out of the screen. any ideas for that last stretch of problem?
    I have Dell inspirion 6400 with ati x1400 .. i get the same problem, but i fixed it by replacing /etc/X11/xorg.conf with another file, xorg.conf-vesa.
    Code:
    # cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
    That did it for me.
    Then proceed to download drivers from ati, install and reboot.
    Btw, i have hard disk installation.

  9. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    68

    Default

    Gents,

    With BT3b (Triple Boot HDD install), I downloaded the linux drivers from the ATI site (even though the drivers are for Xpress 1250 and my Inspirion 1501 has the Xpress 1150 chip).

    It stopped the black hang on boot and I also got Compiz working great on it.

    I have yet to install BT3final to HDD for lack of time, but I would imagine the ATI drivers should work on this release as well.

    (also run "aticonfig --initial" once you have installed the drivers)

  10. #10
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    4

    Default

    ---RESOLVED---

    See, I'm having a similar problem to the rest of you. I'm using an Inspiron E1505 with ATI Mobility Radeon X1400. I'm booting off of a 4GB Micro Cruzer by SanDisk. I can get to bash perfectly fine, and running xconf works, but when I run startx the screen goes black, and then it kicks me back to bash and says something about there being no monitors. Or, monitors were detected, but there were no inferfaces.

    So, I hate to ask, but can someone just walk me through fixing this step by step? Preferably either from bash or from a Windows enviroment.

    Thanks in advance.

    -Scratch that. Forgot to boot into VESA KDE-

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •