Results 1 to 2 of 2

Thread: Cannot user startx with newly created user

  1. #1
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    19

    Default Cannot user startx with newly created user

    I have bt3f installed on a usb flash drive and I booted it up with the compiz options as root. I did adduser and filled all the information out and then i logged out of my root session. After I entered my user name and password for the user I just created I used the startx command which gave me the following error message.

    xauth: creating new authority file /home/zero/.serverauth.10657

    Fatal server error:
    Cannot move old log file ("/var/log/Xorg.0.log" to "var/log/Xorg.0.log.old"

    giving up.
    xinit: No such file or directory (errno 2): unable to connect to x server
    xinit: No such process (errno 3): server error

    It then returns me to the prompt.
    It seems as though I'm only aloud to use startx with root.
    Any ideas as to what's wrong? I also notice when I logout with compiz on that it prints a whole bunch of garbage before it gives me the login prompt.
    I have also tried this without compiz and it still does the same thing.

    Thanks in advance for the help.

  2. #2
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    3

    Default

    I'm a moron. This is the BT3 support forum. Having the same exact issue on BT2. I'll go post in the right place. I'm sure we just need to fix some permissions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •