Results 1 to 10 of 11

Thread: Firefox 3 Install?

Hybrid View

  1. #1
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default Firefox 3 Install?

    I have been trying to install firefox 3 on backtrack 3 final i seen a package on Linux packages

    http://www.linuxpackages.net/search_...fox+3&ver=12.1

    installed with pkgtool but it was spannish it think so i downloaded from the mozilla website


    Download your language preference from here

    http://www.mozilla.com/en-US/firefox/all.html

    Make sure you get the linux version

    extract it using

    tar -jxvf firefox-3.0.tar.bz2

    Then right clicked on the firefox icon on the desktop and chose configure firefox button

    under aplication and command i put /root/firefox/firefox

    It works but i think there is a proper way to do it like the package where it overwrote old version i think
    if anyone can help?

    But it is working at the moment
    My life is a living Hell, Day by Day fixing broken Windows Boxes (will it ever end)

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    68

    Default

    I would like to know how one would go about un-installing Firefox 2.0.14 prior to installing version 3 to keep things nice & tidy?

    Acutally, I would like to know how to uninstall packages in Linux in general.

  3. #3
    Member hawaii67's Avatar
    Join Date
    Feb 2006
    Posts
    318

    Default DL and isntall

    The clean way to install firefox is:

    1. download the firefox package from here:
    http://repository.slacky.eu/slackwar...0-i686-1sl.tgz

    2. issue a "installpkg mozilla-firefox-en-us-3.0-i686-1sl.tgz"
    Don't eat yellow snow :rolleyes:

  4. #4
    Junior Member
    Join Date
    Jan 2010
    Posts
    68

    Default

    Quote Originally Posted by hawaii67 View Post
    The clean way to install firefox is:

    1. download the firefox package from here:
    http://repository.slacky.eu/slackwar...0-i686-1sl.tgz

    2. issue a "installpkg mozilla-firefox-en-us-3.0-i686-1sl.tgz"
    ^^thanks for that

  5. #5
    Member
    Join Date
    Jan 2010
    Posts
    140

    Default

    I downloaded firefox 3.0 from hawaii67's post. After starting up Firefox 3 and accepting the EULA, you are presented with a screen that tells you that XSS ME and SQL Inject ME are not compatible with Firefox 3.0. So if either of those extensions are one's you need, then I would hold off on upgrading. From their website, they do say that they are working on updates for Firefox 3.0, so, hopefully, they will be out soon.

  6. #6
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default

    Thank you hawaii67 this is alot quicker and cleaner install.
    My life is a living Hell, Day by Day fixing broken Windows Boxes (will it ever end)

  7. #7
    Just burned his ISO
    Join Date
    Sep 2006
    Posts
    18

    Default

    Quote Originally Posted by hawaii67 View Post
    The clean way to install firefox is:

    1. download the firefox package from here:
    h**p://repository.slacky.eu/slackware-12.1/network/firefox/3.0/en-us/mozilla-firefox-en-us-3.0-i686-1sl.tgz

    2. issue a "installpkg mozilla-firefox-en-us-3.0-i686-1sl.tgz"
    Thank you very much...very appreciated for a Linux moderate user like me.

    Anyway..until to discover from you this command I have do it manually afterwall

  8. #8
    Member hawaii67's Avatar
    Join Date
    Feb 2006
    Posts
    318

    Thumbs up

    You are welcome guys..........
    Don't eat yellow snow :rolleyes:

  9. #9
    Junior Member skidmarq's Avatar
    Join Date
    Jan 2010
    Posts
    88

    Default

    htxp://repository.slacky.eu/slackware-12.1/network/firefox/3.0.3/en-us/mozilla-firefox-en-us-3.0.3-i686-1sl.tgz

    Here is the updated package link for those who are looking to upgrade...

    EDIT: change to 'http' (I'm n00b-penalized and can't post URLs)

  10. #10
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    6

    Default

    Dled and installed skidmarq's listed url. Worked great, no problems. XSS ME and SQL Inject ME have been updated and work after the update.
    Thank You hawaii67 & skidmarq for posting the package links.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •