Hi Action discrete,

It seems like you know quite a bit about installing Backtrack on a Mac and I am looking for some help with a similar problem to that cahrnah has described.

I installed a "triple boot" configuration with OS X 5.7, Win XP and Backtrack 3, but when I boot up, I get icons for all the volumes including Windows, but the partition that should be Backtrack is showing up as "Legacy OS" with a grey Windows icon and will not boot. In fact, last time I tried to boot from it, it took me into the Windows partition and actually started up fine...

I am having problems getting rEFIt to boot up, even after manually running the rEFIt script in Terminal to "bless" my primary startup volume. The computer refuses to boot up with rEFIt as it should, so I need to do an "Option" startup to see rEFIT, and the rEFIt shell starts and crashes. My post with all the details can be found in P1llowT@lk's instructions for setting up a triple boot system, and I am using a MacPro desktop from 2006:


I made the modifications to the lilo.conf file as per P1llowT@lk's instructions, adding these 3 extra lines to the end of the file as per the instructions:

other = sda4
label = Windows
table = sda

These 3 lines are supposed to get around the OS X problem with having a 4th partition. Also, there is a similar small mod to the Windows boot.ini file that works in conjunction with the lilo.conf modification. All the details are in the post I referenced above.

P1llowT@lk also says to "modify the fstab and install it"... I have no idea what mods need to be done to this file or indeed how to "install" it, and I am not getting replies to my questions.

Can you let me know if you have any ideas ? I have been through several attempts at installing sor a few weeks and still no luck

Thanks !