Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Full install on external. Kernal Panic

  1. #1
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    21

    Default Full install on external. Kernal Panic

    I am working on getting a full install on a usb external hard drive. This is what is going on.

    Ok so this is mounting the usb drive. If i don't do this i get this error when running lilo...Fatal: Illegal 'root=' specification: /dev/sda2

    bt ~ # mount -o bind /dev /mnt/sdb2/dev
    bt ~ # mount -t proc proc /mnt/sdb2/proc
    bt ~ # chroot /mnt/sdb2
    bt / # nano /etc/lilo.conf

    This is the lilo config file I am trying to use.

    Code:
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/sdb
    prompt
    timeout = 12
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 0x317
    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/sdb2
    label = Linux1
    read-only
    # Linux bootable partition config ends
    As you can probably tell from this I am booting from a live install on a usb stick. This is why it is sdb, instead of sda. There are two partitions on this an fat, sdb1, for files and stuff, and ext2, sdb2, the BT3 install.

    When I run lilo I get this output.
    Warning: /dev/sdb is not on the first disk
    Added linux2 *
    One warning was issued.

    I then try to boot from it. I get a flash on the screen that says
    LIL

    Then the lilo screen comes up. It seems to boot fine untill i get this error.

    VFS Cannot open root device "812" or unkown-block(8,18)
    Please append a correct "root" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(8,18)
    Can I get some ideas on where to go next. Or if somebody know the problem, please let me know.

    Thanks,

    Little_Dice

  2. #2
    Senior Member ShadowKill's Avatar
    Join Date
    Dec 2007
    Posts
    908

    Default

    When it boots via USB it may see the drive as sda. Can you change the entry in "/etc/
    lilo.conf" (and "/etc/fstab") to sda2?

    I might be off on this but meh....try it anyway



    "The goal of every man should be to continue living even after he can no longer draw breath."

    ~ShadowKill

  3. #3
    Member The_Denv's Avatar
    Join Date
    Nov 2006
    Posts
    364

    Default

    To the OP,

    Can you please provide your 'fdisk', 'mount' and 'fstab' results so we can narrow the problem down?

    Have you read the other threads on this forum?
    http://forums.remote-exploit.org/sho...t=10236&page=3
    Here is another link to help you solve your problem:
    https://juggernaut.wikidot.com/backt...bdrive-install

    Good luck! My BIOS doesn't support USB Boot otherwise I would be able to tell you right away.

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by ShadowKill View Post
    When it boots via USB it may see the drive as sda. Can you change the entry in "/etc/
    lilo.conf" (and "/etc/fstab") to sda2?

    I might be off on this but meh....try it anyway
    I second this one. Usually whatever you're booting from becomes sda if it's a serial device(usb,sata).
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  5. #5
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    21

    Default

    ShaddowKill: Lilo doesn't let me use sda as the root or boot options. It gives me an error
    Fatal: Illegal 'root=' specification: /dev/sda2 (However I don't follow with what you are saying on fstab so maybe that will make it work)
    I was getting this same error when I didn't use these commands.
    bt ~ # mount -o bind /dev /mnt/sdb2/dev
    bt ~ # mount -t proc proc /mnt/sdb2/proc
    So I think it has something to do with the new root directory not having the removable mounted. And since sda is the usb drive I am booted from I don't want to change its mbr.

    The Denv: I am trying to do a full install instead of a live install with changes, but thank you for those links anyway. How do I get the information you want from mount, fstab, and fdisk.

    Barry: Yes it is an external hard drive running on usb 2.0

    Edit://

    I hope this is what you wanted. In this particular situation the removable hard drive is sdc. I don't know why it changes.
    Mount info

    aufs on / type aufs (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/hda1 on /mnt/hda1 type vfat (rw,noatime,quiet,umask=0,check=s,shortname=mixed)
    /dev/hda2 on /mnt/hda2 type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
    /dev/hda3 on /mnt/hda3 type vfat (rw,noatime,quiet,umask=0,check=s,shortname=mixed)
    /dev/sda1 on /mnt/sda1 type vfat (rw,noatime,quiet,umask=0,check=s,shortname=mixed)
    /dev/sdc1 on /mnt/sdc1 type vfat (rw,noatime,quiet,umask=0,check=s,shortname=mixed)

    Fstab info

    aufs / aufs defaults 0 0 # AutoUpdate
    devpts /dev/pts devpts gid=5,mode=620 0 0 # AutoUpdate
    proc /proc proc defaults 0 0 # AutoUpdate
    sysfs /sys sysfs defaults 0 0 # AutoUpdate
    /dev/hdc /mnt/hdc iso9660 noauto,users,exec 0 0 # AutoUpdate
    /dev/hda1 /mnt/hda1 vfat auto,noatime,users,suid,dev,exec,quiet,umask=0,che ck=s,shortname=mixed 0 0 # AutoUpdate
    /dev/hda2 /mnt/hda2 ntfs-3g auto,noatime,users,suid,dev,exec,locale= 0 0 # AutoUpdate
    /dev/hda3 /mnt/hda3 vfat auto,noatime,users,suid,dev,exec,quiet,umask=0,che ck=s,shortname=mixed 0 0 # AutoUpdate
    /dev/fd0 /mnt/floppy vfat noauto,noatime,users,suid,dev,exec 0 0 # AutoUpdate
    /dev/sdb1 /mnt/sdb1 vfat auto,noatime,users,suid,dev,exec,quiet,umask=0,che ck=s,shortname=mixed 0 0 # AutoUpdate
    /dev/sdc2 /mnt/sdc2 ext2 auto,noatime,users,suid,dev,exec 0 0 # AutoUpdate
    /dev/sdc1 /mnt/sdc1 vfat auto,noatime,users,suid,dev,exec,quiet,umask=0,che ck=s,shortname=mixed 0 0 # AutoUpdate

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    you have to add a rootdelay=10 entry to get this to work in your lilo config. I was never able to get it to work however hdm (metasploits creator) has a eepc with a real install to sd card and it works. It might also require a kernel rebuild to get the usb storage options right. There are a few other threads on this issue already.

  7. #7
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    21

    Default

    O, thats who I was talking to last night. I thought it sounded farmiliar. Where do I add the rootdelay=10. He also said he uses grub which I havn't quite gotten figured out yet.

  8. #8
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I'm not sure how to add it in lilo. in grub it goes in the same line as the other kernel commands.

  9. #9
    Member The_Denv's Avatar
    Join Date
    Nov 2006
    Posts
    364

    Default

    Quote Originally Posted by Little_Dice View Post
    This is the lilo config file I am trying to use.

    Code:
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/sdc
    prompt
    timeout = 12
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 0x317
    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/sdc2
    label = Linux1
    append="root=/dev/sdb2 rootdelay=10 nomce quiet"
    read-only
    # Linux bootable partition config ends
    Quote Originally Posted by Little_Dice View Post
    O, thats who I was talking to last night. I thought it sounded farmiliar. Where do I add the rootdelay=10. He also said he uses grub which I havn't quite gotten figured out yet.
    Yes pureh@te uses Grub, its a wise choice and I used Grub with BT1 and actually preferred it; Grub is good...but I have been using lilo since BT2b and it seems to be fine. Your going to have to add the rootdelay within your lilo.conf, Lilo is different from Grub; so the command your going to use is going to be different than what pureh@te uses for Grub. I edited your lilo.conf by adding a line of text, this text is highlighted in red.
    I have never used this line of code within my lilo.conf, so can someone else please verify that I am giving the OP the correct information?
    Thanks.

    Also, I noticed that your drive is listed as sdc and not sda. I have again edited your lilo.conf in red to point out where it may need changed.

    After editing your lilo.conf file, remember to run: 'lilo -v' and then reboot your computer. Also make sure your boot order is set to USB first

  10. #10
    Just burned his ISO
    Join Date
    May 2008
    Posts
    10

    Default Same Error

    I get this same error:

    VFS: Cannot open root device "812" or unknown-block(8,18)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,18)

    I am using a USB external drive with two partitions and I copy the usb version of BT3b to the partition and execute bootinst.bat and it completes. I get to boot and lilo comes up etc and then I get halted at that error. This has happened to me on the live install from CD and the USB version.

    I have googled it to no avail. One question... if I am using xp how might I edit the files as detailed below?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •