Results 1 to 4 of 4

Thread: Still need help a audio problem and wifi problem and some other noob questions.

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    9

    Unhappy Still need help a audio problem and wifi problem and some other noob questions.

    So far I have done in 2 days make a dual boot with my xp and backtrack 3
    which too time to figure out , I also updated G slapt (dont see too many features). Anyways 2 problems 1 is my audio does not work laptop is
    acer aspire 5315-2153 , I go to sound in my system information sound driver
    is alsa , it says synth devices and midi devices Not enabled in config , How do I
    Fix that? and the wifi problem I have is I have a alfa usb adapter AWUS036H
    and when im in wireless assistant it asks for a wep key , but my network is
    wpa and when I put in the password it says connection failed, then even my neighbours who some have wpa , it also says wep, How do I configure to connect to my network with my key in wpa mode, is there something better than wireless assistance or do I have to upgrade my alfa (rtl8187) drivers,
    if so how , Thanks.

  2. #2
    Member imported_pynstrom's Avatar
    Join Date
    May 2008
    Posts
    143

    Default

    I had a similar problem with sound not working properly on my laptop and desktop. Download the newest alsa-driver from alsa-project.org and install it. If you plan to use backtrack only on your laptop run ./configure before installing. However, if you plan to run on multiple computers check out ./configure --help to set option for different audio cards. As far as the problem connecting to wpa/wpa2, I'm not sure how to configure the wireless assistant, however if you use the terminal window, have a look at the commands wpa_passphrase and wpa_supplicant.
    Code:
    $ wpa_passphrase myssid waylongkeythelongerthebetterbecausewecareaboutsecurityalot
    network={
         ssid="myssid"
         #psk="waylongkeythelongerthebetterbecausewecareaboutsecurityalot"
         psk=ef82e334d941fd88ee8e6d6ef9d112eed40e93e2aa560fcaa326c29659ad375d
    }
    Copy your wpa_passphrase output into /etc/wpa_supplicant.conf
    Code:
    # iwconfig eth1 essid "myssid"
    # ifconfigup eth1
    # wpa_supplicant eth1 -c/etc/wpa_supplicant.conf
    If you need a little more explanation I found this information by typing linux connect wpa into Google and clicking I'm Feeling Lucky.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    9

    Default thanks

    thanks a lot for this info , so I just use terminal to connect, it would
    be so much easier to do in wifi manager.

  4. #4
    Member imported_pynstrom's Avatar
    Join Date
    May 2008
    Posts
    143

    Default

    Have you tried using the wifi manager or wireless assistant after creating the wpa_supplicant.conf file?
    Quote Originally Posted by ontherooftop View Post
    it would be so much easier to do in wifi manager.
    It might be a little easier and quicker but when I first started using backtrack the wifi connection tools were always dropping my connection and then reconnecting, interrupting my scans. With the terminal I have not had that problem once.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •