Since this is my preferred graphical partitioning program, I didn't rest till I've got it to work!

The 1st thing I've done was fix the Slapt-get, following this great Thread:
forums.remote-exploit.org/showthread.php?t=10433&highlight=slapt-get&page=2

Next, added some extra repositories:
Code:
nano /etc/slapt-get/slapt-getrc
(adding this lines)
Code:
#Repository per Slackware 12.1
SOURCE=hxxp://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.1/
SOURCE=hxxp://slacky.uglyplace.org/repository/slackware-12.1/
SOURCE=hxxp://filer-1.filearena.net/pub/slackware/addon/slacky/slackware-12.1/
SOURCE=hxxp://mirrors.xservers.ro/slacky.eu/Slackware-12.1-DEV/

#Repository per Slackware 12.0
SOURCE=hxxp://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/
SOURCE=hxxp://slacky.uglyplace.org/repository/slackware-12.0/
SOURCE=hxxp://filer-1.filearena.net/pub/slackware/addon/slacky/slackware-12.0/

#Repository per Gnome Slacky Extra 12.0
SOURCE=hxxp://darkstar.ist.utl.pt/slackware/addon/slacky/gnome-slacky-12.0/
SOURCE=hxxp://slacky.uglyplace.org/repository/gnome-slacky-12.0
SOURCE=hxxp://filer-1.filearena.net/pub/slackware/addon/slacky/gnome-slacky-12.0/

#Repository per Slackware 11.0
SOURCE=hxxp://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-11.0/
SOURCE=hxxp://filer-1.filearena.net/pub/slackware/addon/slacky/slackware-11.0/
(replace hxxp for http )
Ok, next I've done an overall update:
Code:
slapt-get --update
And searched for qtparted:
Code:
slapt-get --search qtparted
And found one:
Code:
qtparted-0.4.4-i486-1asz
So I've installed it:
Code:
slapt-get -i qtparted-0.4.4-i486-1asz
Everything went just great except when I've tried to run it!! Then it gave me this sh*tty output:
Code:
qtparted: error while loading shared libraries: libparted-1.6.so.13: cannot open shared object file: No such file or directory
So I've had to somehow install this missing lib...
After some searching I've found this RPM:

hxxp://rpm.pbone.net/index.php3/stat/4/idpl/2502313/com/libparted-1.6.24-alt1.i586.rpm.html
(again, replace the hxxp for http)

that provides the following libs:
Code:
libparted-1.6.so.13
libparted
So, now I only needed to convert it to .lzm or to .tgz... but how?

I've downloaded the rpm2tgz program! From this location:
fxp://81.0.235.161/SLAX-5-modules/develop/Rpm2Lzm_pfix_0_1.mo
(replace fxp for ftp )

Next I've installed the program:
Code:
mo2lzm Rpm2Lzm_pfix_0_1.mo Rpm2Lzm_pfix_0_1.lzm
lzm2dir Rpm2Lzm_pfix_0_1.lzm /
And finally converted and installed the missing lib:
Code:
rpm2tgz libparted-1.6.24-alt1.i586.rpm
installpkg libparted-1.6.24-alt1.i586.tgz
Now the qtparted runs just great!