Results 1 to 9 of 9

Thread: Airpwn unable to open interface

  1. #1
    Just burned his ISO
    Join Date
    May 2008
    Posts
    24

    Default Airpwn unable to open interface

    Hey guys,
    I am running bt3 beta and I am experimenting airpwn on my own network. I am using a wg511t card. When I try to use airpwn I get this error:
    Code:
    bt conf # airpwn -c /conf/xss_attack -i ath0 -d madwifi -v -v -v
    Parsing configuration file..
    Opening command socket..
    Opening monitor socket..
    Opening injection socket..
    LORCON - tx80211_setmode(...) is deprecated, please use tx80211_setfunctionalmode(...) instead
    Error setting monitor mode for interface .
    Error enabling athXraw interface.
    Unable to open interface .
    Does anyone know how to solve this problem?
    Thanks in advance,
    Luca

  2. #2
    Junior Member aggtrfrad's Avatar
    Join Date
    Apr 2008
    Posts
    74

    Default

    try setting monitor mode before airpwn and try it with all the driver settings. I have an rt61 chipset and when I set it to rt61 it says cannot open interface but if I set it to allmost anyrhing else but rt61, it works perfectly... (getting the 'cannot set to monitor mode' error but still works)
    -Google is watching you

    -June 1, 2001, Microsoft CEO Steve Ballmer: "Linux is a cancer that attaches itself in an intellectual property sense to everything it touches."

  3. #3
    Member
    Join Date
    Jan 2008
    Posts
    245

    Default

    airmon-ng start before running airpwn

    http://bricowifi.blogspot.com/2008/0...cktrack-3.html

  4. #4
    Just burned his ISO
    Join Date
    May 2008
    Posts
    24

    Default

    ok I am still having problems. Ok heres what I ran in the terminal.
    Code:
    bt ~ # airmon-ng stop ath0;airmon-ng start wifi0
    
    
    Interface       Chipset         Driver
    
    wifi0           Atheros         madwifi-ng
    eth0            Broadcom        bcm43xx
    ath0            Atheros         madwifi-ng VAP (parent: wifi0) (VAP destroyed)
    
    
    
    Interface       Chipset         Driver
    
    wifi0           Atheros         madwifi-ng
    eth0            Broadcom        bcm43xx
    ath0            Atheros         madwifi-ng VAP (parent: wifi0) (monitor mode enabled)
    
    bt ~ # iwconfig
    lo        no wireless extensions.
    
    eth0      IEEE 802.11b/g  ESSID:"Wrzesniak"  Nickname:"Broadcom 4318"
              Mode:Managed  Frequency=2.437 GHz  Access Point: 00:40:10:10:00:03
              Bit Rate=24 Mb/s   Tx-Power=18 dBm
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=51/100  Signal level=-57 dBm  Noise level=-73 dBm
              Rx invalid nwid:0  Rx invalid crypt:1  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    eth1      no wireless extensions.
    
    wifi0     no wireless extensions.
    
    ath0      IEEE 802.11g  ESSID:""  Nickname:""
              Mode:Monitor  Frequency:2.457 GHz  Access Point: 00:0F:B5:AA:A4:05
              Bit Rate:0 kb/s   Tx-Power:19 dBm   Sensitivity=1/1
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=0/70  Signal level=-91 dBm  Noise level=-91 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    bt ~ # airpwn -c /conf/xss_attack -i ath0 -d madwifing -v -v -v
    Parsing configuration file..
    Opening command socket..
    Opening monitor socket..
    Opening injection socket..
    LORCON - tx80211_setmode(...) is deprecated, please use tx80211_setfunctionalmode(...) instead
    Error setting monitor mode for interface .
    Listening for packets...
    Channel changing thread starting..
    And it just stays at channel changing thread starting....

    Here is the conf life located in/conf folder
    Code:
    begin xss attack
    match ^(GET|POST)
    ignore ^GET [^ ?]+\.(jpg|jpeg|gif|png|tiff|tif)
    response /content/xss_content
    here is the other file in the /content file
    Code:
    HTTP/1.1 200 OK
    Connection: close
    Content-Type: text/html
    
    <html>
    <head><title></title></head>
    <body>
    <script>alert(?XSSed?);</script>
    </body></html> <!--

  5. #5
    Just burned his ISO
    Join Date
    May 2008
    Posts
    24

    Default

    Ok I just found out you had to insert a number when the channel thing comes up *face palm* but when i do I get an error.
    Code:
    bt ~ # airpwn -c /conf/xss_attack -i ath0 -d madwifing -v -v -v
    Parsing configuration file..
    Opening command socket..
    Opening monitor socket..
    Opening injection socket..
    LORCON - tx80211_setmode(...) is deprecated, please use tx80211_setfunctionalmode(...) instead
    Error setting monitor mode for interface .
    Listening for packets...
    Channel changing thread starting..
    1
    changing channel to 1
    Error setting channel to 1
    2
    changing channel to 2
    Error setting channel to 2
    3
    changing channel to 3
    Error setting channel to 3
    4
    changing channel to 4
    Error setting channel to 4
    5
    changing channel to 5
    Error setting channel to 5
    6
    changing channel to 6
    Error setting channel to 6
    
    7
    changing channel to 7
    Error setting channel to 7
    8
    changing channel to 8
    Error setting channel to 8
    9
    changing channel to 9
    Error setting channel to 9
    (by the way admin can you still post my previous message please? as it still may be helpful)

  6. #6
    Junior Member
    Join Date
    Feb 2008
    Posts
    44

    Default

    tried ath0, ath1, ath2? i found with atheros cards every time yu mess with airmon-ng it starts new vap or whatever. so every time yu run airmon-ng it creates ath0 ath1 ath2 ath3. screwed up all my scripts cause i wasn't using interface as variable, was just using constant of ath0.

    RxCoup

  7. #7
    Just burned his ISO
    Join Date
    May 2008
    Posts
    24

    Default

    Sorry for the late message. Yes I have tried this. Since it was the first time putting it in monitor mode I do not get ath1,2,3, ect. I still can't change the channel on the card.

  8. #8
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    11

    Default

    ..........

  9. #9
    Just burned his ISO
    Join Date
    May 2008
    Posts
    2

    Default

    @marten:10 : It's a bug caused by udev, you can simply resolve that problem. You have to edit a rule file and it's done.

    Edit: Damn, I can't post links directly. That's the address to the bug report:

    http://madwifi.org/ticket/972

    MOD EDIT: link fixed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •