This days i have tryed to boot the cd of backtrack 3 Beta at my new laptop
Acer Aspire 7520G (costed 800 EURO)
With AMD turion 64 x2 Mobile Technology TL-60 (2GH 2x512KB L2 Cache)
Up to 1024MB nVidia GeForce 8400M G Turbo cache
2GB DDR2 < ram
17" WXGA+ Acer CristalBrite LCD
320GB Dual HDD (2 x 160GB)
802.11b/g WLAN (this is a atheros ARBXB63(at windows vista home premium is a AR5007EG) and this cant work at backtrack 2 final < this is another problem that i will tell you at another post at another day)

When i boot the CD of backtrack 3 Beta the menu can be opened but when i press the first option > BT3 Graphics mode (KDE)
than backtrack screen is black and it is stoping to load the CD

So i wanted to shutdown the laptop, i pushed the power button and there the screen returns with the beautiful image of backtrack 3 beta... so there was the loading log , to turn off to restart , i dont have released the power button and the laptop shuts down... !!!
So i changed a option by restarting and booting i pushed tab to edit the option of booting backtrack, i changed VGA=0x317 to VGA=normal
Than i booted up and another error was there(this was the error that stoped loading the CD), just read this error:
NET: Registered protocol family 15
No dock devices found.
ACPI: bus type pci registered
PCI: Using MMCONFIG
PCI: No mmconfig possible on device 00:18
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using IOAPCI for interrupt routing
And here stuck and stops loading the CD of backtrack 3 beta
So if someone can tell me how to fix this error or something that can help me to boot up the backtrack 3 beta
Backtrack 2 final boots fine without errors but backtrack 3 beta doesnt boot!!!
Please someone help me