Page 5 of 8 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 73

Thread: How to get ar9170 chipset usb adapter working

  1. #41
    Member dustyboner's Avatar
    Join Date
    Jan 2010
    Posts
    98

    Default Re: How to get ar9170 chipset usb adapter working

    ok first thing to try is
    Code:
    modprobe -a ath ar9170usb cfg80211 mac80211
    because these modules aren't showing up in your lsmod output

  2. #42
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Unhappy Re: How to get ar9170 chipset usb adapter working

    I'm having a similar problem and was wondering if anyone might be able to help. I've followed the instructions from the OP and am having a similar problem of my wifi adapter not being read. No lights on the adapter and no ath0 in terminal when testing it.

    I've been racking my brain for the last week or so to get a solution and any help would be graciouslly accepted.

    I'm running Backtrack 4 off a persistant usb install on a Sony Vaio VGN-NS190J. I'm also using a DWA-160 A2 usb wifi adapter.

    My output for ifconfig, iwconfig, and lsmod are as follows:

    root@bt:~# ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:10 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:528 (528.0 B) TX bytes:528 (528.0 B)

    root@bt:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11abgn Mode:Managed Access Point: Not-Associated
    Tx-Power=15 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff

    root@bt:~# lsmod
    Module Size Used by
    ipv6 239348 14
    i915 172552 2
    drm 142208 3 i915
    sbs 10940 0
    sbshc 4500 1 sbs
    acpi_cpufreq 7808 0
    cpufreq_stats 4728 0
    cpufreq_powersave 1268 0
    cpufreq_performance 1300 0
    cpufreq_ondemand 7080 2
    freq_table 3476 3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
    cpufreq_conservative 7048 0
    iptable_filter 2324 0
    ip_tables 10916 1 iptable_filter
    x_tables 13592 1 ip_tables
    parport_pc 24292 0
    lp 9412 0
    parport 30572 2 parport_pc,lp
    snd_hda_codec_realtek 194936 1
    snd_hda_intel 24712 1
    snd_hda_codec 57204 2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep 6776 1 snd_hda_codec
    snd_pcm_oss 37728 0
    arc4 1588 2
    snd_mixer_oss 14324 1 snd_pcm_oss
    snd_pcm 67704 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    ecb 2484 2
    snd_seq_dummy 2424 0
    snd_seq_oss 27328 0
    iwlagn 217684 0
    joydev 9728 0
    iwlcore 212380 1 iwlagn
    snd_seq_midi 5952 0
    mac80211 205220 2 iwlagn,iwlcore
    snd_rawmidi 19488 1 snd_seq_midi
    cfg80211 118824 3 iwlagn,iwlcore,mac80211
    sdhci_pci 6900 0
    sdhci 15864 1 sdhci_pci
    snd_seq_midi_event 5972 2 snd_seq_oss,snd_seq_midi
    video 18024 1 i915
    output 2388 1 video
    rfkill_backport 17096 1 cfg80211
    mmc_core 46704 1 sdhci
    sony_laptop 28224 0
    psmouse 41732 0
    uvcvideo 58016 0
    snd_seq 47568 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    rtc_cmos 10156 0
    serio_raw 5016 0
    videodev 37056 1 uvcvideo
    rtc_core 15792 1 rtc_cmos
    snd_timer 19068 2 snd_pcm,snd_seq
    snd_seq_device 6048 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    rfkill 9328 2 sony_laptop
    led_class 3608 2 iwlcore,sdhci
    v4l1_compat 13336 2 uvcvideo,videodev
    rtc_lib 2388 1 rtc_core
    iTCO_wdt 10584 0
    iTCO_vendor_support 2840 1 iTCO_wdt
    snd 50468 14 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_se q_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    intel_agp 26108 1
    shpchp 31560 0
    soundcore 5856 1 snd
    snd_page_alloc 7836 2 snd_hda_intel,snd_pcm
    agpgart 29356 3 drm,intel_agp
    evdev 9120 12
    aufs 143020 1
    exportfs 3828 1 aufs
    squashfs 21144 1
    sg 25064 0
    firewire_ohci 22648 0
    firewire_core 40640 1 firewire_ohci
    sky2 45464 0
    fuse 53104 1

  3. #43
    Member dustyboner's Avatar
    Join Date
    Jan 2010
    Posts
    98

    Default Re: How to get ar9170 chipset usb adapter working

    Quote Originally Posted by Sem616 View Post
    I'm having a similar problem and was wondering if anyone might be able to help. I've followed the instructions from the OP and am having a similar problem of my wifi adapter not being read. No lights on the adapter and no ath0 in terminal when testing it.

    I've been racking my brain for the last week or so to get a solution and any help would be graciouslly accepted.

    I'm running Backtrack 4 off a persistant usb install on a Sony Vaio VGN-NS190J. I'm also using a DWA-160 A2 usb wifi adapter.
    try:
    Code:
    modprobe -a ath ar9170usb cfg80211 mac80211
    because these modules aren't showing up in your lsmod output
    once the modules are loaded and showing in your lsmod output, if the adapter still isn't showing up when you run iwconfig, try unplugging your adapter and then plugging the adapter back in.

  4. #44
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Default Re: How to get ar9170 chipset usb adapter working

    Actually since switching to the R1 release it seems that the drivers are implimented automaticaly. ^-^

  5. #45
    Junior Member
    Join Date
    Jun 2010
    Location
    Carmel, IN USA
    Posts
    36

    Default Re: How to get ar9170 chipset usb adapter working

    I get the following when trying to do a make
    Code:
    WARNING: Symbol version dump /usr/src/linux-source-2.6.34/Module.symvers
               is missing; modules will have no dependencies and modversions.
    I also get the same thing when trying to do a make install
    Code:
    WARNING: Symbol version dump /usr/src/linux-source-2.6.34/Module.symvers
               is missing; modules will have no dependencies and modversions.
    I tried this
    Code:
    *If you get a "No such file or directory" error when you run make, run this command:
    ln -s /usr/src/linux /lib/modules/2.6.30.9/build
    
    Open /etc/modprobe.d/blacklist with any text editor and add blacklist arusb_lnx to the list and save the file.
    but it didn't seem to work any different

    What am I doing wrong?

  6. #46
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    3

    Default Re: How to get ar9170 chipset usb adapter working

    [QUOTE=ondrovic;175254]I get the following when trying to do a make
    Code:
    WARNING: Symbol version dump /usr/src/linux-source-2.6.34/Module.symvers
               is missing; modules will have no dependencies and modversions.
    I also get the same thing when trying to do a make install
    Code:
    WARNING: Symbol version dump /usr/src/linux-source-2.6.34/Module.symvers
               is missing; modules will have no dependencies and modversions.
    The warning compiler message is normal. Everyone will see it if they do a "make".
    I can get the TL-WN821N (ar9170) to work on BT4 R1 for Wicd but not for airodump-ng. Upon executing airodump-ng <monitor mode Wifi interface>, it works for about 1-2 mins then it stops.

    If anyone has a solution please post, thanks.

  7. #47
    Member dustyboner's Avatar
    Join Date
    Jan 2010
    Posts
    98

    Default Re: How to get ar9170 chipset usb adapter working

    did you update the firmware with the version in the repos. I did and had problems so i copy/pasted my old firmware files to /lib/firmware and now it works like its supposed to.

    with BT4 R1 make sure you blacklist arusb_lnx. that it and it should work properly. If you running it from a liveCD you just need to run modprobe -r arusb_lnx at start up.

  8. #48
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    1

    Default Re: How to get ar9170 chipset usb adapter working

    hi.ALL
    i have laptop hp Presario cq61
    i install BackTrack 4 on VMWARE i also have TPLINK usb wireless (TL-WN422G) kindly i need a clear steps how can is bring up the laptop wireless and tplink wireless on this VMWARE

    ioot@bt:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    -------------------------------------------------------------
    root@bt:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0c:29:0f:d6:40
    inet addr:10.43.36.105 Bcast:10.43.36.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fe0f:d640/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:15086 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5347 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:7098753 (7.0 MB) TX bytes:737759 (737.7 KB)
    Interrupt:18 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:248 errors:0 dropped:0 overruns:0 frame:0
    TX packets:248 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:12400 (12.4 KB) TX bytes:12400 (12.4 KB)
    ------------------------------------------------------------------------------------------------------
    root@bt:~# lsusb
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 003: ID 0cf3:1006 Atheros Communications, Inc.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    ---------------------------------------------------------------------------------------------------------
    root@bt:~# lsmod
    Module Size Used by
    ath 7764 0
    rfkill_backport 17096 0
    ar9170usb 41080 0
    mac80211 204728 1 ar9170usb
    cfg80211 61268 2 ath,mac80211
    led_class 3608 1 ar9170usb
    btusb 11592 0
    bluetooth 54148 1 btusb
    sbs 10940 0
    sbshc 4500 1 sbs
    video 18024 0
    output 2388 1 video
    cpufreq_powersave 1268 0
    cpufreq_ondemand 7080 0
    cpufreq_conservative 7048 0
    cpufreq_stats 4728 0
    cpufreq_performance 1300 0
    freq_table 3476 2 cpufreq_ondemand,cpufreq_stats
    iptable_filter 2324 0
    ip_tables 10916 1 iptable_filter
    x_tables 13592 1 ip_tables
    ipv6 239348 10
    lp 9412 0
    snd_ens1371 21216 0
    gameport 9984 1 snd_ens1371
    snd_ac97_codec 100824 1 snd_ens1371
    ac97_bus 1364 1 snd_ac97_codec
    snd_pcm_oss 37728 0
    snd_mixer_oss 14324 1 snd_pcm_oss
    snd_pcm 67704 3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
    snd_seq_dummy 2424 0
    snd_seq_oss 27328 0
    snd_seq_midi 5952 0
    snd_rawmidi 19488 2 snd_ens1371,snd_seq_midi
    snd_seq_midi_event 5972 2 snd_seq_oss,snd_seq_midi
    snd_seq 47568 6
    snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    parport_pc 24292 1
    parport 30572 2 lp,parport_pc
    snd_timer 19068 2 snd_pcm,snd_seq
    snd_seq_device 6048 5
    snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    snd 50468 10
    snd_ens1371,snd_ac97_codec,snd_pcm_oss,snd_mixer_o ss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_tim er,snd_seq_device
    psmouse 41732 0
    rtc_cmos 10156 0
    rtc_core 15792 1 rtc_cmos
    serio_raw 5016 0
    soundcore 5856 1 snd
    rtc_lib 2388 1 rtc_core
    snd_page_alloc 7836 1 snd_pcm
    i2c_piix4 9796 0
    intel_agp 26108 1
    agpgart 29356 1 intel_agp
    shpchp 31560 0
    evdev 9120 5
    ata_generic 4536 0
    pata_acpi 3892 0
    fuse 53104 1
    ------------------------------------------------------------------------------
    root@bt:~# dmesg


    NET: Registered protocol family 31
    Bluetooth: HCI device and connection manager initialized
    Bluetooth: HCI socket layer initialized
    Bluetooth: Generic Bluetooth USB driver ver 0.5
    usbcore: registered new interface driver btusb
    hrtimer: interrupt too slow, forcing clock min delta to 39918510 ns
    cfg80211: Using static regulatory domain info
    cfg80211: Regulatory domain: US
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
    (5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
    (5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
    (5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
    (5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
    cfg80211: Calling CRDA for country: US
    usbcore: registered new interface driver ar9170usb
    cfg80211: Regulatory domain changed to country: US
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
    (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5490000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)


    ---------------------------------------------------------------------------------------------------------------
    thanks

  9. #49
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    1

    Default Re: How to get ar9170 chipset usb adapter working

    Good morning.

    I have been looking through this thread for about 7 houres now, trying to get the information I need for making my problem work but i just cant come to it.

    I have a USB adaptor, the w3100 one from netgear, wich makes me able to actually browse on the internet on my Linux, but it just, wont let it'self be found when doing things like airodump, airmon, you name it. In iwconfig, it also has no accesability, but i'll post that now.

    When doing ifconfig :
    Code:
    eth0      Link encap:Ethernet  HWaddr 08:00:27:5b:66:f4
              inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::a00:27ff:fe5b:66f4/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:5438 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2634 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:5856123 (5.8 MB)  TX bytes:251631 (251.6 KB)
    
    eth1      Link encap:Ethernet  HWaddr 08:00:27:1a:eb:3f
              inet6 addr: fe80::a00:27ff:fe1a:eb3f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:1494 (1.4 KB)
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:143 errors:0 dropped:0 overruns:0 frame:0
              TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:7336 (7.3 KB)  TX bytes:7336 (7.3 KB)
    iwconfig :

    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      no wireless extensions.
    When i try your magic drivers, i get the warning the file is missing (when doing Make). He ignores this and goes on making. Then when putting in make install he goes ballistic, giving the same error and not procceeding. I tried your fix here, even one i found on another forum, but that just wont help. Saw a feign hint about Kernel somewhere in a strange languedge based forum but i guess that has nothing to do with it. I'm really hoping for your help guys, i really want to start working with this material for i find it highly intriging.

    Now I shared this with the rest of the world i can finaly get some sleep. Time flies when you're fighting wifi.

    Demiaxz

  10. #50
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    1

    Smile Re: How to get ar9170 chipset usb adapter working

    i have TP-link WN422G how to make her work on the backtrack4

    thanks

Page 5 of 8 FirstFirst ... 34567 ... LastLast

Similar Threads

  1. Best USB wireless adapter for BT4 Final
    By autocannon in forum Beginners Forum
    Replies: 17
    Last Post: 02-18-2011, 12:48 AM
  2. Dell Wireless 1390 Broadcom Chipset is compatible i think
    By musabbulut in forum Beginners Forum
    Replies: 5
    Last Post: 06-06-2010, 03:24 AM
  3. atheros ar9170 usb adapter
    By llabrword in forum Beginners Forum
    Replies: 6
    Last Post: 04-08-2010, 04:28 AM
  4. Noob asks: How to install RT2870 Chipset into BT4 VMWare?
    By forenmeister in forum Beginners Forum
    Replies: 4
    Last Post: 01-23-2010, 12:19 PM
  5. HP Mini Wireless Chipset?
    By Jufjufjuf in forum Beginners Forum
    Replies: 4
    Last Post: 01-20-2010, 08:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •