Results 1 to 7 of 7

Thread: x server doesnt start

  1. #1
    Just burned his ISO
    Join Date
    May 2008
    Posts
    3

    Default x server doesnt start

    i installed backtrack via the installer, the installation went ok but when i reboot and try to start the xserver it tells me there is a server error and version 'GLIBC_2.4' not found. please help me

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by c0ldzer0 View Post
    i installed backtrack via the installer, the installation went ok but when i reboot and try to start the xserver it tells me there is a server error and version 'GLIBC_2.4' not found. please help me
    could you give us a cut and paste of the actual error?
    And some specifics about the type of hardware you are using.
    Also might wanna check the wiki for compatibility issues.

    http://backtrack.offensive-security.....php/Main_Page
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Just burned his ISO
    Join Date
    May 2008
    Posts
    3

    Default xserver

    well it the live cd works but when i install it, it doesnt work. now i am trying to reinstall it again and it has been sitting at 81% for about 2 hours now. lol. I will check the specs to see if there is a compatibility prob but i don't get y there would be if the live cd works. the error is in the prompt screen rigth after i login, so i dont think i can copy the error.

  4. #4
    Just burned his ISO
    Join Date
    May 2008
    Posts
    3

    Default screw it

    i gave up and decided to just use the live cd it didnt matter i still couldnt do what i wanted thanks for the help

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by c0ldzer0 View Post
    well it the live cd works but when i install it, it doesnt work. now i am trying to reinstall it again and it has been sitting at 81% for about 2 hours now. lol. I will check the specs to see if there is a compatibility prob but i don't get y there would be if the live cd works. the error is in the prompt screen rigth after i login, so i dont think i can copy the error.

    You could also copy it by hand depending on how bad you want backtrack to work.

    Also did you check the md5sum and burn it on the slowest settings? Could be a bad download.
    might wanna check this thread too:
    http://forums.remote-exploit.org/showthread.php?t=9618
    Also some hardware specs may help us out here.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Just burned his ISO
    Join Date
    May 2008
    Posts
    1

    Default Have the same issue after live cd install and reboot

    Yes I get the GLIBC_2.4' not found after a reboot.
    The liveCD works just fine but I am unable to run xorgsetup or xorgconf and get this error when trying.

    I will try to find a resolution....

  7. #7
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    21

    Default

    This is by far not the preferred method but depending on how well you know Linux it might be easier to just boot back to the live CD and patch the files that are missing. I am pretty sure glibc is:

    Linux 2.6.21.5.
    bt ~ # cd /lib
    bt lib # ls -al libc.so*
    lrwxrwxrwx 1 root root 11 Apr 14 11:20 libc.so.6 -> libc-2.5.so*
    bt lib # ls -al libc-2.5.so
    -rwxr-xr-x 1 root root 1528742 Dec 7 16:28 libc-2.5.so*

    so you would need to copy libc-2.5.so to the /lib directory of your backtrack install and then link it to libc.so.6

    Or you might be better off installing it by hand rather than using the installer.
    http://backtrack.offensive-security.com/mwb_v1-2.pdf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •