Results 1 to 5 of 5

Thread: Dlink DWL-G122 C1 BT2 issue

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    5

    Default Dlink DWL-G122 C1 BT2 issue

    I read the forums, did a few searches and I am unable to fix my problem. When I load up BT2 final live cd on my laptop it loads ok.

    When I go into airmon-ng and do an iwconfig it only shows my Broadcom adapter in my laptop.

    It's wierd because the DWL-G122 is detected in the system maintenance in BT2, but airmon won't detect it.

    I was thinking that maybe it was a driver issue, so I downloaded the drivers for the DWL-G122 C1. (ipwraw-ng-2.3.4-04022008.tar.bz2)

    My question is:

    Is there something I am missing that I need to do since it's a USB wifi card.
    Or is it a driver issue? And if it is a driver issue, how do I install the updated drivers? (I am a complete linux n00b and have no idea how to do it even after reading here and searching on google.)

    thanks!!

  2. #2
    Junior Member
    Join Date
    Mar 2008
    Posts
    27

    Default

    first do

    ifconfig rausb0 up

    although it should detect it even if the interface is down its worth a try

    ive used the same adapter (i still am using it) and it worked right out of the box with absolutely no problems whatso ever

    btw is ure broadcom one built in? if so it could be that your USB Hub on ure mobo isnt being detected. what chipset is your motherboard? look for any special drivers for your motherboard and install them. I remember when i was using SuSe my network card wasnt being detected cos the motherboard wasnt being identified properly.

  3. #3
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    this card works out of the box with native driver !

    i can guaranty it for sure

    just follow that :

    1st it use rt73 driver (you can find an updated one on same page than ipraw-ng , aspj page)

    ifconfig rausb0 up
    don't use airmon-ng at all with native driver (driver pb)
    iwconfig rausb0 mode monitor channel x rate 2M
    iwpriv rausb0 forceprism 1
    iwpriv rausb0 rfmontx 1

    like that you are ready with bt2 native driver

    the 2 last lines are not needed since you have updated to 1.1 version of rt73 driver from aspj
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  4. #4
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    17

    Default

    Where exactly is the aspj page with drivers.
    I have the same card, a DWL-G122 C1 and I am using it with Kismac on leopard and also on BT3 but on both platforms I cannot inject or Deauth Networks
    Will those commands work on BT3?
    Any info would be great. Tried searching but cant really find much answers.

    Maybe i should try using BT2?
    Your feedback is appreciated.
    Cheers
    Kevin

  5. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by bigkev81 View Post
    Where exactly is the aspj page with drivers.
    I have the same card, a DWL-G122 C1 and I am using it with Kismac on leopard and also on BT3 but on both platforms I cannot inject or Deauth Networks
    Will those commands work on BT3?
    Any info would be great. Tried searching but cant really find much answers.

    Maybe i should try using BT2?
    Your feedback is appreciated.
    Cheers
    Kevin
    BT3 already has the updated RT73 driver... so as shamanvirtuel said, it works out of the box.
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •