Results 1 to 10 of 10

Thread: Kismet Error Help!!

  1. #1
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    13

    Default Kismet Error Help!!

    I tried running Kismet and it came up with this.

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (addme): Opening none source interface none...
    FATAL: Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line. Please read the README for more information about configuring Kismet.
    Kismet exiting.
    Done.

  2. #2
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by Maybeamac View Post
    I tried running Kismet and it came up with this.

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (addme): Opening none source interface none...
    FATAL: Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line.
    Please read the README for more information about configuring Kismet.
    Kismet exiting.
    Done.
    The problem is explained quite clearly in the error.

  3. #3
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    13

    Default

    Can you please explain how to do this?

  4. #4
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    From the Kismet Documentation

    12. Capture Sources

    A capture source in Kismet is anything which provides packets to the Kismet
    engine. Capture sources define the underlying engine needed to capture
    data from the interface, how to change channel, and how to enter rfmon
    mode. It is necessary to tell Kismet what specific type of card you use
    because different drivers often use different methods to report information and enter monitor mode.
    Read here on how to add sources ==> http://forums.remote-exploit.org/showthread.php?t=13290

  5. #5
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    13

    Default

    Sorry that Gave me a total Headache! I did not understand one thing even though I read through it a couple of times what do I do here nano /usr/local/etc/kismet.conf That's as much as I can go without hurting my head... Also I have a intel pro wireless 3945abg chipset.

  6. #6
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by Maybeamac View Post
    Sorry that Gave me a total Headache! I did not understand one thing even though I read through it a couple of times what do I do here nano /usr/local/etc/kismet.conf That's as much as I can go without hurting my head... Also I have a intel pro wireless 3945abg chipset.
    If you cannot be willing to follow the very instructions provided with Kismet to correct an error that explicitly tells you what to do, there really is no hope for you. If you want to learn something you need to take it upon yourself to show some small amount of initiative to do something on your own. I'm not suggesting that you can't ask for help, but you posted an error that has been posted several times, as recently as a few days ago. Not only that, the error tells you *exactly* what to do. Furthermore, the documentation walks you through how to fix this error. Yet, you plead ignorance. Not a good start my friend.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  7. #7
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by Maybeamac View Post
    Sorry that Gave me a total Headache! I did not understand one thing even though I read through it a couple of times what do I do here nano /usr/local/etc/kismet.conf That's as much as I can go without hurting my head... Also I have a intel pro wireless 3945abg chipset.
    That's scary dude... if those simple instructions give you a headache then the rest of BT is going to give you a heart attack

    Just to show you how easy it can be if you're calm and patient.

    Since you obviously prefer gui mode, here goes nothing

    Open a Terminal (Shell)
    Type
    kate /usr/local/etc/kismet.conf
    Press "Enter"
    Find this section:

    # Sources are defined as:
    and make it look like this:

    # Sources are defined as:
    source=ipw3945,wifi0,internal
    # Source types and required drivers are listed in the README under the
    # CAPTURE SOURCES section.
    # The initial channel is optional, if hopping is not enabled it can be used
    # to set the channel the interface listens on.
    # YOU MUST CHANGE THIS TO BE THE SOURCE YOU WANT TO USE
    source=none,none,addme

    # Comma-separated list of sources to enable. This is only needed if you defined
    # multiple sources and only want to enable some of them. By default, all defined
    # sources are enabled.
    # For example:
    enablesources=internal
    Next
    In the kate menu:
    Click File ==> Save

    Now in a terminal type:
    kismet
    Press "Enter"
    SUCCESS!!!

    If that was too much for you then I'd suggest give up Backtrack now and *nix in general and go back to Windoze

  8. #8
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    13

    Default

    I did that but then this came up?

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    Source 0 (internal): Enabling monitor mode for ipw3945 source interface wifi0 channel 6...
    FATAL: GetIFFlags: interface wifi0: No such device
    Done.

    I think I have to find drivers is that right?

  9. #9
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by Maybeamac View Post
    I did that but then this came up?

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    Source 0 (internal): Enabling monitor mode for ipw3945 source interface wifi0 channel 6...
    FATAL: GetIFFlags: interface wifi0: No such device
    Done.

    I think I have to find drivers is that right?
    I believe ipw3945 uses eth# not wifi#.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  10. #10
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by Maybeamac View Post
    I did that but then this came up?

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    Source 0 (internal): Enabling monitor mode for ipw3945 source interface wifi0 channel 6...
    FATAL: GetIFFlags: interface wifi0: No such device
    Done.

    I think I have to find drivers is that right?
    I don't even know what BT version you're using.

    If you're using BT3 Beta, it already has the drivers.

    The IPW 3945/4965 (iwl3945) driver's used to connect to networks a... in Managed or Ad-Hoc mode, it uses wlan# -

    For kismet and airmon-ng... load the ipwraw driver to change to monitor mode. It uses eth# or wifi#,

    theprez98 is right in some cases afaik. Some use eth# and some use wifi#. My ipw3945 uses wifi0... which is why I suggested it.

    After loading ipwraw drivers you can check to see what yours uses by running this command.

    iwconfig


    Example: After loading the ipwraw driver and then the iwconfig command... I get this.

    lo no wireless extensions.

    ppp0 no wireless extensions.

    wifi0
    unassociated ESSIDff/any
    Mode:Monitor Channel=108 Bit Rate=54 Mb/s

    rtap0 no wireless extensions.
    You see mine is wifi0. However if yours is eth#, just substitute eth# for wifi# in the kismet configuration file you edited earlier.

    Before running kismet you may want to change the Bit Rate to 1 Mb/s by simply running this command.

    airmon-ng start wifi0

    After all this is done run kismet

    If you have a headache after all this. Have a glass of water and a 1 hour rest

    Hope this helps Maybeamac... Good Luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •