Results 1 to 4 of 4

Thread: zlib error when decompressing kernel.lzm

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    14

    Default zlib error when decompressing kernel.lzm

    It seems as though nvidia.lzm does not include a driver for the nVidia 8400M GS. When trying to extract kernel.lzm to build the correct drivers I keep getting a zlib error:
    Code:
    bt src # lzm2dir ./kernel.lzm ./linux
    Lseek failed because Invalid argumensqlzma_un: ZLIB data error
    /usr/bin/lzm2dir: line 17:  5880 Aborted                 unsquashfs -f -dest "$2" "$1" >/dev/null
    Tried building and installing zlib libraries, but did not help.
    Any ideas?

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    seems to work just fine for me. You command syntax is wrong. The point of a .lzm is it will install itself in the proper locations


    backtrack3 ~ # wget http://www.offensive-security.com/kernel.lzm
    --19:19:32-- http://www.offensive-security.com/kernel.lzm
    => `kernel.lzm'
    Resolving www.offensive-security.com... 208.68.234.120
    Connecting to www.offensive-security.com|208.68.234.120|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 64,905,216 (62M) [text/plain]

    100%[================================================== =========>] 64,905,216 178.56K/s ETA 00:00

    19:28:01 (124.60 KB/s) - `kernel.lzm' saved [64905216/64905216]

    backtrack3 ~ # lzm2dir kernel.lzm /
    backtrack3 ~ #

  3. #3
    Just burned his ISO
    Join Date
    Jul 2008
    Posts
    14

    Default

    Thanks. Not only was my syntax wrong but the lzm package was corrupted as well.

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Another satisfied customer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •