Results 1 to 3 of 3

Thread: Cannot chmod files on NTFS partition?

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    1

    Question Cannot chmod files on NTFS partition?

    I am booting BT2 from a newly-partitioned external HD with a large NTFS partition. Most things are working fine. I can read and write to the NTFS partition from BT/Linux with no problems. However, when I try to chmod files on this partition, it has no effect. The partition is still functional, but all file permissions are stuck at 777 world writable.

    Do I need to adjust mount parameters? Any ideas?

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Do I need to adjust mount parameters? Any ideas?
    NTFS file system will not accept chmod commands. You will need to use the mask command when mounting the drive to achieve the same effect. For example I believe that the option –o umask=0000 when mounting the drive will set the permissions for the whole drive to be read/write for all users, i.e. chmod 777.

    I understand that this is not what you are trying to achieve, but hope I managed to nod you in the right direction.
    -Monkeys are like nature's humans.

  3. #3
    Jenkem Addict imported_wyze's Avatar
    Join Date
    Jul 2007
    Posts
    1,543

    Default

    Quote Originally Posted by redeemed1 View Post
    I am booting BT2 from a newly-partitioned external HD with a large NTFS partition. Most things are working fine. I can read and write to the NTFS partition from BT/Linux with no problems. However, when I try to chmod files on this partition, it has no effect. The partition is still functional, but all file permissions are stuck at 777 world writable.

    Do I need to adjust mount parameters? Any ideas?
    You're out of your mind... hope you don't need the data on the NTFS partition.
    dd if=/dev/swc666 of=/dev/wyze

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •