Results 1 to 9 of 9

Thread: Cannot Transfer Files To usb HardDrive

  1. #1
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    2

    Default Cannot Transfer Files To usb HardDrive

    Hello Well i just downloaded a huge wordlist so i can crack me wpa password but the hardrive i have that backtrack is installed on is way to small so i am trying to transfer a few wordlists to my usb hardrive that i just freshly formatted with ntfs when i go throught the system icon then to storage media and click my usb hardrive and try to drag the file from my desktop into the usb hardrive window it just shows a red X any idea why this is happening? thanks

  2. #2
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by LogitechGamer View Post
    Hello Well i just downloaded a huge wordlist so i can crack me wpa password but the hardrive i have that backtrack is installed on is way to small so i am trying to transfer a few wordlists to my usb hardrive that i just freshly formatted with ntfs when i go throught the system icon then to storage media and click my usb hardrive and try to drag the file from my desktop into the usb hardrive window it just shows a red X any idea why this is happening? thanks
    Right there is your problem, ntfs is not a native linux filesystem and write support is only provided if you use a third party app.

  3. #3
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by balding_parrot View Post
    Right there is your problem, ntfs is not a native linux filesystem and write support is only provided if you use a third party app.

    I don't know why but my bt3 beta installation has ntfs write support out the box. I remember when I was using Kubuntu though I had to install a 3rd party app to enable it.
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  4. #4
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by .lonewolf View Post
    I don't know why but my bt3 beta installation has ntfs write support out the box. I remember when I was using Kubuntu though I had to install a 3rd party app to enable it.
    I know bt3 has ntfs read support out of the box, but as far as I know write support is not enabled by default.
    You may very well be right, I have never been in the situation to try it, but I am certain I have read a discussion on the forum saying that write support needs to be "forced".

    I will have to try and remember to have a check later.

  5. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by balding_parrot View Post
    I know bt3 has ntfs read support out of the box, but as far as I know write support is not enabled by default.
    You may very well be right, I have never been in the situation to try it, but I am certain I have read a discussion on the forum saying that write support needs to be "forced".

    I will have to try and remember to have a check later.
    I was having doubts so I checked again and copied a file over to ntfs.
    I could be mistaken though, maybe I installed support without knowing.
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  6. #6
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by .lonewolf View Post
    I was having doubts so I checked again and copied a file over to ntfs.
    I could be mistaken though, maybe I installed support without knowing.
    I'm checking out shamans new installer right now and so far it is looking very good, so I will try and have a look later.

    It wouldn't be the first time I was wrong, and I am quite happy to be shown to be so. With all the new features in bt3, it would be very easy for me to miss something like that.

  7. #7
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    Quote Originally Posted by balding_parrot View Post
    I'm checking out shamans new installer right now and so far it is looking very good, so I will try and have a look later.

    It wouldn't be the first time I was wrong, and I am quite happy to be shown to be so. With all the new features in bt3, it would be very easy for me to miss something like that.
    I'm wrong more often than not

    Precisely why i love BT3 so much, it has all the essential elements and the most amazing features, as is. And the rest is an awesome journey.
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  8. #8
    Member
    Join Date
    Jan 2007
    Posts
    242

    Default

    You are both right.

    When you boot a computer with BT that has a ntfs formatted hard drive, it sets the mount option in /etc/fstab to ntfs-3g, which has write support.

    When you insert a ntfs formatted usb drive, it sets the mount option in fstab to ntfs ro (read-only).

    To mount your ntfs formatted usb drive rw make sure it isn't already mounted, open a console and

    ntfs-3g /dev/sda1 /mnt/sda1 #your device may be different.

    To the original poster:

    You should try the "mount" command with no options. It will show you what is mounted and how.

    Another command that is helpful is "cat /etc/fstab"

    You might also try:
    man mount
    man fstab
    man ntfs-3g

    Have Fun

  9. #9
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Thank you for the info ghaze, it seems we both had part of the full story and in effect were as you say in effect both right.
    As far as I'm concerned that is a win win situation.

    Now with any luck, the information you have provided will answer the OP's question and everybody will be happy.

    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •