Results 1 to 9 of 9

Thread: WUSB54GC Driver problem

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    4

    Default WUSB54GC Driver problem

    Hello all

    Im new to linux so please be gentle

    Ive been trying to use WUSB54GC with Backtrack 2.0 and 3.0 Live with limited success.

    Airedump seems to work ok, aireplay however seams to have very slow injection/capure (less than 200 a minute). From reading the forum it seams backtrack is loading the incorrect driver RT2500 and it needs to be loading RT73

    I have tried this on multiple laptops and the problem is the same across the board so i assume other people have had exactly the same problem with this Card

    I have tried the mini guide written by "shamanvirtuel" hxxp://forums.remote-exploit.org/showthread.php?t=10074

    But when i use:

    Rmmod rt2750, it throws an error

    Airmon-ng install 31, it says its missing kernal headers

    Could someone give me a good guide of how to install this card right on BT 2.0 or 3.0 live as im at my wits end.

    Thanks, Dan

  2. #2
    Junior Member stasik's Avatar
    Join Date
    Dec 2007
    Posts
    29

    Default

    i have the same card.i installed the rt73 driver as mentioned on backtrack wiki and still the same story.if i use the default settings (500 pps), it runs ok for some seconds then it seems to hand and do nothing ( no arp packets increases while sent packed increas). so i just use option -x with some digit,which works best for me.i use bt3

  3. #3
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    4

    Default

    Do you think problem installing the r73 driver related to running it off a live cd.

  4. #4
    Junior Member stasik's Avatar
    Join Date
    Dec 2007
    Posts
    29

    Default

    i dont think it makes difference it it is installed or running live. u still can install the driver if running live. i think u should try both bt2 and bt3 and see which works better.for me the best way is bt2 with driver. i also noticed that depend on pc. a havent a clue why and how... just keep messing arround

  5. #5
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    5

    Default Howto WUSB54GC

    I made this howto for Sacchand, he PM'ed me because he wanted to know how I got WUSB54GC working:

    I did this on BT2, but it should work exactly the same on BT3-beta

    First of all, you need to download this:

    h**p://homepages.tu-darmstadt.de/~p_larbig/wlan/rt73-k2wrlz-2.0.1.tar.bz2
    (just save to root)
    (this comes from shamanvirtuel's thread: h**p://forums.remote-exploit.org/showthread.php?t=9376&highlight=rt73)
    Code:
    -Shutdown WUSB54GC:
    ifconfig rausb0 down
    
    -Uninstall drivers:
    rmmod rt73
    
    -Extract new drivers to root:
    tar -xvjf rt73-k2wrlz-2.0.1.tar.bz2
    
    -cd to driver dir + install it:
    cd rt73-k2wrlz-2.0.1
    cd Module
    make
    make install
    modprobe rt73
    
    -ready to go:
    ifconfig rausb0 up
    iwconfig rausb0 mode monitor channel xx rate 1M
    
    -now try to capture packets:
    airmon-ng stop rausb0
    macchanger -m xx:xx:xx:xx:xx:xx
    airmon-ng start rausb0
    airodump-ng rausb0
    etc.....

    Please let me know if it works!

    Good luck!

  6. #6
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    6

    Default

    Quote Originally Posted by Master004 View Post
    I made this howto for Sacchand, he PM'ed me because he wanted to know how I got WUSB54GC working:

    I did this on BT2, but it should work exactly the same on BT3-beta

    First of all, you need to download this:

    h**p://homepages.tu-darmstadt.de/~p_larbig/wlan/rt73-k2wrlz-2.0.1.tar.bz2
    (just save to root)
    (this comes from shamanvirtuel's thread: h**p://forums.remote-exploit.org/showthread.php?t=9376&highlight=rt73)
    Code:
    -Shutdown WUSB54GC:
    ifconfig rausb0 down
    
    -Uninstall drivers:
    rmmod rt73
    
    -Extract new drivers to root:
    tar -xvjf rt73-k2wrlz-2.0.1.tar.bz2
    
    -cd to driver dir + install it:
    cd rt73-k2wrlz-2.0.1
    cd Module
    make
    make install
    modprobe rt73
    
    -ready to go:
    ifconfig rausb0 up
    iwconfig rausb0 mode monitor channel xx rate 1M
    
    -now try to capture packets:
    airmon-ng stop rausb0
    macchanger -m xx:xx:xx:xx:xx:xx
    airmon-ng start rausb0
    airodump-ng rausb0
    etc.....

    Please let me know if it works!

    Good luck!

    I always get an error 1

  7. #7
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    1

    Default Awesome!!! It Works!!!

    HELLO EVERYONE! I WAS HAVING ISSUES WITH MY LINKSYS WUSB54GC ADAPTER AND I JUST FOUND THIS GUIDE TO LOAD THE NEW DRIVER AND I JUST WANNA THANK "MASTER" AND "SHAMANVIRTUEL" AND ANYBODY WHO HELPED WITH THIS ISSUE. I FOLLOWED THOSE STEPS TO INSTALL THE NEW DRIVER AND STARTED CRACKING...AMAZING! YOU GUYS SHOULD SEE THE SPEED OF THOSE PACKETS BEING INJECTED! IT'S BEEN 14 MINUTES AND I'M UP TO 430,000 #DATA COLLECTED, LIKE 700 IVs PER SECOND...AMAZING! BY THE WAY, I HAVE A DELL LATITUDE C640, PENTIUM 4 2GHZ, IN CASE SOMEBODY WANTS TO KNOW. ANY QUESTIONS, PLEASE ASK. THANKS!!!!

  8. #8
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Please try to be a adult and not type in all caps. I personally find it annoying and juvenile.

  9. #9
    Junior Member Thunderbirdboy's Avatar
    Join Date
    Feb 2010
    Posts
    26

    Default

    I am using the same card and had the same problems with bt2.
    Tjeck out the thread: "rt73/rt2500 driver problem"
    ShamanVirtuel was very nice and helped me to update the driver. Everything has work since then.
    With bt3beta it is not a problem for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •