Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: -=Solved=- Problem with atheros

  1. #1
    Just burned his ISO
    Join Date
    Jan 2007
    Posts
    2

    Default -=Solved=- Problem with atheros

    Hi,

    I still haven't found any solution for this bugs. I use MacBook for installing bt3 and everything runs smoothly until problem occured with wireless connection.

    02:00.0 Network controller: Atheros Communications, Inc. AR5418 802.11a/b/g/n Wireless PCI Express Adapter (rev 01)

    The connection to AP used to disconnect. When it disconnect, i tried to re-scan the network but it failed, reload the drivers and tried to scan the AP network and it failed. First I thought something wrong with my AP but it's oke to other's machine. The solution i got for this problem now is *always* reboot the machine to get the wireless connection.

    Anyone ever had this problem before?

  2. #2
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default

    Yes, same here!

  3. #3
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Its not a bug...its your drivers. I'm moving to BT3 general. Update your madwifi drivers to fix the internet reconnection issues.

    Have you even tried yo update your madwifi-ng drivers ?? Also wouldn't hurt to update your dev version of aircrack-ng to the newest version.



    MADWIFI DRIVERS version 0.9.3.3
    http://downloads.sourceforge.net/mad...5&big_mirror=0

    to install.....

    Code:
    ifconfig ath0 down
    ifconfig wifi0 down
    cd madwifi-0.9.3.3
    cd scripts
    ./madwifi-unload.bash
    ./find-madwifi-modules.sh $(uname -r)
    cd ..
    make
    make install
    modprobe ath_pci
    THATS IT!!

    For the latest aircrack-ng suite Developmental version.....

    Code:
    svn co http://trac.aircrack-ng.org/svn/branch/1.0-dev/ aircrack-ng
    cd aircrack-ng
    gmake SQLITE=true
    gmake SQLITE=true install
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  4. #4
    Junior Member
    Join Date
    Jan 2008
    Posts
    44

    Default


    MADWIFI DRIVERS version 0.9.3.3

    to install.....

    Code:
    ifconfig ath0 down
    ifconfig wifi0 down
    cd scripts
    ./madwifi-unload.bash
    ./find-madwifi-modules.sh $(uname -r)
    cd ..
    make
    make install
    modprobe ath_pci
    THATS IT!!
    I still can't get this to install.... im still getting the KERNELPATH= blahlblah not found.. then i did some snooping around and found the /kernel/2.6.21.5/ and then it says conf not found... Ive searched and read but havn't been able to find anything... thanks for the help in advanced!

  5. #5
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Quote Originally Posted by zero visual View Post
    I still can't get this to install.... im still getting the KERNELPATH= blahlblah not found.. then i did some snooping around and found the /kernel/2.6.21.5/ and then it says conf not found... Ive searched and read but havn't been able to find anything... thanks for the help in advanced!
    Download the kernel sources here>>Put them in your /root or "Home" directory (same thing)...and run the command....

    Code:
     lzm2dir kernel.lzm /
    .................................^^^......thats a space between kernel.lzm and the / symbol.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  6. #6
    Junior Member
    Join Date
    Jan 2008
    Posts
    44

    Default

    Quote Originally Posted by -=Xploitz=- View Post
    Download the kernel sources here>>Put them in your /root or "Home" directory (same thing)...and run the command....

    Code:
     lzm2dir kernel.lzm /
    .................................^^^......thats a space between kernel.lzm and the / symbol.
    I just did that right after i posted.. Now im getting

    checking requirements ... ok
    checking kernal configuration... ok.
    make -C /lib/modules/2.6.21.5/build SUBDIRS=/root/madwifi-0.9.3.3'
    Makefiel:278: /usr/src/linux-2.6.21.5/scripts/Kbuild.include: No such file or directory
    /bin/sh: line0: [: -lt: unary operator expected
    ERROR: Kernel configuration is invalid.
    include/linux/autoconf.h or include/config/auto.conf are missing.
    Run 'make oldconfig && make prepare' on kernel src to fix it

    make[1]: *** No rule to make target '/usr/src/linux-2.6.21.5/scripts.Kbuild.include'. Stop.
    make[1]: Leaving directory '/usr/src/linux-2.6.21.5'
    make:*** [modules] Error 2





    Should i reinstall BT3?

  7. #7
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Quote Originally Posted by zero visual View Post
    I just did that right after i posted.. Now im getting

    checking requirements ... ok
    checking kernal configuration... ok.
    make -C /lib/modules/2.6.21.5/build SUBDIRS=/root/madwifi-0.9.3.3'
    Makefiel:278: /usr/src/linux-2.6.21.5/scripts/Kbuild.include: No such file or directory
    /bin/sh: line0: [: -lt: unary operator expected
    ERROR: Kernel configuration is invalid.
    include/linux/autoconf.h or include/config/auto.conf are missing.
    Run 'make oldconfig && make prepare' on kernel src to fix it

    make[1]: *** No rule to make target '/usr/src/linux-2.6.21.5/scripts.Kbuild.include'. Stop.
    make[1]: Leaving directory '/usr/src/linux-2.6.21.5'
    make:*** [modules] Error 2





    Should i reinstall BT3?
    Never ran across that error. See what I bolded in your quote?? Try that. Specifically the last bolded line.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  8. #8
    Junior Member
    Join Date
    Jan 2008
    Posts
    44

    Default

    Quote Originally Posted by -=Xploitz=- View Post
    Never ran across that error. See what I bolded in your quote?? Try that. Specifically the last bolded line.
    I am just going to do a Fresh install and hopefully it will work.. i was up late lastnight and might have deleted some things.

  9. #9
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Very well.

    Best of luck to you this time.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  10. #10
    Junior Member
    Join Date
    Jan 2008
    Posts
    44

    Default

    worked like a charm...
    heres what i did
    -reinstalled BT3
    -kernel.lzm
    -Aircrack-ng update
    -Madwifi-0.9.3.3 update
    Im running a macbook 13.3"
    thanks for the help Xploitz.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •