Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How To Browse Using LAN with Backtrack 2

  1. #1
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    6

    Default How To Browse Using LAN with Backtrack 2

    Hi,

    I just recently started using Backtrack 2 using the live cd. Everything is working perfectly except that i cant browse the internet or see my network using my lan card. Am using a hp laptop dv2130us with an Intel(R) PRO/Wireless 3945ABG Network Connection as my wireless card and an Intel(R) PRO/100 VE Network Connection for my lan card. Since the Backtack 2 comes with the latest drivers for my wireless card, i have no problems but its my lan card thats giving me problems. i have tried the netconfig command. i set everything up but still no packets are received or sent. Am a new convert to linux so i might not know some ofthe basic commands to set it up. please help. thank you. samir.

  2. #2
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    In a console do........

    Code:
    modprobe e100
    .......then you bring it up with....

    Code:
    ifconfig eth0 up
    (or whatever the card is - if the wireless is already up and designated as eth0 then your lan card will be eth1
    Do ifconfig to see the how the wlan card is designated and take it from there)

    ....and then you'll be able to use it.

  3. #3
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006
    Posts
    1,031

    Default

    Also dhcpcd eth0

    (or whatever your card is) wouldn't hurt. Sometimes I have to run that in order to get internet on my ethernet card.
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

  4. #4
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    6

    Default

    Hi,

    Thank you for your prompt reply. i have tried most of these commands. My wireless card is set as eth0. Now i dont know exactly what my lan card is set to and how to find out. i have tried the modprobe, lspci, netsta, lsmod and other commands but i can't comprehend the output or how to use the information. thanks

  5. #5
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    6

    Default How To Browse Using LAN with Backtrack 2

    Hi,

    Thanks for you prompt and quick reply.

    i tried the commands but its still not going on the network. i tried several other commands as well like lspci, lsmod, netstat, dhcp, and others but to no avail. Also my wireless card is set to eth0, therefore i dont know what my lan card is set to. is there any particular program in backtrack 2 that i can use to detet the lan card ? pls help. thank you.

  6. #6
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default

    Search the forums for "3945" there are lots of threads about it, and check http://forums.remote-exploit.org/showthread.php?t=1489 in the Tutorials section.
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  7. #7
    Senior Member streaker69's Avatar
    Join Date
    Jan 2010
    Location
    Virginville, BlueBall, Bird In Hand, Intercourse, Paradise, PA
    Posts
    3,535

    Default

    Quote Originally Posted by spankdidly View Post
    Also dhcpcd eth0

    (or whatever your card is) wouldn't hurt. Sometimes I have to run that in order to get internet on my ethernet card.
    Please say that you just wrote that so the newb would understand and that you don't really talk that way.
    A third party security audit is the IT equivalent of a colonoscopy. It's long, intrusive, very uncomfortable, and when it's done, you'll have seen things you really didn't want to see, and you'll never forget that you've had one.

  8. #8
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    Quote Originally Posted by thorin View Post
    Search the forums for "3945" there are lots of threads about it, and check http://forums.remote-exploit.org/showthread.php?t=1489 in the Tutorials section.

    The 3945 wlan card is working fine, as I understood it.

    Its the Intel Pro 100/ve that is the issue.


    Quote Originally Posted by samir101ng View Post
    Hi,

    I just recently started using Backtrack 2 using the live cd. Everything is working perfectly except that i cant browse the internet or see my network using my lan card. Am using a hp laptop dv2130us with an Intel(R) PRO/Wireless 3945ABG Network Connection as my wireless card and an Intel(R) PRO/100 VE Network Connection for my lan card. Since the Backtack 2 comes with the latest drivers for my wireless card, i have no problems but its my lan card thats giving me problems. i have tried the netconfig command. i set everything up but still no packets are received or sent. Am a new convert to linux so i might not know some ofthe basic commands to set it up. please help. thank you. samir.

    Usually it's a simple modprobe e100 but apparently that isn't working!?

    You do realise that "modprobe e100" won't give you "output" as you call it in your post? It loads the driver module.

    Then you can do "ifconfig eth1 up" (as your wlan will be eth0) Again, you'll see no output resulting from the command (unless you don't have an eth1!).

    Then you can do "ifconfig" just for confirmation, which *should* show output, confirming that you now have an eth0 and an eth1 device.

    Next, if you want the simplest way, just use the "set IP address" gui on your eth1 device (lan card) otherwise type "dhcpcd eth1" if you use dhcp on your network.

    I realise that I'm pretty much repeating myself here, but can you confirm you are doing these steps in this order, from a fresh boot, please?

  9. #9
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default

    Quote Originally Posted by Re@lity View Post
    The 3945 wlan card is working fine, as I understood it.
    I didn't mean to suggest it wasn't, I just knew that there had been other threads on it lately that might point him to an answer (without all of us typing the same text over and over again).
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  10. #10
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006
    Posts
    1,031

    Default

    Quote Originally Posted by streaker69 View Post
    Please say that you just wrote that so the newb would understand and that you don't really talk that way.
    In my defense, I have a turkey hang-over. And yes, looking back at what I wrote, I realized that I talked like a nubcake pwnsauce. I appologize.

    I was trying to simplify things, and sounded retarded at the same time. 2 birds with one stone? Yes...
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •