Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Problems with SVN up / msfupdate in BT5 r3

  1. #1
    Just burned his ISO
    Join Date
    Aug 2012
    Location
    Somewhere in the ether
    Posts
    6

    Default Problems with SVN up / msfupdate in BT5 r3

    My apologies if this is in the wrong place.

    running into an issue using svn up to update MSF. I'm using to being able to use svn up to update the framework directory, but doing so in R3 nets me the following error:

    Code:
    this client is too old to work with working copy '.' . You need to get a newer Subversion client, or to downgrade this working copy. See http://subversion.tigris.org/faq.htm...-format-change for details.
    so... I do that, get redirected to the apache subversion faq, and find this:

    http://subversion.apache.org/faq.htm...-format-change

    I wget the python script in question, and based off of another document I found via google-fu, run the script as such:

    Code:
    python change-svn-wc-format.py /pentest/exploits/framework 1.5
    and get the error:
    Code:
    Unrecognized WC format 12 in '/pentest/exploits/framework/.svn/entries'; only formats 8,9 and 10 can be supported.
    So figuring that the howto I found on google is outdated or wrong, I tried other things.

    I tried updating the svn client and apt says its fully updated. As a last resort, I try the msfupdate script in the directory and that works. I'm using that for now and if this is the supported method of doing it, that's fine. Tell me to eff off, and I'll go about my business. I'm just curious as to why svn up no longer works, yet msfupdate, svn-based, does work.

    Thanks,

    DA

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    11

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    hi,
    i had the same problem with updating the msf-framework, i did the followings steps:

    - rm -rf /opt/metasploit/msf3/ --(removing msf direcorty)
    - svn co http://www.metasploit.com/svn/framework3/trunk msf3 --(re downloading all the msf-framework from source)
    - ln -s /opt/metasploit/msf3 /pentest/exploits/framework --(symbolic link inside /pentest/exploits directory)

    Now the command svn up inside the dir is working good, surely not the best solution for the problem but at least is working

  3. #3
    Just burned his ISO
    Join Date
    Aug 2012
    Location
    Somewhere in the ether
    Posts
    6

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    Quote Originally Posted by johnjohnsp1 View Post
    hi,
    i had the same problem with updating the msf-framework, i did the followings steps:

    - rm -rf /opt/metasploit/msf3/ --(removing msf direcorty)
    - svn co http://www.metasploit.com/svn/framework3/trunk msf3 --(re downloading all the msf-framework from source)
    - ln -s /opt/metasploit/msf3 /pentest/exploits/framework --(symbolic link inside /pentest/exploits directory)

    Now the command svn up inside the dir is working good, surely not the best solution for the problem but at least is working

    I was going to try that next. Anytime MSF starts acting funky I'll usually remove it via apt-get, re-install the apt package, create a symbolic link to /pentest/exploits/framework and svn up (as well as whatever else was broken) will usually work fine.

    Thanks for the input, and have a nice day.

  4. #4
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    Here is the simpler solution:
    Code:
    apt-add-repository ppa:svn/ppa
    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 72BF9B1DCEB42852D7710ECAEAA903E3A2F4C039
    gpg: requesting key A2F4C039 from hkp server keyserver.ubuntu.com
    gpg: key A2F4C039: public key "Launchpad Subversion" imported
    gpg: Total number processed: 1
    gpg:               imported: 1  (RSA: 1)
    apt-get update
    apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following NEW packages will be installed:
      libserf1
    The following packages will be upgraded:
      libsvn1 subversion
    2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2,420kB of archives.
    After this operation, 635kB of additional disk space will be used.
    Do you want to continue [Y/n]?

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    over the under
    Posts
    197

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    @ask0n Thanks that worked quite well!

  6. #6
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    Quote Originally Posted by ask0n View Post
    Here is the simpler solution:
    Code:
    apt-add-repository ppa:svn/ppa
    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 72BF9B1DCEB42852D7710ECAEAA903E3A2F4C039
    gpg: requesting key A2F4C039 from hkp server keyserver.ubuntu.com
    gpg: key A2F4C039: public key "Launchpad Subversion" imported
    gpg: Total number processed: 1
    gpg:               imported: 1  (RSA: 1)
    apt-get update
    apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following NEW packages will be installed:
      libserf1
    The following packages will be upgraded:
      libsvn1 subversion
    2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2,420kB of archives.
    After this operation, 635kB of additional disk space will be used.
    Do you want to continue [Y/n]?
    I registered just to say thank you! This problem has been driving me nuts the last week and this did the trick!

  7. #7
    Junior Member Lancha's Avatar
    Join Date
    Mar 2012
    Location
    in volcano
    Posts
    30

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    when i try run my metasploit i have this errors [-] WARNING! The following modules could not be loaded!
    [-] /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb: SyntaxError /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:35: syntax error, unexpected tLSHFT, expecting ')'
    <<<<<<< .mine
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected tASSOC, expecting keyword_end
    'Version' => '$Revision: 16005 $',
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected tASSOC, expecting keyword_end
    'Platform' => [ 'windows' ],
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected tASSOC, expecting keyword_end
    'Version' => '$Revision: 16005 $',
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected tASSOC, expecting keyword_end
    'Platform' => [ 'win' ],
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:42: syntax error, unexpected tASSOC, expecting keyword_end
    'SessionTypes' => [ 'meterpreter' ]
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:43: syntax error, unexpected ')', expecting keyword_end
    ))
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:379: syntax error, unexpected $end, expecting keyword_end
    Last edited by Lancha; 10-31-2012 at 01:50 PM.

  8. #8
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    Quote Originally Posted by Lancha View Post
    when i try update my metasploit i have this errors [-] WARNING! The following modules could not be loaded!
    [-] /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb: SyntaxError /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:35: syntax error, unexpected tLSHFT, expecting ')'
    <<<<<<< .mine
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected tASSOC, expecting keyword_end
    'Version' => '$Revision: 16005 $',
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected tASSOC, expecting keyword_end
    'Platform' => [ 'windows' ],
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected tASSOC, expecting keyword_end
    'Version' => '$Revision: 16005 $',
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected tASSOC, expecting keyword_end
    'Platform' => [ 'win' ],
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected ',', expecting keyword_end
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:42: syntax error, unexpected tASSOC, expecting keyword_end
    'SessionTypes' => [ 'meterpreter' ]
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:43: syntax error, unexpected ')', expecting keyword_end
    ))
    ^
    /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:379: syntax error, unexpected $end, expecting keyword_end



    1 - Go to Places> Search for files> Search for outlook.rb in file system!
    2 - Delete all files found
    3 - Open the terminal> msfupdate

  9. #9
    Junior Member Lancha's Avatar
    Join Date
    Mar 2012
    Location
    in volcano
    Posts
    30

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    ok i gonna try
    thanks for the help

  10. #10
    Junior Member Lancha's Avatar
    Join Date
    Mar 2012
    Location
    in volcano
    Posts
    30

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    i have a another problem
    i solve
    the problem it is when i open the artimage
    Unable to handle kernel NULL pointer dereference at virtual address 0xd34db33f
    EFLAGS: 00010046
    eax: 00000001 ebx: f77c8c00 ecx: 00000000 edx: f77f0001
    esi: 803bf014 edi: 8023c755 ebp: 80237f84 esp: 80237f60
    ds: 0018 es: 0018 ss: 0018
    Process Swapper (Pid: 0, process nr: 0, stackpage=80377000)


    Stack: 90909090990909090990909090
    90909090990909090990909090
    90909090.90909090.90909090
    90909090.90909090.90909090
    90909090.90909090.09090900
    90909090.90909090.09090900
    ..........................
    cccccccccccccccccccccccccc
    cccccccccccccccccccccccccc
    ccccccccc.................
    cccccccccccccccccccccccccc
    cccccccccccccccccccccccccc
    .................ccccccccc
    cccccccccccccccccccccccccc
    cccccccccccccccccccccccccc
    ..........................
    ffffffffffffffffffffffffff
    ffffffff..................
    ffffffffffffffffffffffffff
    ffffffff..................
    ffffffff..................
    ffffffff..................


    Code: 00 00 00 00 M3 T4 SP L0 1T FR 4M 3W OR K! V3 R5 I0 N4 00 00 00 00
    Aiee, Killing Interrupt handler
    Kernel panic: Attempted to kill the idle task!
    In swapper task - not syncing

Page 1 of 2 12 LastLast

Similar Threads

  1. BT5-Gnome-VM: msfupdate does not work
    By halo3 in forum BackTrack 5 Beginners Section
    Replies: 6
    Last Post: 05-26-2011, 09:34 PM
  2. BT5-Gnome-VM: msfupdate does not work
    By halo3 in forum BackTrack 5 Bugs
    Replies: 1
    Last Post: 05-12-2011, 05:55 AM
  3. Error al actualizar Metasploit con msfupdate
    By hackmaf in forum Soporte en Software
    Replies: 2
    Last Post: 01-17-2011, 03:30 AM
  4. Framework3-MsfUpdate not working?
    By imported_mzer0 in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 0
    Last Post: 03-03-2009, 06:53 AM
  5. Framework3 Msfupdate failed
    By Bud Jones in forum OLD Pentesting
    Replies: 7
    Last Post: 02-14-2009, 04:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •