Results 1 to 3 of 3

Thread: Issue with NMAP using the -sI command

  1. #1
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Cool Issue with NMAP using the -sI command

    when Im trying to run a zombie scan using an idle machine with the ip of 10.0.0.10, to scan the ip of 10.0.0.31, I get some odd errors.

    Here's the command I'm using: nmap -PN -sI 10.0.0.10 10.0.0.31 * exec: nmap -PN -sI 10.0.0.10 10.0.0.31

    which gives me a bunch of errors like this

    Failed to resolve given hostname/IP: plugins. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: README. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: scripts. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: test. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges

    etc etc etc.......
    Im new so take pity on me

    Thanks

  2. #2
    Junior Member
    Join Date
    Jun 2010
    Posts
    28

    Default Re: Issue with NMAP using the -sI command

    Quote Originally Posted by Z3R0C00 View Post
    when Im trying to run a zombie scan using an idle machine with the ip of 10.0.0.10, to scan the ip of 10.0.0.31, I get some odd errors.

    Here's the command I'm using: nmap -PN -sI 10.0.0.10 10.0.0.31 * exec: nmap -PN -sI 10.0.0.10 10.0.0.31

    which gives me a bunch of errors like this

    Failed to resolve given hostname/IP: plugins. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: README. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: scripts. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges
    Failed to resolve given hostname/IP: test. Note that you can't use '/mask' and '1-4,7,100-' style ip ranges

    etc etc etc.......
    Im new so take pity on me

    Thanks
    Not sure if the * is valid but from the error nmap seems to think you are trying to use it as a wildcard and IP ranges are not allowed also not sure what -PN option is supposed to do but try without it and add -v or -vv for verbose output may help to diagnose it
    Last edited by promark; 08-11-2011 at 11:31 PM.
    There's no place like ~/

  3. #3
    Very good friend of the forum Gitsnik's Avatar
    Join Date
    Jan 2010
    Location
    The Crystal Wind
    Posts
    851

    Default Re: Issue with NMAP using the -sI command

    The * is mapping out the local files:

    bash-3.2$ ls
    cleanup insecurity stealth
    bash-3.2$ echo *
    cleanup insecurity stealth
    bash-3.2$

    Which is where your problem appears to be arising:

    bash-3.2$ echo 192.168.1.*
    192.168.1.*
    bash-3.2$

    Works fine, however, because it is not a * character on its own.

    And yes, * is valid in nmap, but it should be attached somewhere (nmap *.10.23.11 will scan every IP that matches: 1.10.23.11 2.10.23.11 3.10.23.11 and so on... not a good idea).

    The giveaway is the hostnames having what look like filenames in them. Should have been your first indicator
    Still not underestimating the power...

    There is no such thing as bad information - There is truth in the data, so you sift it all, even the crap stuff.

Similar Threads

  1. [nmap] - Erro no Nmap
    By F0K3R in forum Suporte Software
    Replies: 4
    Last Post: 12-08-2010, 09:58 PM
  2. Nmap issue
    By skull2006 in forum Beginners Forum
    Replies: 11
    Last Post: 10-18-2010, 02:47 PM
  3. NMAP Issue + Keyboard
    By mozie in forum Beginners Forum
    Replies: 1
    Last Post: 08-04-2010, 03:39 PM
  4. Plz help with nmap
    By yucatans in forum OLD Newbie Area
    Replies: 4
    Last Post: 12-09-2008, 01:05 AM
  5. Airodump-ng Issue + Aireplay-ng Issue
    By whiteice in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-05-2008, 05:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •