Results 1 to 10 of 10

Thread: Another Networking Problem... Please bear with me!

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    11

    Default Another Networking Problem... Please bear with me!

    I've been using Back|Track on Virtualbox, and it worked great. I decided to burn it to a DVD as a live DVD.

    Everything worked out great, until I got to the internet. I used google to the best of my ability, and managed to Wicd Network Manager working. It found my wireless network, I entered the password in the settings box, and did everything. The problem is, whenever I try to connect, it goes through all the steps, but hangs on authenticating. I'm not sure if that's supposed to happen. Then, everything stops and it says Not connected again.

    Also, though this might be an entirely different problem, the Wicd doesn't capture networks for more than 10 minutes, after which it shows "No wireless networks detected." I have to go back to Konsole and use the # /etc/init.d/wicd start command to get it to work.

    I'm not a super backtrack, or even Linux, expert here, so I don't know all the commands. I'm just reading my Gray Hat Hacking book that suggested I use Back|Track. I've searched the forums, but I may have missed something. If there is already a thread with a solution, please point me to it, and feel free to call me n00b!

  2. #2
    Member macphail's Avatar
    Join Date
    Jun 2010
    Location
    East Coast, USA
    Posts
    164

    Default Re: Another Networking Problem... Please bear with me!

    There are other users who have had similar problems. A good search of the site will uncover possible resolutions.
    Here's a good start:
    http://www.backtrack-linux.org/forum...earchid=449891

    of course, if you read the rest of this thread, you'll see that the link above doesn't work. that's because I'm a moron. however, I'm sure you get the idea...


    also, when posting for assistance it is usually best to let people know the hardware and drivers, etc.....(hint: search for your wifi card model, specific errors you come across, etc.)
    Last edited by macphail; 08-04-2010 at 08:47 PM. Reason: because i'm a moron.
    -----------
    ~peace
    MacPhail

  3. #3
    Member
    Join Date
    Jul 2010
    Location
    Holland
    Posts
    110

    Default Re: Another Networking Problem... Please bear with me!

    Quote Originally Posted by macphail View Post
    There are other users who have had similar problems. A good search of the site will uncover possible resolutions.
    Here's a good start:
    http://www.backtrack-linux.org/forum...earchid=449891

    also, when posting for assistance it is usually best to let people know the hardware and drivers, etc.....(hint: search for your wifi card model, specific errors you come across, etc.)
    Sorry, link is not good.

  4. #4
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    11

    Default Re: Another Networking Problem... Please bear with me!

    I would have, but it didn't seem relevant because this wouldn't work on my desktop or laptop. It showed the same error both times, and they were completely different models and make. Also, I noticed that it didn't ask me for a login/password, even though it does ask for that on Virtualbox. Is this because it is on a Live DVD?

  5. #5
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Another Networking Problem... Please bear with me!

    Quote Originally Posted by TheFlyingDutchMan View Post
    Sorry, link is not good.
    While the link may not work the technique does. Try searching the forums as mentioned by macphail.

    macpahil, it's true searches don't resolve properly since the search id changes all the time with new posts, threads etc.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  6. #6
    Just burned his ISO
    Join Date
    Apr 2010
    Location
    Boston
    Posts
    2

    Default Re: Another Networking Problem... Please bear with me!

    While I am new here I recently had a problem similar to this.

    I would resolve wireless networks and then try to connect. My problem came when obtaining an IP. It would continue to try to connect with no success.

    I found that by changing my WPA Supplicant driver I was able to connect. I would suggest trying that. You can find it under the WICD preferences.

    This is the suggestion of someone who is learning also so please bear in mind that my information not be dead accurate.

  7. #7
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    11

    Default Re: Another Networking Problem... Please bear with me!

    Thanks fbxxkl. I'll try that and get back to you as soon as I can.

  8. #8
    Just burned his ISO
    Join Date
    Jul 2010
    Location
    That would be telling !
    Posts
    12

    Default A good solution to get you through the night !

    Well mohanbharath,

    As i said in message...do try those commands,

    when you boot linux up you have to set up the network connection with a couple of commands in a shell,as bt does not do this automatically for security reasons....nice

    If all fails..all is not lost...to get by for now do this if you have a spare laptop etc.

    1.Run windows on the spare box..and get your connection with this.

    2.connect your linux pc to this with a ethernet cable and use windows ics to share connection.

    3.on your linux pc you could run bt in vmware with windows as host no problem...

    also doing this means you can try another linux os aswell.....

    no wifi issue then,and thus,this gives you a teacher and a student set up....know what im saying

    learn on one (videos etc) while being practical on the other my brother..(+u only need 1 mac changer aswell..lol)

    human rights to tommatos man !

  9. #9
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    11

    Default Re: Another Networking Problem... Please bear with me!

    Alright, I'm back, and now I feel compelled to mention that it won't even bring up wlan0 on my laptop. The card is a Dell Wireless 1397 WLAN Mini-Card. I don't want to try anything on the desktop until I'm sure it will work, because it is new, and I don't want to damage it. But I'll also state that my desktop card is an Atheros 802.11 a/b/g/n Dualband Wireless Network Module. On my laptop, which is what I use for pen testing, it cannot find the device for wlan0. It also still does not ask me for a login/pass whenever I boot, and I find this strange. Help would be appreciated, as I don't want to be stuck using backtrack on just one machine!

  10. #10
    Member macphail's Avatar
    Join Date
    Jun 2010
    Location
    East Coast, USA
    Posts
    164

    Default Re: Another Networking Problem... Please bear with me!

    i haven't searched until my fingers bled, but you mentioned Broadcom and that caught my attention.
    Broadcom sucks for linux in general and for BT in specific (not to put too fine of a point on it).

    There may have been improvements in BT4 that I missed, but check out this old thread for a possible solution:
    Dell Studio 15 - 1397 (Broadcom chipset) - Remote Exploit Forums

    and yeh, my link will work this time...
    -----------
    ~peace
    MacPhail

Similar Threads

  1. /etc/init.d/networking start problem?
    By imsorrisuck in forum Beginners Forum
    Replies: 5
    Last Post: 03-03-2010, 08:35 AM
  2. Boot problem (loooooong) with networking problems.
    By michelinok in forum OLD BackTrack 4 General Support
    Replies: 4
    Last Post: 01-08-2010, 03:39 PM
  3. HP Netbook 311 and Backtrack 4 PR Networking Problem
    By manic in forum OLD Newbie Area
    Replies: 5
    Last Post: 12-06-2009, 12:47 AM
  4. backtrack4 in vmware networking problem
    By imported_hackjkp in forum OLD BackTrack 4 General Support
    Replies: 4
    Last Post: 10-01-2009, 05:01 PM
  5. -=SOLVED=- Networking Problem (no wired LAN)
    By kastro in forum OLD Newbie Area
    Replies: 4
    Last Post: 10-15-2007, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •