Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Actualizar kernel Backtrack 4 pre-final

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    22

    Default Actualizar kernel Backtrack 4 pre-final

    Tenemos que ejecutar los siguientes comandos para actualizarnos al ultimo kernel y ultimos drivers:

    Code:
    apt-get update
    apt-get install -d linux-image
    cd /var/cache/apt/archives/
    dpkg -i –force all linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb
    apt-get dist-upgrade
    apt-get install madwifi-drivers
    apt-get install r8187-drivers
    Saludos! x7uk

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    dpkg -i –force all linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb


    Code:
    dpkg -i --force-all linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb

  3. #3
    Junior Member
    Join Date
    Jan 2010
    Posts
    76

    Default

    que estara pasando?
    cuando intento modificar mi version de BT? con bt4-customise.sh
    root@BT4:/var/cache/apt/archives# dpkg -i --force-all linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb
    dpkg: error processing linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb
    root@BT4:/var/cache/apt/archives# dpkg -i –force all linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb
    dpkg: error processing –force (--install):
    cannot access archive: No such file or directory
    dpkg: error processing all (--install):
    cannot access archive: No such file or directory
    dpkg: error processing linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    –force
    all
    linux-image-2.6.30.5_2.6.30.5-10.00.Custom_i386.deb
    saludos y gracias anticipadas

  4. #4
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    Quote Originally Posted by manulu View Post
    que estara pasando?
    cuando intento modificar mi version de BT? con bt4-customise.sh

    cannot access archive: No such file or directory
    saludos y gracias anticipadas
    correste lo comando apt-get install -d linux-image?

    yo no hablo mucho español... sorry

  5. #5
    Junior Member
    Join Date
    Jan 2010
    Posts
    76

    Default

    he notado que la version ha cambiado

    I noticed that the version has changed to:
    dpkg -i –force all linux-image-2.6.30.7_2.6.30.7-10.00.Custom_i386.deb

  6. #6
    Just burned his ISO
    Join Date
    Nov 2009
    Posts
    17

    Default

    Hola Manulu,

    En vez de "force all" es "force-all".

    Saludos.

  7. #7
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    4

    Default

    Quote Originally Posted by Snayler View Post
    correste lo comando apt-get install -d linux-image?

    yo no hablo mucho español... sorry
    Buenas, Soy nuevo en lo que es backtrack, anteriormente utilizaba Fedora Leoninas. Tengo el mismo inconveniente con respecto a las actualizaciones, al poner " apt-get " no me reconoce el comando mucho menos si pongo " Sudo apt-get install " " yum " busque en el directorio apt en /vat/cache/ y no existe. puede que no se alla copiado el contenido completo al hacer el preserve? si tienen alguna solucion se lo agradeceria

  8. #8
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Question no se si entendi bien?

    Quote Originally Posted by Mckast View Post
    Buenas, Soy nuevo en lo que es backtrack, anteriormente utilizaba Fedora Leoninas. Tengo el mismo inconveniente con respecto a las actualizaciones, al poner " apt-get " no me reconoce el comando mucho menos si pongo " Sudo apt-get install " " yum " busque en el directorio apt en /vat/cache/ y no existe. puede que no se alla copiado el contenido completo al hacer el preserve? si tienen alguna solucion se lo agradeceria
    Hola! no se si entendí bien tus problemas, pero voy a intentar responder lo que entendí.

    1 - Queres usar yum? yum es para fedora, BackTrack esta basado en ubuntu, usa apt-get.
    es facil:
    yum = apt-get
    rpm = dpkg

    2 - Buscar el directorio /vat/cache/ ? debe ser /var/cache/
    ahí podes encontrar /var/cache/apt/archives/ que es donde se descargan todos los paquetes antes de ser instalados, es uno de los directorios que hay que acordarse de vaciar cada tanto para no llenar el disco.
    lo podes hacer con:
    #apt-get clean <--- Borra todos los paquetes descargados
    o
    #apt-get autoclean <--- que solo borra los antiguos

    3 - Para que usaste preserve, por lo que recuerdo es un parámetro que se se usaba para instalar BT4beta que no traía instalador y se podía instalar haciendo un #cp --preserve /[directorio1,directorio2,directorio3,directorio...]
    Te recomiendo que instales BT4 Final, que trae un script de instalación en el escritorio, trae muchas mas aplicaciones que la versión beta, están mas actualizadas, y te vas a ahorrar muchos problemas.
    lo podes descargar de acá:

    hxxp: // www . backtrack-linux . org /downloads/

    Saludos!

  9. #9
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    4

    Default

    entendiste mi problemas a medias lo que digo es que cuando ejecuto apt-get me dice comando desconocido, a lo que voy con VAR ( no VAT que fue un error de tipeo) es que cuando realize la instalacion con el comando cp -- preserver es que seguramente no se instalo el diectorio /var/cache/apt/ que de seguro ese es el inconveniente al ejectutar en la consola apt-get install. y si yum es para fedora, solo que lo di como un ejemplo. En fin hay algun forma de poder lograr ejecutar el comando apt-get sin tener instalado el /var/cache/apt? espero pronta respuesta

  10. #10
    Junior Member
    Join Date
    Dec 2009
    Posts
    29

    Default

    Quote Originally Posted by Mckast View Post
    entendiste mi problemas a medias lo que digo es que cuando ejecuto apt-get me dice comando desconocido, a lo que voy con VAR ( no VAT que fue un error de tipeo) es que cuando realize la instalacion con el comando cp -- preserver es que seguramente no se instalo el diectorio /var/cache/apt/ que de seguro ese es el inconveniente al ejectutar en la consola apt-get install. y si yum es para fedora, solo que lo di como un ejemplo. En fin hay algun forma de poder lograr ejecutar el comando apt-get sin tener instalado el /var/cache/apt? espero pronta respuesta
    ahaha!!! ahora si...
    es mas complicado de lo que parece, no se por que realizaste la instalación con el comando cp, yo te recomiendo que lo instales directamente desde el script que viene en el escritorio desde la version 4pre.
    La verdad que no te puedo dar muchas mas soluciones, tenes un sistema instalado a medias, es mas... todavía me pregunto como arranca?...

    Saludos!

    .
    .
    .
    hackmaf

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •