Results 1 to 6 of 6

Thread: Madwifi-ng & Cisco AIR-CB21AG-A-K9

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    3

    Angry

    I've read other posts and searched everywhere i could think of for a simple solution to my problem but im pretty sure there isnt one, need help guys hope someone can lend me there knowledge

    Card worked fine in BT2 out the box but not BT4

    So I downloaded Madwifi-hal-0.10.5.6.r4103-20100110

    i did make
    make install
    modprobe -r ath5k
    modprobe ath_pci
    ifconfig ath0 up
    ifconfig

    i also added ath5k to my blacklist

    now shows ath0 and shows my cards mac
    (lights on the card are blinking getting closer)

    heres where i run into a brick wall and dont know where to go from

    to test the card i tried to connect to my wifi and did
    iwconfig ath0 key ******** and i get this in response
    Error for wireless request set encode (8B2A)
    Set failed on device ath0 ; no such device

    i tried running airodump and get this:
    Interface ath0;
    ioctl(SIOGIFINDEX) Failed: No such device

    WIcd Network Manager doesnt show my card

    Please help guys any kind of direction would help

    Really is no one willing to chime in on this

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default

    Don't bump your threads please, if someone wants to respond they will.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  3. #3
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    Why would you want to remove ath5k driver in favour of madwifi-ng? Furthermore, do you realise there's madwifi-driver in the repository that would most likely come pre-patched for injection without you having to go downloading extra driver?

    Do you see a wifi0 interface with the madwifi-ng driver? if not then madwifi-ng may have issue detecting your card, possibly because of unsupported chipset or radio.. I'd check dmesg for information.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    3

    Default

    ath5k driver supports atheros chipset AR5001x+ ??? When i was reading up before i installed bt4 i thought i had read that it didnt...

    when i installed madwifi i get ath0 and wifi0...

  5. #5
    Senior Member
    Join Date
    Aug 2007
    Posts
    916

    Default

    ath5k should support AR5001X+ I have devices with that ID and it works with ath5k. In fact most ar5xxx devices should be supported with ath5k by now.

    You should have ath0 and wifi0 by default with madwifi-ng, you were saying about no such device, etc. That could possibly mean a collision with ath5k driver which may still be loaded on that running instance.

    BTW: You can't issue airodump-ng on ath0 without first setting it on monitor mode.

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    3

    Default

    i did a fresh install and ran a couple injection test using ath5k and injection is working fine, thnx so much for your help, you were correct i didnt even need madwifi-ng drivers, my own fault, next time i will be sure ive tried every option available before posting dumb questions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •