Results 1 to 3 of 3

Thread: Fake ap problem over ppp0

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default Fake ap problem over ppp0

    Hi,

    i'm trying to setting up a Fake Ap with an Asus EEEPC 1000HE, Backtrack 4 and a huawei e169 internet key.

    I followed the g0tmi1k method and i can make it work with the ethernet connection.

    Now i'm trying to use the ppp0 over the internet key but when i change the following command

    Code:
    iptables -t nat -A PREROUTING -p udp -j DNAT --to $gatewayip
    iptables --table nat --append POSTROUTING --out-interface $internet_interface -j MASQUERADE
    i set internet_interface to ppp0
    and the gatewayip is giving me all the trouble because i cannot get anywere the the gateway ip that the internet key is using.

    Anyone can help me to use ppp0 instead of eth0 so i can use the fake ap without my home connection?

    thanks a lot!

    Bye

  2. #2
    Senior Member Nick_the_Greek's Avatar
    Join Date
    Jan 2010
    Location
    Greece
    Posts
    181

    Default

    Quote Originally Posted by Mr.Maxs View Post
    i set internet_interface to ppp0
    and the gatewayip is giving me all the trouble because i cannot get anywere the the gateway ip that the internet key is using.
    Hi, Mr.Maxs.

    Why can't you find the IP of the ppp0 connection? What output give you the
    Code:
    ifconfig ppp0
    command?

    To be honest I can't remember if g0tmi1k's script uses dhcp daemon (I think so), but maybe you have to make some changes in dhcp.conf about DNS servers and gateway. Maybe you have to dig a little bit more to make it work with point to point connections.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default

    hi, thaks for your answer.

    I'm a little n00b but the script seems to redirect all the traffic of the fake ap on the at0 interface to the interface that connected to internet and with

    Code:
    iptables -t nat -A PREROUTING -p udp -j DNAT --to $gatewayip
    change the udp traffic from the gateway ip of at0 (10.0.0.1) to my internet gateway.

    With ethernet i use 192.168.1.1 and everything work.

    When i connect the internet key the ppp0 take some ip like 103.75.33.121 and a remote addres of P-t-p that is always 10.64.64.64.

    If i ping 10.64.64.64 i can get no response, but i can still navigate.
    the route command tell me that my net had 10.64.64.64 as gateway


    I think the problem is in this line of code

    Code:
    iptables -t nat -A PREROUTING -p udp -j DNAT --to $gatewayip
    if i give it the 10.64.64.64 ip anyone who connect to fake ap cannot use internet or ping any addres.

    It seems that the 10.64.64.64 won't accept any connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •