Results 1 to 10 of 10

Thread: rtl8187 patching issue?

  1. #1
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default rtl8187 patching issue?

    Hallo hallo

    Ive been playing around with airdump and aircrack for a few weeks to learn more about it. While I was still going from the usb it was working fine. After actually installing Bt4 it was having some issues and couldnt crack a WEP encryption. After preforming the injection test it seemed to show that my wireless adapter card didnt support injection. So I went to aircrack to get the index of patches and first of all im not exactly sure which I would need. I found the ones for my adapter which uses the rtl8187 chipset. So I decided to wing it, choose one that seemed good and went about the process I read here in an old thread about how to install patches but it doesnt seem to work x.x

    Cause when I get the file it isnt even a .tar its just a .patch so I decided to skip the unpacking step since it was just plain source code. Then I tried the ./configure thing but it says bash:command not found and the make /make install step likewise produces no results.

    Is there a specific folder it should be in? Something im just missing? idk Ive been messing around with it for about 5 or days trying to just get this one patch installed but I just seem to be lacking some critical step/info to get things going smoothly.

    Any help would be appreciated

    btw the patch im trying is rtl8187_2.6.24v3.patch if there is a different patch/more recent one I should be using that someone could make me aware of, thatd be appreciated as well. Thanks in advance.

  2. #2
    Junior Member
    Join Date
    Oct 2009
    Posts
    26

  3. #3
    Member imported_vvpalin's Avatar
    Join Date
    Apr 2009
    Posts
    442

    Default

    *sighs*

    You couldnt crack your neighbors wep so you ... forget it its not worth a ban.

    Anyways you dont need a patch with BT end of story.
    Using backtrack for the first time is like being 10 years old again with the keys to a Ferrari.

  4. #4
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default

    No my neighbors isnt even encrypted, Im cracking my own for the sake of learning how to, because ohmigodz!!! I actually want to learn something :0 >.>

    According to the results of the injection test outlined on the aircrack-ng page my adapter doesnt support packet injection. So ive been trying to patch it as advised by the site, and have merely been having some issues with it.

    If it doesnt need a patch at all then would you care to explain why it wouldnt be able to support packet injection?

    If need be I can redo the test tommorow when I have more time and paste the results for you to see.

    Unlike many of the everyday scum pestering about stupid things to be spoonfed for trivial things I have a genuine curiosity and am considering going to a tech school and such. I dont particularily like asking for help but Im just rather stuck right now and if Im just completely on the wrong track then pointing me in the right one is far more beneficial. So until then ill review the link captaincrunch provided and see if I can't get it working that way.

  5. #5
    Jenkem Addict imported_wyze's Avatar
    Join Date
    Jul 2007
    Posts
    1,543

    Default

    This is a BackTrack support forum; the distro supports rtl8187 out of the box, so why do you feel the need to patch it??
    dd if=/dev/swc666 of=/dev/wyze

  6. #6
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default

    Because packet injection isnt working. I tried the aireplay-ng -1 wlan0 (the correct channel btw, I checked) and it results in 0/30 0%

    So while reading on how to to fix this I found sometwhere that suggested a patch and the person had later responded that it worked, so I tried the same method and it didnt even get the patch running. It was even a topic on here for some months back I believe, which lead me to think that it could work cause I had no prior reason to believe it wouldnt, im not very good or apt when it comes to hardware related issues x.x im so glad my laptop is a HP.

    So it is possible im just flatout wrong and missing something but I cant for the life of me figure out exactly what it is :/

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by madf0x View Post
    So it is possible im just flatout wrong and missing something but I cant for the life of me figure out exactly what it is :/
    Yeah you are missing something, and that is comprehending post's 3 and 5 above. The card works out of the box, that means no patch is required. If it does not work then that means you are doing something wrong or you may have another card/chipset then what you have posted above.
    im not very good or apt when it comes to hardware related issues x.x im so glad my laptop is a HP.
    This last little bit above will tell you a lot. If you are not able to do the basics and installing, configuring and deleting software is basic, then how do you expect to do the advanced "stuff". (Actually cracking wep is more like intermediate.)
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  8. #8
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    7

    Default

    well then maybe you should read the part about it not working properly. I do not have another chipset or adapter of the sorts. Just the one. Packet injection doesnt work and what I read said that I should get an rtl8187 patch from patches.aircrack-ng which I did, and have been having a tough time figuring out how to install it properly because so far what ive read has been irelevent/does not work. Hence why I came here, cause you know the whole being a support forum designed for such related issues.

    And it is also why, after reading several accounts of it working out of the box Ive been asking if someone could point out maybe something Ive overlooked/doing wrong, why packet injection isnt working and what not. And ya know i suppose i was just making a guess that the linux spirit of pointing people in the right direction when encountering an issue would apply to support forums as well.

    I understand the process of cracking wep and how the various programs essentially work, so while going through the process to understand it more fully before I move on into other areas I encountered an issue. I attempted to solve the issue with various guesses, searches, and googling, but it hasnt work, hence why I present my issue here. I dont understand why it seems so difficult for several people here to grasp that if my percieved solution is wrong that I simply request to be pointed towards a better more accurate solution, not essentially been told im an idiot for encountering an issue I havnt seen much anywhere else. I dont care if anyone thinks I am or even says I am but it would be...I dunno... NOT USELESS SPAM... to add in something more beneficial. So if Ive been wrong as several of you have repeatedly claim why not provide at LEAST direction to the answer?

    Because I UNDERSTAND it works out of the box cause guess what? I CAN conect to the internet with it and I CAN find essids, I perfectly understand this part. I just dont understand why packet injection wont work, once again being why I am here, presenting my issue, asking for advice.

    Jesus people >.>

  9. #9
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Your religion has nothing to do with it so leave the Jesus part out next time thanks.

    In addition you might want to post the output here of your injection test so that others can see it and maybe further help you out.
    Don't get upset because we tell you that you do not need a patch. Again I have had 2 cards with the same chipset and have never had a problem with them.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  10. #10
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    I had a rtl8187 and i could only get injection to work by unloading rtl8187 and loading r8187 on airdriver-ng.

    Mine wasn't the Real Alpha, so i couldn't inject with rtl8187 driver (don't know why, maybe because of the construction of the device??).

    Anyway, it wouldn't hurt to try...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •