Results 1 to 6 of 6

Thread: Atheros 928x with madwifi drivers, no wpa/wpa2-enterprise

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default Atheros 928x with madwifi drivers, no wpa/wpa2-enterprise

    Hi, first of all

    i'm proud to be a member of this great community

    So, i'm using Madwifi drivers, i've been 'testing' injection and wep cracking and my atheros ar928x works fine with it..
    The only problem i'm facing is i cant seem to connect to any wpa-enterprise network.

    At wicd it shows my school network WPA
    (at windows 7 i can connect to it, using WPA-TKIP, EAP, with no certificate)


    Everything else works fine... apart from WPA-Enterprise
    Any solutions ?



    Thanks again for this great community

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    Is your school part of the "eduroam" project?

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default

    Quote Originally Posted by Snayler View Post
    Is your school part of the "eduroam" project?
    Yes it is mate.
    I can connect to it using windows or fedora with default drivers :S
    But at BackTrack the WPA-Enterprise option doesnt even shows up for any network.

    After doing LIVE USB persistent mode, i've update kernel according to offensive-security site and installed madwifi drivers also...
    I'm able to inject and monitor too.

    Currently this is my WICD preferences:
    hxxp:///img50.imageshack.us/img50/7583/snapshot1a.png
    in the dropdown that has "wext" at the moment, i have other options like ndiswrapper, madwifi... etc but if i choose madwifi for eg, it wont allow me to connect to internet.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default

    Ok, i've found that i can connect to the network using:
    Quote Originally Posted by wpa_supplicant.conf
    network={
    ssid="eduroam"
    key_mgmt=WPA-EAP
    eap=PEAP
    phase2="auth-MSCHAPV2"
    identity="fcxxxx@alunos.xxx.xxxx"
    password="xxxxx"
    }
    and doing
    wpa_supplicant -i wlan0 -D wext -c wpa_supplicant.conf
    dhclient wlan0

    With this commands i was able to connect. But can't i use WICD to do that with GUI ? :S

  5. #5
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    Eduroam uses 802.1x (at least in my university), i've found out that you can use the following command:

    Code:
    root@pc# iwpriv ath0 authmode 3 <---- 802.1x authentication
    I see that you've sorted out how to connect to your network (now you can just create a script with the commands and use it to connect), but there are reports on the net that WICD works fine with the 802.1x protocol.I can't see for myself if this is true, but when I have the opportunity I'll test it at my university and I'll be back with the results as soon as I get them.

    BTW, Are you Portuguese?

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    16

    Default

    Quote Originally Posted by Snayler View Post
    Eduroam uses 802.1x (at least in my university), i've found out that you can use the following command:

    Code:
    root@pc# iwpriv ath0 authmode 3 <---- 802.1x authentication
    I see that you've sorted out how to connect to your network (now you can just create a script with the commands and use it to connect), but there are reports on the net that WICD works fine with the 802.1x protocol.I can't see for myself if this is true, but when I have the opportunity I'll test it at my university and I'll be back with the results as soon as I get them.

    BTW, Are you Portuguese?
    Yes, i am
    I just dont understand why WICD doesnt let me connect to any network if i chose "madwifi" in wpa_supplicant settings, instead of default wext.

    Please test it and report :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •