Results 1 to 10 of 10

Thread: GPS / Kismet in Backtrack

  1. #1
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    8

    Default GPS / Kismet in Backtrack

    I FINALLY got my usb wireless working in kismet by modifying some config but I also (obviously) want gps working if I possibly can.

    I do not get any specific hardware id#s running lspci/lsusb, it says "Prolific Technology, INC. PL2303 Serial Port". I beleive its the device because I ran a dmesg and it said it was on device /dev/ttyUSB0.
    I tried resetting serial interface and then "gpsd /dev/ttyUSB0" but it still says no gps found in kismet and I'm unsure how to test if there is any specific output on the port like I'd see in windows (eg. gps coordinates).

    I'm not "great" on linux... Actually been out of the game for about a year (give or take) so if anybody has an "idiots guide". According to gpsd its not compatible but its a simple serial interface. non-specific to any protocol, application, etc.. so it should work. If there is a howto I'd willing to try, I'm just not at all sure howto start and worse yet nothing on google specific, on debian sites or ubuntu docs

    I'd appreciate the help. please and thank you
    Geo

  2. #2
    Senior Member Thorn's Avatar
    Join Date
    Jan 2010
    Location
    The Green Dome
    Posts
    1,509

    Default

    Quote Originally Posted by freeballer View Post
    I FINALLY got my usb wireless working in kismet by modifying some config but I also (obviously) want gps working if I possibly can.

    I do not get any specific hardware id#s running lspci/lsusb, it says "Prolific Technology, INC. PL2303 Serial Port". I beleive its the device because I ran a dmesg and it said it was on device /dev/ttyUSB0.
    I tried resetting serial interface and then "gpsd /dev/ttyUSB0" but it still says no gps found in kismet and I'm unsure how to test if there is any specific output on the port like I'd see in windows (eg. gps coordinates).

    I'm not "great" on linux... Actually been out of the game for about a year (give or take) so if anybody has an "idiots guide". According to gpsd its not compatible but its a simple serial interface. non-specific to any protocol, application, etc.. so it should work. If there is a howto I'd willing to try, I'm just not at all sure howto start and worse yet nothing on google specific, on debian sites or ubuntu docs

    I'd appreciate the help. please and thank you
    Geo
    There are several different versions of gpsd floating around, so any advice may be a bit generic. First, try the "-h" option to see if there is some special argument that's needed for the version you're using. Secondly, try using the -V command ("Dump version and exit.") to see exactly which version you're using, and then search the web for the specifics of using that version .

    For example, the "-p" (port) argument is needed on the version of gspd that I commonly use, so my command looks like this:
    Code:
    gpsd -p /dev/ttyUSB0
    Running gpsd with a debug level (-D) of "2" or higher will dump out NMEA sentences to the console. While bad for actually running with kismet or another application, it should help you determine if the port is correct, or if there is some other error with either gpsd or the GPS receiver (GPSr).

    So to try it with mine, the command line looks like this:
    Code:
    gpsd -p /dev/ttyUSB0 -D 2
    Make sure that gpsd is using the default output port (2947), and that the kismet configuration is set to look at that port for the NMEA sentences.

    Here's the gpsd Home Page: GPSd — Put your GPS on the net! Looking through the documentation there may help, too.

    Another thing to consider is the settings on the GPSr itself. Make sure that the output matches what gpsd expects to see (baud rate, NMEA v2.1 or higher, etc.). Finally, many GPSr's will not output any NMEA sentences unless they have a clear view of at least 3 to 5 of the GPS satellites. Make sure that you're testing these things outside, and that the GPSr actually has at least a 2D lock.
    Thorn
    Stop the TSA now! Boycott the airlines.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    8

    Default tnxs

    thank you, I certainly have alot of "hacking" to do.. I'll be happy just to see the output through console, that way I know its heading in right direction. I'm also in a great possition where the satelite works inside the house.

    There are some questions in reguards to what you said, first will linux automatically check the port speed? (While fiddling in windows the baudrate had to be "38400") how do I match those settings in linux?

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Dragorn and Renderman mentioned newcore will work with gps'es directly, no screwing with broken gpsd.

    In kismet.conf scroll down to the gps settings, comment out gpstype=gpsd part and uncomment gpstype=serial, the uncomment the gpsdevice=/dev/ttyUSB0. <--- You'll have to edit that part, it starts out as gpsdevice=/dev/rfcomm I think.

  5. #5
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    8

    Default awesome

    You read my mind, I was lying here with a migrane thinking kismet.conf might have something there to work but hurt to much to duck around with it right now.. Course It would have taken alot of mucking around to get working so thank you that should save me alot of time -- and perhaps some sanity.

    Will report back even if working so they'll be yet another post to help out

  6. #6
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by freeballer View Post
    You read my mind, I was lying here with a migrane thinking kismet.conf might have something there to work but hurt to much to duck around with it right now.. Course It would have taken alot of mucking around to get working so thank you that should save me alot of time -- and perhaps some sanity.

    Will report back even if working so they'll be yet another post to help out
    As long as the gps works with nmea in the serial stream it will work. It's running that way on my desk right now.

  7. #7
    Very good friend of the forum TAPE's Avatar
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    599

    Default

    I have been kicking myself trying to get my setup to see my GPS device, but no go sofar..

    Have followed the above and have

    - modified the kismet.conf to have kismet use gpstype=serial and have commented out the gpsd.
    - modified the serial device to gpsdevice=/dev/ttyUSB0

    Otherwise have changed nothing.

    Kismet does not seem to pick up my usb GPS device, and I am wondering if I am pointing to the right source ?

    Any pointers on how I can check if the USB0 is correct ?

    Kismet is still advising that no GPS connected

    EDIT
    -----
    Have checked with dmesg as is advised on the kismet site.
    Output after plugging in the usb gps;

    Code:
    usb 4-1: new full speed USB device using uhci_hcd and address 4
    usb 4-1: configuration #1 from 1 choice
    cp2101 4-1:1.0: cp2101 converter detected
    usb 4-1: reset full speed USB device using uhci_hcd and address 4
    usb 4-1: cp2101 converter now attached to ttyUSB0
    So would appear that the ttyUSB0 is correct.

    When checking with lsusb as well, the device is mentioned OK.

    But still kismet is advising no GPS..

  8. #8
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by =TAPE= View Post
    I have been kicking myself trying to get my setup to see my GPS device, but no go sofar..

    Have followed the above and have

    - modified the kismet.conf to have kismet use gpstype=serial and have commented out the gpsd.
    - modified the serial device to gpsdevice=/dev/ttyUSB0

    Otherwise have changed nothing.

    Kismet does not seem to pick up my usb GPS device, and I am wondering if I am pointing to the right source ?

    Any pointers on how I can check if the USB0 is correct ?

    Kismet is still advising that no GPS connected

    EDIT
    -----
    Have checked with dmesg as is advised on the kismet site.
    Output after plugging in the usb gps;

    Code:
    usb 4-1: new full speed USB device using uhci_hcd and address 4
    usb 4-1: configuration #1 from 1 choice
    cp2101 4-1:1.0: cp2101 converter detected
    usb 4-1: reset full speed USB device using uhci_hcd and address 4
    usb 4-1: cp2101 converter now attached to ttyUSB0
    So would appear that the ttyUSB0 is correct.

    When checking with lsusb as well, the device is mentioned OK.

    But still kismet is advising no GPS..

    Is the gps getting a signal? From within kismet click on window then gps details. It should show you the satellite signals the gps is receiving. You might just not be getting enough signal for a lock.

  9. #9
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    8

    Default what I did

    after trying gpsserial what I did is rebooted and thus making all files back using default "gpsd" but changed the tty to /dev/ttyUSB0 just in case

    Install "MiniCom" also if you want to make sure is working correctly.

    Went into minicom (please use ctrl+a->z to see the help menu)
    I hit "o" for options on modem. I changed the tty to "ttyUSB0" and I had to change the speed/baud to "38400" <-- make sure its matching yours
    while leaving the options select "save setup as df1" (default one)

    then I excited and reset "x" and reopened minicom, initialized modem "i" (if not done). You should see the nmea/gps info scrolling in the screen. If not something is wrong. Maybee the speed or communications.

    serial speed can also be set on device by "stty -F /dev/ttyUSB0 38400"

    if you have no issues at that point. I opened gpsd

    "gpsd /dev/ttyUSB0"

    now gps is working on all programs supporting gpsd, including xgps, kismet


    hope this helps

    (I think the gps is simply not recognized, instead of not good signal because a) mine works indoors b) I got a seperate msg [that I don't remember] when signal was poor)

  10. #10
    Very good friend of the forum TAPE's Avatar
    Join Date
    Jan 2010
    Location
    Europe
    Posts
    599

    Default

    thanks for the above replies guys, will be trying it out tomorrow and will be reverting !

    Reverting
    =========

    Well I never did manage to get it working without using gpsd..

    I tried leaving it running for a while (10 min) but still no advice of any connection.. As far as I could tell all the configs were
    OK.

    I did get it working fine, but then simply using gpsd.

    So only adjusting the kismet.conf file to point to; /dev/ttyUSB0 and that was it.

    Started with
    Code:
    gpsd /dev/ttyUSB0
    Then when running Kismet with the GPS connected, it literally only took a matter of seconds for it to start showing up the GPS info..

    Anyways I might try the serial connection lateron, but for now it works with gpsd, mapping now back in progress
    so I wont complain !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •