Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: airodump-ng help

  1. #1
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    16

    Default airodump-ng help

    I was going to play around with my wireless since I hadn't done any wireless cracking, or even tried to do any wireless cracking, with my HP netbook. So I opened up a terminal and this is what I got.

    Code:
    root@HP-Mini:~# airmon-ng start eth0
    
    
    Interface       Chipset         Driver
    
    eth0            Unknown                 wl (monitor mode enabled)
    
    root@HP-Mini:~# airodump-ng eth0
    ioctl(SIOCSIWMODE) failed: Invalid argument
    
    ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make sure RFMON is enabled: run 'airmon-ng start eth0 <#>'
    Sysfs injection support was not found either.
    I'm not too sure what exactly I'm supposed to do here. BT4 is still kind of new to me although I use it as my netbook's primary OS. I'm positive that eth0 is my wireless interface, since wireless is all I use for my netbook, and this is the first time I've seen any Linux distro call a wireless interface by eth0. Could that be part of my problem?

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default

    eth0 is the ethernet interface...

  3. #3
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    16

    Default

    Quote Originally Posted by Snayler View Post
    eth0 is the ethernet interface...
    That's exactly why I think it's the problem. How would I go about changing it to wifi0 or something like that? I've done it before with Fedora but I don't remember how and I'm sure even if did remember, it would still be different.

  4. #4
    Member mixit's Avatar
    Join Date
    Jan 2010
    Posts
    104

    Default

    Type

    ifconfig

    to see what interfaces are available. One of them should be your wireless interface if everything is configured properly. I believe the name of it changes based on your wireless card. Mine for example appears as wlan0. If you cant figure it out, post the output of ifconfig here, and someone will be able to assist you further. Once you have identified it, you can try something like

    airmon-ng start <enter wifi interface>

    This will create a new interface called mon0, which is your interface that you can now use to monitor wireless networks. You could then go on to type

    airodump-ng mon0

    to get information about the wireless networks within range of your computer.

    Hopefully that will get you started. Look around the forum for tutorials on using these tools. Also, if you google any of those tools, you will find plenty of information on them.

  5. #5
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    16

    Default

    This is what I get from ifconfig while I'm connected to my wireless network:
    Code:
    root@HP-Mini:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:25:56:5c:71:8a
              inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::225:56ff:fe5c:718a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:194 errors:0 dropped:0 overruns:0 frame:460
              TX packets:155 errors:10 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:106675 (106.6 KB)  TX bytes:30083 (30.0 KB)
              Interrupt:16 Base address:0xc000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:200 (200.0 B)  TX bytes:200 (200.0 B)
    And this is my iwconfig output:
    Code:
    root@HP-Mini:~# iwconfig
    lo        no wireless extensions.
    
    eth0      IEEE 802.11bg  ESSID:"Belkin_Pre-N_647504"  Nickname:""
              Mode:Managed  Frequency:2.412 GHz  Access Point: 00:11:50:CF:9C:16
              Bit Rate=54 Mb/s   Tx-Power:32 dBm
              Retry min limit:7   RTS thr:off   Fragment thr:off
              Power Managementmode:All packets received
              Link Quality=5/5  Signal level=-35 dBm  Noise level=-89 dBm
              Rx invalid nwid:0  Rx invalid crypt:30  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

  6. #6
    Member mixit's Avatar
    Join Date
    Jan 2010
    Posts
    104

    Default

    That's strange that your wireless is showing up as eth0. I'm no Ubuntu guru, but I'll try and read up on the issue. Maybe one of the more experienced members can shed some light on this.

  7. #7
    Senior Member kidFromBigD's Avatar
    Join Date
    Jan 2010
    Location
    Texas
    Posts
    159

    Default

    This is a strange problem. Your HP Netbook has a dedicated ethenet port and WiFi, correct? I looked online and most HP netbooks have both.

    Try shutting down the WiFi, and then turning it back on with these commands:
    Code:
    airmon-ng stop eth0
    airmon-ng start eth0
    And then doing the iwconfig command after that. Report back here...
    You. Are. Doing. It. Wrong.
    -Gitsnik

  8. #8
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    16

    Default

    Quote Originally Posted by kidFromBigD View Post
    This is a strange problem. Your HP Netbook has a dedicated ethenet port and WiFi, correct? I looked online and most HP netbooks have both.
    Yeah, mine has both an ethernet port and WiFi. Here's the different commands you told me to try:

    Code:
    root@HP-Mini:~# airmon-ng stop eth0
    
    
    Interface       Chipset         Driver
    
    eth0            Unknown                 wl (monitor mode disabled)
    Code:
    root@HP-Mini:~# airmon-ng start eth0
    
    
    Interface       Chipset         Driver
    
    eth0            Unknown                 wl (monitor mode enabled)
    Code:
    root@HP-Mini:~# iwconfig
    lo        no wireless extensions.
    
    eth0      IEEE 802.11bg  ESSID:""  Nickname:""
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
              Bit Rate:54 Mb/s   Tx-Power:32 dBm
              Retry min limit:7   RTS thr:off   Fragment thr:off
              Power Managementmode:All packets received
              Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

  9. #9
    Senior Member kidFromBigD's Avatar
    Join Date
    Jan 2010
    Location
    Texas
    Posts
    159

    Default

    Ok, I'm truly stumped here.

    BT4 should distinguish between your Netbook's wired ethernet port and its WiFi port. Clearly it is not doing this. It may be a limitation of the tools or the Linux kernel, I cannot be sure. If anybody else has the same kind of Netbook, please try this out.

    You are left with seemingly one option: Find yourself an external USB WiFi dongle, plug it in, and see if iwconfig recognizes it. Then the airmon-ng stop and start commands should work, and you should make some progress.

    Sorry I cannot be more helpful. Truly a strange problem.
    You. Are. Doing. It. Wrong.
    -Gitsnik

  10. #10
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    16

    Default

    I have a USB card laying around here somewhere. I don't think BackTrack supports it though. Actually, I don't think I've seen any distro that supports it. I'll test it out and report back.

    EDIT: I did some reading around real quick on wireless with BackTrack. The thing I was reading said that even though eth0 is usually dedicated to your wired port, it sometimes is used for your wireless card and that the name your card gets is based on your chipset. It then gave a few examples of various names for wireless cards that you might see. Since iwconfig shows "IEEE 802.11bg" that would mean that it recognizes eth0 as wireless, right? I'm no expert though so I'm just taking a guess here.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •